Windows 10: File Explorer crashes attempting file operations, on network drives

Discus and support File Explorer crashes attempting file operations, on network drives in Windows 10 Support to solve the problem; Hi This is another FileExplorer crash post - however this one slightly different than others I could find, and the solutions for the others has not... Discussion in 'Windows 10 Support' started by Sharza, Jan 31, 2017.

  1. Sharza Win User

    File Explorer crashes attempting file operations, on network drives


    Hi

    This is another FileExplorer crash post - however this one slightly different than others I could find, and the solutions for the others has not provided a solution either.

    Long story short - upon attempting file operations on mapped network drives - e.g. rename file, delete file, copy file, create a new file through explorer, results in a crash and restart (of explorer that is - not the pc).

    What I know:

    1.
    The crash seems unrelated to the operation itself. Reasoning behind this conclusion:

    - Just selecting a file, and pressing shift+delete triggers the crash (at the point, where a "are you sure" dialog should be presented)
    - During a test, I deleted a file from another PC, in the folder currently in focus - this triggers an update of the view, and this in turn crashed the Explorer (on the problem pc, everything worked out nicely on the other pc used for testing).

    2.
    It is only operations on files on network shares mapped with a drive letter that fails.

    - Local files does not trigger the crash
    - If I subst the directory to a local drive letter, the crash is not triggered.
    - If I access the shared directory directly through the UNC path (e.g. \\domaindfs\share\path) instead of through the mapped drive letter (which btw. is mapped to the exact same location) the crash is not triggered. (And this is seriously weird stuff).

    The network shares are all accessed through a domain-dfs, hosted on Windows Server 2012 R2, however there is only one target in the namespace - thus the destination share location is always the same.

    3.
    This machine is an in-place upgraded Windows 10, from Windows 7

    4.
    Historically I've experienced another issue, related to Quick Access on this particular pc. If any file (any at all) was created/modified on a network location, path+filename length more than approx 235 chars, it would result in an invalid reference being created in Quick Access, causing explorer to crash instantly when opened, unless opened with a specific directory as target (so that Quick Access did not show) - If Quick Access was later selected, the crash was triggered.

    Now this particular issue was resolved with an Adobe Reader upgrade - but then this one has occured instead.


    What I've Tried:

    1.
    Disable basicly all Shell Extensions.

    2.
    Chkdsk, SFC, various Dism commands - all the standard troubleshooting jazz.

    3.
    Remap network drives, and testing all kind of various combinations of permissions, both NTFS and Share permissions.

    4.
    Using another user on the same PC, recreate user profile - no dice.

    5.
    Removing Windows updates quite a while back, uninstalling/reinstalling various applications.

    6.
    Tracing with Process Monitor and WinDbg.

    7. Probably much more I simply cant remember.


    I have already decided to install a fresh OS on a new workstation, to get rid of any upgrade artifacts and whatever - however I am puzzled, and hoping for some bright ideas, as to why this happens - because quite frankly - I'm all out of ideas here.

    It seems to be related to the drive mapping somehow, but why I cannot figure.

    Any ideas of any kind?

    Thanks in advance.

    -

    :)
     
    Sharza, Jan 31, 2017
    #1

  2. File Explorer has gone crazy after last nights upgrade.

    My only has icons instead of full descriptions. I can not get back to a point where I have tabs that actually say something. Please tell me how to get my view repaired? help... Help.... HELP!!!
     
    File Explorer, Jan 31, 2017
    #2
  3. JeffEpp Win User
    [BUG] File Explorer preforming file operations on whole directories, rather than specified files!

    This has happened to me now, on two different computers. I selected a number of files to have an operation done on, in one case deletion, and the other copy, only to have File Explorer begin to do this for the entire parent directory! And, when I say parent,
    I mean the top level, not the several levels where things where suppose to be happening. Also note, that in both cases, external USB drives were in use, though of two different kinds and manufactures.

    Most recently, I was copying a couple of files to another directory, by drag and drop. That was an easy fix, and I was able to stop it before it went to far. But, the previous time was a deletion of some redundant files, on a thumb drive (ie no Recycle Bin).
    I was able to recover all the lost files, through a combination of backups and file recovery software. But, this was a "working drive", and I could have lost work that had not yet been backed up, and I lost a great deal of working time to do the recovery.

    I have no method of troubleshooting this, but I have a guess at what is roughly happening. Somehow, behind the GUI, the file command string is being truncated following the first directory in the string. So, "H:\Documents\foo\bar\dummy.txt" is cropped to
    just "H:\Documents\", and the file ops specified are carried out for everything.

    I am not looking for help, rather I am trying to pass on a bug to those who may be able to fix this. And, I hope that someone else will be able to recognize what is happening, when this hits them, and take the steps to minimize the results for themselves.
     
    JeffEpp, Jan 31, 2017
    #3
  4. Sharza Win User

    File Explorer crashes attempting file operations, on network drives

    No one even remotely has any input to this?
     
    Sharza, Feb 10, 2017
    #4
  5. RolandJS Win User
    I hope you have recent backups of your OS partition. My experience with Windows 8, let alone 10, was once the file explorer [explorer.exe, correct?] imploded or exploded, I was forced to either do a restore of an earlier OS partition or reinstall Windows from scratch. I hope you have much better success than I did.
     
    RolandJS, Feb 10, 2017
    #5
  6. Sharza Win User
    No there is no backup, and its not really needed. I did install a new client with a fresh OS - I still have the buggy workstation here, which I want to troubleshoot out of pure curiosity, because quite frankly this issue is just too weird - i'd hoped someone had something to put on the table which could point me in the right direction, because even tho' I feel quite capable, I must admit defeat for now, which is an upleasant feeling *Wink and Im trying to avoid that *Wink
     
    Sharza, Feb 10, 2017
    #6
  7. dalchina New Member
    Have you looked at your event log?

    Is trying in safe mode with networking any use? (I've no idea whether some necessary services etc might not be running).
    Failing that a clean boot?
    - that's just trying to establish a working scenario, then elimination, part of which you've tried as listed above.

    I also seem to recall some having success with explorer crashes by clearing or resetting Quick Access.
     
    dalchina, Feb 10, 2017
    #7
  8. Sharza Win User

    File Explorer crashes attempting file operations, on network drives

    Hi dalchina

    Thanks for chiming - let's make a quick breakdown:

    - Eventlog: yup - first thing done, and continuously monitored, however information extremely sparse, basicly only the Dr. Watson generated one - Application Crash, module explorer.exe blablabla...

    - Safe mode: no dice changes nothing. I'm pretty sure I'm in the deep with something in HKCR somewhere.

    - Clean boot: well... honestly no, I did not disable any services, and didn't think it a viable option, as safe mode bails on me as well - but it could be worth a try, even tho' I seriously doubt it should be any good at all.

    - Resetting Quick Access: had some effect in the earlier scenario, but not this one - and this one happens outside of the view of Quick Access. One may even open the same file that makes Explorer crash if trying to delete/move/etc ... with no issues at all. Talk about schizophrenic behavior.

    One thing springs to mind I've failed to do - removing the Antivirus software on the machine to see if it changes anything. I might try that sometime next week if I get the chance.

    Thanks for your input - its appreciated!

    -
     
    Sharza, Apr 4, 2018
    #8
Thema:

File Explorer crashes attempting file operations, on network drives

Loading...
  1. File Explorer crashes attempting file operations, on network drives - Similar Threads - File Explorer crashes

  2. Windows Explorer specifically file explorer Crashing when Attempting to Eject a USB Drive

    in Windows 10 Drivers and Hardware
    Windows Explorer specifically file explorer Crashing when Attempting to Eject a USB Drive: Hello, I was encountering a strange problem where I was in File Explorer trying to eject a plugged in USB device. I tried to right click the device, and it stopped responding and crashed. After it started doing this every single time, I realized there was a bit of a...
  3. File Explorer crashes

    in Windows 10 Network and Sharing
    File Explorer crashes: Split from this thread. I have the same problem. First I upgrade from Windows 7 Home to Windows 10 Home using the MS Upgrade Assistant. After the Upgrade the computer worked fine but very slow, so I cloned the HDD to a SSD. The first boot with the SSD failed so I had to...
  4. Network drive extremely slow and crashes file explorer

    in Windows 10 Network and Sharing
    Network drive extremely slow and crashes file explorer: Hi ive installed a nas and Im on windows 10 1909, the nas will take a very long time to open in file explorer as when first connected to the network it will not show how much storage is in it till you open it. When you can then open a document this sometimes can take 20...
  5. File Explorer Crashes

    in Windows 10 BSOD Crashes and Debugging
    File Explorer Crashes: File Explorer stops responding every single time I try to navigate to and open a document. I have just spent 4 horrible hours with tech support from both Microsoft and Lenovo who both want to charge me to fix this. It can't be this hard. So far, they have suggested that I...
  6. File Explorer Crashes

    in Windows 10 Installation and Upgrade
    File Explorer Crashes: I just got the latest Windows 10 update and now File Explorer crashes. If I double-click a file to open it, then it does not respond. If I right-click a file, it does not respond. This happened to me before I I wiped my computer clean and reinstalled Windows. I do not want to...
  7. File Explorer Crash

    in Windows 10 BSOD Crashes and Debugging
    File Explorer Crash: I can't open it and I can not do anything. https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/file-explorer-crash/c7cfbc10-affd-4e22-828f-d70429c6c910
  8. Network File Copies and Moves Crash File Explorer

    in Windows 10 Network and Sharing
    Network File Copies and Moves Crash File Explorer: Everytime I try to move or copy any files from a mapped network share, it crashes out the file explorer. Anyone have any ideas on what can be causing this? The OS is Windows 10 Pro, the network share is on a Synology NAS box. Thank you 70147
  9. File Explorer Crashing

    in Windows 10 Support
    File Explorer Crashing: Hello, so i am trying to open file explorer on my laptop from the start menu and where it is pinned on the start menu. When i do this, file explorer opens for a couple of seconds and closes on both. When this happens, I also hear the hard drive make a noise inside. I can...
  10. file explorer crashes

    in Windows 10 Support
    file explorer crashes: Hey guys, pretty new here.. Been trying all night to fix this but haven't had any luck so far. Couple problems that I'm pretty sure are related somehow? The first is that file explorer is constantly crashing. It crashes when I try to go to file explorer properties, and...