Windows 10: Photoshop edit BSOD IAsTORa.SYS

Discus and support Photoshop edit BSOD IAsTORa.SYS in Windows 10 BSOD Crashes and Debugging to solve the problem; Hello, I a have been having app crash issues with Adobe LR6 for the last week or so. Today, while in Photoshop CS6, editing an image , I received a... Discussion in 'Windows 10 BSOD Crashes and Debugging' started by Russ85, Jun 7, 2017.

  1. Russ85 Win User

    Photoshop edit BSOD IAsTORa.SYS


    Hello,
    I a have been having app crash issues with Adobe LR6 for the last week or so. Today, while in Photoshop CS6, editing an image , I received a BSOD; iaStorA.sys..... Any help is appreciated!

    :)
     
    Russ85, Jun 7, 2017
    #1
  2. jkP0 Win User

    iaStorA.sys BSOD

    Thanks for your suggestion. I have already updated the drivers and i checked it again from Lenovo and Intel pages.
     
    jkP0, Jun 7, 2017
    #2
  3. StamosK Win User
    NTOSKRNL.EXE

    Thanks for the response. Unfortunately, there is still a problem. Here's the latest:

    1. I updated the driver for iaStorA.sys from the Intel site. The driver now has a Driver Date of 2/3/2016 and a version number 14.10.0.1016.

    2. I got two more BSOD's. The minidumps have been uploaded in onedrive in folder BSOD-2, here is the link: OneDrive

    3. After I got the latest BSOD, I run driver verifier on iastora.sys. The verifier did not report any issue and the system booted normally.

    I see the windbg suspects iastora.sys, but there must be something else going on. May be better luck this time? Thanks again.
     
    StamosK, Jun 7, 2017
    #3
  4. Spectrum Win User

    Photoshop edit BSOD IAsTORa.SYS

    Hi Russ,

    I don't see any crash dumps in the folder you attached. Is anything in C:\Windows\Minidump, or does C:\Windows\MEMORY.DMP exist?

    If iaStorA.sys is indeed the problem, I see you are running version 14.5.0.1081 of the Intel Rapid Store driver (iaStorA.sys). The latest upstream release from Intel is 15.5.0.1051 and the last release Dell approved is 12.6.0.1033. I would suggest installing either of those versions.

    Intel's latest release

    Last release approved by Dell
     
    Spectrum, Jun 7, 2017
    #4
  5. Russ85 Win User
    Thanks "Spectrum" for the reply. Before I attempt updates from either IBM or Dell please review the attached dump file (hope it works this time);

    Thanks,
    Wayne
     
    Russ85, Jun 7, 2017
    #5
  6. Spectrum Win User
    Wayne,

    The dump file appears to be corrupted, but that would be in line with a problem occurring in the storage subsystem, and iastorA.sys is the intel RAID driver. I would strongly suggest updating your Rapid Store driver, and if problems continue, running HDTune to check your hard drive's health.

    Code: *** Memory manager detected 1 instance(s) of corrupted pagefilepage(s) while performing in-page operations. Memory Manager detected corruption of a pagefile page while performing an in-page operation.The data read from storage does not match the original data written. This indicates the data was corrupted by the storage stack, or device hardware.[/quote]
    Looking at the event logs there is more evidence of a problem in your storage subsystem.

    Namely, there are 55 occurrences of the driver having to reset the raid controller. Resets generally occur when the driver encounters an error and attempts to recover from it.

    Code: Log Name: System Source: iaStorA Event ID: 129 Task: N/A Level: Warning Opcode: N/A Keyword: Classic User: N/A User Name: N/A Computer: XPS8700 Description: Reset to device, \Device\RaidPort0, was issued.[/quote]
     
    Spectrum, Jun 7, 2017
    #6
  7. BSODHunter, Jun 7, 2017
    #7
  8. Photoshop edit BSOD IAsTORa.SYS

    Bad block found via windows event log too:

    Code: 2017-05-22T18 18:11.709 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-05-23T18 18:06.178 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-05-24T18 18:13.097 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-05-26T15 34:44.939 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-05-29T18 18:19.609 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-05-31T18 18:29.406 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-06-01T18 18:05.668 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-06-03T18 18:05.289 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-06-04T18 18:42.338 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-06-05T18 18:23.128 Error: The device, \Device\Harddisk1\DR1, has a bad block. 2017-06-06T18 18:22.662 Error: The device, \Device\Harddisk1\DR1, has a bad block.[/quote]
    After u installed another controller driver u should check your disks:




    Photoshop edit BSOD IAsTORa.SYS [​IMG]
    Diagnostic Test
    Photoshop edit BSOD IAsTORa.SYS [​IMG]
    HDD TEST

    Photoshop edit BSOD IAsTORa.SYS [​IMG]
    Run HDTune to check health and scan for errors.


    Photoshop edit BSOD IAsTORa.SYS [​IMG]



    Photoshop edit BSOD IAsTORa.SYS [​IMG]
    Note It may take some time, but look for signs of any errors or failure.

    You can also run a disk check using chkdsk. Refer to the tutorial for details of how to do this.
     
    BSODHunter, Jun 7, 2017
    #8
  9. Russ85 Win User
    Spectrum & BSODHunter,

    Many thanks for your assistance! So far I have changed the system dump collection from automatic to kernel. I ran the dump file collector again and the size of the file changed slightly but not sure there is any new relevant information. See file attached. I also updated the Intel Rapid Store Driver as requested to ver 15.5.0.1051. I will run HD Tune next...........

    Wayne
     
    Russ85, Jun 7, 2017
    #9
  10. Code: 0x0000001A: MEMORY_MANAGEMENT (8.06.2017 03:38:10) [Windows 10] CAUSED BY: memory_corruption PROCESS: MemCompression Usual causes: Device driver, memory, kernel[/quote]
    I say disk or RAM memory. First step should be checking the disk. Second would be checking the RAM with memtest
     
    BSODHunter, Jun 7, 2017
    #10
  11. Spectrum Win User
    Wayne,

    To be clear, since updating the Rapid Store driver, have you encountered anymore BSODs? I'd echo BSODHunter's advice, run HDTune anyways to rule out a failing disk.
     
    Spectrum, Jun 7, 2017
    #11
  12. Russ85 Win User
    OK, I scanned the disc (C*Smile and it did find issues and did a repair and a restart. I re-ran the check disc and no errors were found. Should I still check the RAM with memtest?
     
    Russ85, Jun 7, 2017
    #12
  13. Russ85 Win User

    Photoshop edit BSOD IAsTORa.SYS

    Spectrum, I have downloaded the trial version of HDTune but have not run it yet. I have received no more BSOD's since updating the Intel software and repairing the main disc.
     
    Russ85, Jun 7, 2017
    #13
  14. Russ85 Win User
    I ran HD Tune, files attached.
     
    Russ85, Jun 8, 2017
    #14
  15. Then, maybe, the drivers was the cause
     
    BSODHunter, Jun 8, 2017
    #15
Thema:

Photoshop edit BSOD IAsTORa.SYS

Loading...
  1. Photoshop edit BSOD IAsTORa.SYS - Similar Threads - Photoshop edit BSOD

  2. BSOD L1C63x64.sys

    in Windows 10 BSOD Crashes and Debugging
    BSOD L1C63x64.sys: Heya guys, this is my first post here *Smile. I just had like 3 or 4 BSODs in these last two days, never had any. I just updated my Atheros 8151 PCI-e driver from Network adapter->properties->update driver. I'm not sure if it is the cause, so I used the tool and attached...
  3. BSOD featuring dxgmms2.sys

    in Windows 10 BSOD Crashes and Debugging
    BSOD featuring dxgmms2.sys: Got another BSOD earlier tonight, this time with dxgmms2.sys cited onscreen. 85143
  4. BSOD when starting Photoshop

    in Windows 10 BSOD Crashes and Debugging
    BSOD when starting Photoshop: Good evening all! I have a nasty problem with my laptop. In this case an Asus N750jk with an 850 evo SSD as primary drive. When I got the laptop the original windows 8.1 was installed and I installed an SSD using the samsung migration software. No problems. I installed...
  5. BSOD with Photoshop

    in Windows 10 BSOD Crashes and Debugging
    BSOD with Photoshop: I've had Photoshop CC 2014 since I've had my laptop (around 6 months), and it worked fine up until around a week ago. I launched it last week, and it opened the loading up screen, and before it was over, I got a BSOD with the error KERNEL_SECURITY_CHECK_FAILURE I've...
  6. BSOD blaming L1C63x64.sys

    in Windows 10 BSOD Crashes and Debugging
    BSOD blaming L1C63x64.sys: Like many others I am the victim of this, it happens more than once a day. It never happened on windows 8.1. At Toshiba's request, I have back-dated my driver to the one that Windows installs with windows 10. I am hoping this fixes the issue, if not, here's my dump 58971
  7. wdf01000.sys BSOD

    in Windows 10 BSOD Crashes and Debugging
    wdf01000.sys BSOD: Hey, this is more of a question. My keyboard has been malfunctioning due to liquid damage, so to disable it I installed an incompatible keyboard/touchpad driver intentionally. The day after, I've been getting wdf01000.sys BSOD errors during startup, which brings me to a...
  8. Frequent BSODs - L1C63x64.sys

    in Windows 10 BSOD Crashes and Debugging
    Frequent BSODs - L1C63x64.sys: Since upgrading to Windows 10 I am getting frequent BSODs with DRIVER_IRQL_NOT_LESS_OR_EQUAL in L1C634x64.sys especially when the network is loaded (heavy bit torrent activity) Googling has led me to believe that it is problems lies with my Atheros driver so I have updated...
  9. BSOD tdr_failure_igdkmd64.sys

    in Windows 10 BSOD Crashes and Debugging
    BSOD tdr_failure_igdkmd64.sys: I have been encountering this error frequently when running games, mostly World of Tanks and the World of Warships beta test. I ALWAYS get this error whenever I accidentally bump the windows key on my laptop in game. If I am at the port or garage screen with all my ships,...
  10. BSOD iaStorA / ntoskrnl.exe+142480

    in Windows 10 BSOD Crashes and Debugging
    BSOD iaStorA / ntoskrnl.exe+142480: Hello, I am consistently getting a BSOD once a day with my machine. I've tried as many things as I could and can't seem to get it solved. System is a Alienware 15 R2, I swapped the 1TB HGST drive for a Samsung 850 EVO 2TB at the user drive. Main OS drive is factory installed...
Tags: