Windows 10: Problem: "Ethernet doesn't have a valid IP configuration" Lenovo

Discus and support Problem: "Ethernet doesn't have a valid IP configuration" Lenovo in Windows 10 Network and Sharing to solve the problem; Dear Tenforums users, I have recently encountered some problems wth my relatively new Lenovo IdeaPad laptop; whenever I try to connect to the... Discussion in 'Windows 10 Network and Sharing' started by esmorax, Nov 7, 2016.

  1. esmorax Win User

    Problem: "Ethernet doesn't have a valid IP configuration" Lenovo


    Dear Tenforums users,

    I have recently encountered some problems wth my relatively new Lenovo IdeaPad laptop;
    whenever I try to connect to the internet using ethernet it tells me that "Ethernet doesn't have a valid IP configuration"

    I have the Realtek PCIe GBE family controller as my ethernet device.

    I have browsed the internet about it and tried to update the ethernet driver via device manager. However, even after doing that, nothing has changed. I am currently using Wifi, but at my work location the connection via WLAN is very... bad.

    I hardly have any knowledge about drivers and BIOS and stuff. I hope that anyone amongst you is able and willing to help me out in this matter!

    I sincerely thank you all for your time!

    Yours,



    :)
     
    esmorax, Nov 7, 2016
    #1

  2. Windows 10 Update of 09/22/2016 Disconnected my Network Drives

    Diagnosis reports: "Ethernet doesn't have a valid IP configuration." There's no support offered for how to get a "valid IP configuration".
     
    JoeHudak Jr., Nov 7, 2016
    #2
  3. Ethernet doesn't have a valid IP configuration

    Recently I have found myself unable to connect to the internet with an ethernet cable. The connection is an "Unidentified network" and the troubleshooter tells me "'Ethernet' doesn't have a valid IP configuration." I encountered this very problem a few
    months ago with Windows 7, and upgrading to Windows 10 seemed to work after a couple of days.
     
    Seamus O'C, Nov 7, 2016
    #3
  4. Samuria Win User

    Problem: "Ethernet doesn't have a valid IP configuration" Lenovo

    open a cmd prompt then type ipconfig /all post results
     
    Samuria, Nov 8, 2016
    #4
  5. esmorax Win User
    Dear Samuria,

    As requested the ipconfig/all results:

    Windows IP Configuration Host Name . . . . . . . . . . . . : Kevin-Lenovo Primary Dns Suffix . . . . . . . : Node Type . . . . . . . . . . . . : Hybrid IP Routing Enabled. . . . . . . . : No WINS Proxy Enabled. . . . . . . . : No DNS Suffix Search List. . . . . . : HomeEthernet adapter Ethernet: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller Physical Address. . . . . . . . . : 54-EE-75-7D-B1-C2 DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : YesWireless LAN adapter Local Area Connection* 2: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter Physical Address. . . . . . . . . : E0-94-67-40-30-EA DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : YesWireless LAN adapter Wi-Fi: Connection-specific DNS Suffix . : Home Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 3165 Physical Address. . . . . . . . . : E0-94-67-40-30-E9 DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : Yes Link-local IPv6 Address . . . . . : fe80::f8fc:7f2e:3127:b684%5(Preferred) IPv4 Address. . . . . . . . . . . : 192.168.1.20(Preferred) Subnet Mask . . . . . . . . . . . : 255.255.255.0 Lease Obtained. . . . . . . . . . : dinsdag 8 november 2016 23:09:47 Lease Expires . . . . . . . . . . : woensdag 9 november 2016 23:36:18 Default Gateway . . . . . . . . . : 192.168.1.1 DHCP Server . . . . . . . . . . . : 192.168.1.1 DHCPv6 IAID . . . . . . . . . . . : 65049703 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-E0-1A-61-54-EE-75-7D-B1-C2 DNS Servers . . . . . . . . . . . : 192.168.1.1 NetBIOS over Tcpip. . . . . . . . : EnabledEthernet adapter Bluetooth Network Connection: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Bluetooth PAN HelpText Physical Address. . . . . . . . . : E0-94-67-40-30-ED DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : YesTunnel adapter Teredo Tunneling Pseudo-Interface: Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6abd:386b:30f2:3f57:feeb(Preferred) Link-local IPv6 Address . . . . . : fe80::386b:30f2:3f57:feeb%14(Preferred) Default Gateway . . . . . . . . . : :: DHCPv6 IAID . . . . . . . . . . . : 402653184 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-E0-1A-61-54-EE-75-7D-B1-C2 NetBIOS over Tcpip. . . . . . . . : DisabledTunnel adapter isatap.Home: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Home Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3 Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes
     
    esmorax, Nov 8, 2016
    #5
  6. Been having the same issue after applying an update today. Been going crazy for two hours now trying to resolve. In for a fix!
     
    masterhail, Nov 8, 2016
    #6
  7. Samuria Win User
    When you did that was there a network cable plugged in as it show its disconnected so if it was plugged in does it show a light on the router to show the cable is ok?
     
    Samuria, Nov 8, 2016
    #7
  8. esmorax Win User

    Problem: "Ethernet doesn't have a valid IP configuration" Lenovo

    I rebooted my PC after first deinstalling the Ethernet driver (for the 2nd time) and doing a clean install of the driver downloaded from Lenovo site. I also rebooted the router at that time. WHen I plugged in the cable it was FINALLY recognized and I managed to get a connection!

    I hope it will stay working now! Will post if I encounter new issues! Thanks for your comments and help!

    -
     
    esmorax, Apr 5, 2018
    #8
Thema:

Problem: "Ethernet doesn't have a valid IP configuration" Lenovo

Loading...
  1. Problem: "Ethernet doesn't have a valid IP configuration" Lenovo - Similar Threads - Problem Ethernet doesn't

  2. "Ethernet" doesn't have a valid IP configuration

    in Windows 10 Network and Sharing
    "Ethernet" doesn't have a valid IP configuration: Problem: intermittent no internet connectivity Running network troubleshooter gives me the error message: "Ethernet" doesn't have a valid IP configuration My system Toshiba satellite laptop S75 hardwire to a personal modem arris sb6141, my ISP is Comcast xfinity. No router....
  3. Ethernet doesn't have a valid IP configuration

    in Windows 10 Network and Sharing
    Ethernet doesn't have a valid IP configuration: I do not have internet connection to my desktop computer (Windows 10). It is connected to my router using Ethernet cable. Network Connections is shows my Ethernet and then under that it says Unidentified network. I ran the trouble shooter and it gives me Ethernet doesn't...
  4. "Ethernet" doesn't have a valid IP configuration

    in Windows 10 Network and Sharing
    "Ethernet" doesn't have a valid IP configuration: Problem: intermittent no internet connectivity Running network troubleshooter gives me the error message: "Ethernet" doesn't have a valid IP configuration My system Toshiba satellite laptop S75 hardwire to a personal modem arris sb6141, my ISP is Comcast xfinity. No router....
  5. Ethernet doesn't have a valid IP configuration

    in Windows 10 Network and Sharing
    Ethernet doesn't have a valid IP configuration: Suddenly my internet stopped working and windows is giving me this error. I already did reset winsock, ip, tcp, nbtstat -R, nbtstat -RR and everything i could find out there. My network adapter is probably not the problem since i can ping localhost fine. Drivers are up...
  6. ethernet doesn't have valid ip configuration

    in Windows 10 Network and Sharing
    ethernet doesn't have valid ip configuration: IPv6 DNS servers: fec0:0:0:ffff::1%1 fec0:0:0:ffff::2%1 fec0:0:0:ffff::3%1 Manufacturer: Realtek Description: Realtek PCIe GBE Family Controller Driver version: 9.1.406.2015 Physical address (MAC): 14-DD-A9-27-9B-ED ethernet doesn't have valid ip configuration I try a lot...
  7. Ethernet doesn't have valid IP configuration

    in Windows 10 Network and Sharing
    Ethernet doesn't have valid IP configuration: Hey, My gf's computer in her office (a school) was slow and riddled with viruses, so I had the bright idea to use the media creation tool to upgrade the machine to from win7 to win10 (x86) - clean install. Now, the ethernet that it was connected to before gives the error...
  8. Ethernet doesn't have a valid IP configuration

    in Windows 10 Network and Sharing
    Ethernet doesn't have a valid IP configuration: Hello, I'm about 4 hours deep into trying to fix this. I've followed several forum posts with similar issues, with no luck. I've been running windows 10 on my PC with my current hardware (including modem/router) for about a year now with no issues. Yesterday I booted...
  9. "Ethernet" doesn't have a valid ip configuration

    in Windows 10 Network and Sharing
    "Ethernet" doesn't have a valid ip configuration: So i decided to move on wired network connection for some reason and i can't make it work. To sum it up, i have a router that has 2 ports which offer 10mbps apparently and other 2 with 100mbps. I tried all 4 with a laptop and they work as expected ( same cable used ). Now,...
  10. Ethernet doesn't have valid IP configuration

    in Windows 10 Network and Sharing
    Ethernet doesn't have valid IP configuration: I've been working on this for over two hours now. I have wifi on laptop. In Windows 10 I can't access internet on PC with Ethernet. On the same computer I have a Linux Mint partition and ethernet connection is fine there 160Mbps. I've unplugged (several times) modem and...