Windows 10: SAMBA WINS Server + IPsec SIte to Site VPN = Browsing Service Not Work

Discus and support SAMBA WINS Server + IPsec SIte to Site VPN = Browsing Service Not Work in Windows 10 Network and Sharing to solve the problem; I have setup a Site-to-Site VPN using Sophos UTM at each end. I set up an Ubuntu VM as a WINS Server using Samba. So far so good. VPN Works. My... Discussion in 'Windows 10 Network and Sharing' started by Naldinho, Aug 15, 2016.

  1. Naldinho Win User

    SAMBA WINS Server + IPsec SIte to Site VPN = Browsing Service Not Work


    I have setup a Site-to-Site VPN using Sophos UTM at each end. I set up an Ubuntu VM as a WINS Server using Samba.

    So far so good. VPN Works.

    My problem is with the WINS Server. I have taken two Windows 10 computers and for both of them added the IP of the WINS server under Advanced TCP/IP Settings and changed NetBIOS to Enable NetBIOS over TCP/IP.

    The results are close but not quite right. The two computers with the modified settings can now ping each other using computer name rather than IP. Other computers on each end of the VPN can not do that.

    That said neither computer shows up in the Networks of the other. This is what I am trying to fix.

    It appears that name resolution is working for the computers that check in with the WINS server but that the Windows 10 browsing service is not adding those computers to the network.

    The LANs are 192.168.2.0/24 and 10.1.1.0/24 the WINS server is on 192.168.2.0/24 and it comes back as __MSBROWSE__ for that network. For 10.1.1.0/24 the computer that connects to the WINS server is showing __MSBROWSE__ when I check with nbtstat.

    When I check services Computer Browser is running.

    Can someone help me or at least point me in the right direction? This really shouldn't be this hard so I feel like I'm missing something obvious.

    :)
     
    Naldinho, Aug 15, 2016
    #1

  2. How to Connect Nokia E72 to VPN?

    Hello,



    Hotspot Shield has an awesome free VPN service which works very well on the iPhone:

    http://hotspotshield.com/clientless/iphone/get_started.php




    I want to use this service with my Nokia E72.



    As Nokia web site suggests, my phone supports VPN. Hotspot Shield VPN service is using IPSec.



    I found a tool on Nokia web site which apparently I should use to generate a VPN policy and install it to my phone. It is at the bottom of this page:

    http://europe.nokia.com/support/download-software/nokia-mobile-vpn/compatibility-and-download




    I searched a lot, but I really can't figure it out and make it work SAMBA WINS Server + IPsec SIte to Site VPN = Browsing Service Not Work :(



    How can I make it work?
     
    hbazerbashi, Aug 15, 2016
    #2
  3. After connect VPN Ethernet is disconnect

    I setup a VPN connection on a Windows 10 client but as soon the VPN is connecting to the server Ethernet connection is disconnected.

    The Server is a Apple Mac Server and needs VPN L2TP over IPSec with a shared secret password.

    I already changed in regedit the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent > AssumeUDPEncapsulationContextOnSendRule DWORD value to 2 and at

    HKLM\System\CurrentControlSet\Control\lsa the LmCompatibilityLevel to 3.

    https://support.microsoft.com/en-us...ipsec-server-behind-a-nat-t-device-in-windows

    Windows 10 can't connect to OS X server 1… - Apple Community

    But still VPN is disconnecting the Ethernet connection.

    The VPN is working fine on a Mac computer but not working on a Windows machine.

    Hope anybody could help.
     
    SteffendeErnst, Aug 15, 2016
    #3
  4. bro67 Win User

    SAMBA WINS Server + IPsec SIte to Site VPN = Browsing Service Not Work

    VPN will only work for outside the network, not meant for connections inside the network.
     
    bro67, Aug 16, 2016
    #4
  5. Naldinho Win User
    Either you didn't understand the question or that response makes no sense. This is a site-to-site VPN connecting two networks. The issue of cross-subnet browsing is a well known problem.

    Anyway in case anyone comes looking changing the WINS node type to H-Node fixed the problem on subnet that does not have the WINS server.

    For the subnet that has the WINS server the browsing service has not yet added the other subnets computers but I am making progress.

    I think a more elegant solution would be to have another machine running at the other end and I might go that way yet as I found a couple of tutorials on that method but for now I'm trying to do it with every computer reporting to just the one WINS server on one subnet.
     
    Naldinho, Aug 16, 2016
    #5
  6. bro67 Win User
    Nothing to state differently. See my post above. If the networks are outside of your house, you need to use a standard VPN like Open VPN. What you are trying to do is set up a Domain and use it in the wrong way. If the networks are behind the same modem, it still will not work, because VPN's are meant for outside across the Intranet.
     
    bro67, Aug 17, 2016
    #6
  7. Naldinho Win User
    My post says I have a site-to-site VPN setup that works and that even name resolving works -- my problem is just getting the browsing service to work across subnets.
     
    Naldinho, Aug 17, 2016
    #7
  8. bro67 Win User

    SAMBA WINS Server + IPsec SIte to Site VPN = Browsing Service Not Work

    Site to Site will not work with using Ubuntu or any distro as a VM. Use a Headless server running Open VPN. Browsing Services is going to be a little harder if there is a firewall on either side that is blocking.

    If you want to work in fixing the SAMBA problem, download Webmin and use it to make the changes. You are also using a Domain setup, so that means that you may want to look at using an alternative like NethServer or Zentyal, that gives you the proper backend for handling Domain and VPN. The easier is going to be NethServer. The stronger one if you are going to be sharing Windows mail, etc, would be Zentyal.
     
    bro67, Aug 17, 2016
    #8
  9. Naldinho Win User
    I'm not using Ubuntu -- I'm using two Sophos UTMs with IPsec.

    The Ubuntu VM is for a local webserver but I figured it could take on the extra duties of being a WINS server.

    The cross-subnet browsing is now working sporadically on one subnet which confirms it is possible I'm just trying to figure out why it is sporadic and why only on one of the subnets.

    As it currently stands the WINS server is on 192.168.2.0 and when browsing 10.1.1.0 can see all the computers on 10.1.1.0 and 192.168.2.0 but computers on 192.168.2.0 can only see computers on 192.168.2.0. Name resolution works for all computers on both subnets including across subnets which means that WINS is working but browsing is not.
     
    Naldinho, Aug 17, 2016
    #9
  10. bro67 Win User
    What are the logs showing, along with the Firewall? Is it showing that the Keep Alive is being dropped on the main side, or remote location? Also is the firewall for Sophos and for the other machine handling the VPN properly? IPSec in itself has had some issues for a long time. Going from a 10.x.x.x/8 to a 192.x.x.x/32 can cause problems if the VPN is not set up properly. You may want to check the Sophos forums to see if anyone else is having this same problem.

    Wins is mainly used for Domains, should not be a problem with a VPN.
     
    bro67, Apr 5, 2018
    #10
Thema:

SAMBA WINS Server + IPsec SIte to Site VPN = Browsing Service Not Work

Loading...
  1. SAMBA WINS Server + IPsec SIte to Site VPN = Browsing Service Not Work - Similar Threads - SAMBA WINS Server

  2. Syncing folders over Site-to-Site VPN

    in Windows 10 Network and Sharing
    Syncing folders over Site-to-Site VPN: Hey all, I have a client who has three homes connected to each other with a site-to-site VPN. He can be at Home A and access any IP at Home B and Home C. He has a large music folder and would like to have that folder sync to the folders at his other two homes. For example,...
  3. Syncing folders over Site-to-Site VPN

    in Windows 10 Support
    Syncing folders over Site-to-Site VPN: Hey all, I have a client who has three homes connected to each other with a site-to-site VPN. He can be at Home A and access any IP at Home B and Home C. He has a large music folder and would like to have that folder sync to the folders at his other two homes. For example,...
  4. Syncing Folders over site-to-site VPN

    in Windows 10 Network and Sharing
    Syncing Folders over site-to-site VPN: Hello, I have a client who has three homes which are permanently connected over a site-to-site VPN, so all three networks are accessible from any of the three sites. He has a desktop PC at each home. He would like to have a single music folder on each PC which sync to each...
  5. Chrome can only browse Google sites

    in Browsers and Email
    Chrome can only browse Google sites: Not sure how I got to this stage, but if i reboot my machine I am able to browse in chrome for a short while. Then I start getting ERR_CONNECTION_RESET errors on anything but Google and Utube sites I am even unable to log onto my router. Have tried to reset all network...
  6. Chrome can only browse Google sites

    in Windows 10 Support
    Chrome can only browse Google sites: Not sure how I got to this stage, but if i reboot my machine I am able to browse in chrome for a short while. Then I start getting ERR_CONNECTION_RESET errors on anything but Google and Utube sites I am even unable to log onto my router. Have tried to reset all network...
  7. are there any free vpn sites

    in AntiVirus, Firewalls and System Security
    are there any free vpn sites: are there any free vpn sites https://answers.microsoft.com/en-us/windows/forum/all/are-there-any-free-vpn-sites/30118a05-82c5-40d7-9139-a95500138014"
  8. Windows 10 branch users - IPSec site to site VPN

    in Windows 10 Network and Sharing
    Windows 10 branch users - IPSec site to site VPN: Hi all, This is my first post in this forum. I have encountered a problem on Windows 10 computers located in a remote site. The branch is connected to head office via Cisco router using IPSec site to site VPN. All Windows 10 computers are unable to authenticate in the...
  9. L2TP IPSec VPN no longer working

    in Windows 10 Network and Sharing
    L2TP IPSec VPN no longer working: Hi I've been connecting to a L2TP IPSec VPN for quite a few months now to monitor a remote network but all of a sudden it has stopped working. It keeps saying "...Security layer encountered a proccessing error..." and will not connect. I have tested the connection details...
  10. Sites Missing In Browsing History In Microsoft Edge

    in Windows 10 Network and Sharing
    Sites Missing In Browsing History In Microsoft Edge: I recently went to the browsing history in my Microsoft Edge browser, and there are some sites missing. I went to a site called savethechildren.com through a click thru button on a site called MyPoints so that I could get points for my donation on Saturday, I think it was,...

Users found this page by searching for:

  1. windows not browsing over site-to-site vpn