Windows 10: Windows 10 Admin Privileges causing issue

Discus and support Windows 10 Admin Privileges causing issue in Windows 10 Support to solve the problem; Hi, I'm having persistent issues with Windows 10 and its user privilege settings. When running a program as administrator, I'm unable to drag and... Discussion in 'Windows 10 Support' started by tbcam88, Aug 25, 2015.

  1. tbcam88 Win User

    Windows 10 Admin Privileges causing issue


    Hi,


    I'm having persistent issues with Windows 10 and its user privilege settings. When running a program as administrator, I'm unable to drag and drop files as normal onto its GUI. A look at the screen record below should elaborate on what I mean exactly:


    Windows 10 Admin Privileges causing issue [​IMG]


    I've tried a few things such as taking ownership of the various files/folders involved but nothing seems to correct this problem so far!

    The only thing that has worked up until now was to enable Window's built in hidden administrator account. This rectified the problem completely and I was free to drag/drop etc. as normal. I can't help but feel there is something wrong with my install... It's as if the system permissions have been configured irregularly somehow.

    Any idea what may be the cause here?

    Thanks!


    :)
     
    tbcam88, Aug 25, 2015
    #1
  2. Allan Mej Win User

    The only User Profile that shows up doesn't exist also has Admin over everything

    Do you have an Admin privileges on the account that you are using? We need an Administrator account to troubleshoot your issue. If you don't have Admin privileges, we may need to Reinstall Windows 10 on your PC.
     
    Allan Mej, Aug 25, 2015
    #2
  3. RickF_007 Win User
    Cannot add local account after upgrading to Windows 10

    OK, given that I installed Windows 10 through the free upgrade facility, where do I get/find the Windows installation media?
     
    RickF_007, Aug 25, 2015
    #3
  4. swarfega Win User

    Windows 10 Admin Privileges causing issue

    When you have fundamental problems like this I tend to suggest thinking about a clean install of Windows 10.
     
    swarfega, Aug 25, 2015
    #4
  5. When you run a program as Administrator it will not accept interactions from a process that is not elevated to Administrator like the program. Explorer, does not run as Administrator and cannot be elevated like Photoshop. So you will not be able to drag files onto it to open them when Photoshop is running as Administrator. (It has worked this way since Windows Vista.)

    The solution is easy. Don't use the run as Administrator option. Its not needed to use Photoshop.
     
    logicearth, Aug 25, 2015
    #5
  6. Harpert Win User
    I agree...

    It's not needed to run as admin.
    Photoshop should work without any problem in "user" mode
     
    Harpert, Aug 25, 2015
    #6
  7. tbcam88 Win User
    I was thinking this myself to be honest but I'm worried it may happen again as my recent install of Windows 10 was a clean install..
     
    tbcam88, Aug 25, 2015
    #7
  8. tbcam88 Win User

    Windows 10 Admin Privileges causing issue

    Photoshop was merely the example used for the purposes of recording the GIF... There are other programs which I need to run as Administrator for a host of other reasons (Ableton Live for example) and therein lies the problem with regards to drag/dropping onto the interface.

    Is it not possible for me to elevate explorer's user privileges then? (apart from aforementioned hidden administrator account of course...)

    If so, this causes me a real headache. *Shock
     
    tbcam88, Aug 25, 2015
    #8
  9. Maybe you can elaborate on the need for you to run the applications in question as Administrator. What is stopping you from running them normally?
     
    logicearth, Aug 25, 2015
    #9
  10. tbcam88 Win User
    When running Ableton Live for example, I use a program called "jBridge" which allows use of 32bit plugins within my 64bit version of Ableton.

    Since moving from Windows 7 to 10, I must now run Ableton as Administrator or jBridge will flag up permission based errors such as:


    Windows 10 Admin Privileges causing issue [​IMG]


    I may be mistaken, but this all seems to point back to what I mentioned earlier... It's as if my user privileges are corrupted somehow. I'm being locked out from basic read/write access on the C: drive.

    Windows 8 may have been the same, I wouldn't know (having bypassed the OS as a whole), but I definitely didn't experience this with 7. And, I must've installed 7 from scratch a good five or six times over throughout its software cycle.
     
    tbcam88, Aug 25, 2015
    #10
  11. Mystere Win User
    I assume you migrated to Windows 10 from XP somehow, because this has worked this way since Since windows Vista. Back in the XP days, there was a security vulnerability called a "Shatter attack" discovered. At the time, it was claimed this was "unfixable", but Microsoft did indeed fix it. Part of the problem was an unsafe method of communicating between windows with elevated privileges and those without.

    The "fix" does not allow elevated apps to communicate with non-elevated apps, and that includes drag and dropping. Both apps have to be at the same elevation level.

    You can read about this here, if you are technically minded. Exploiting design flaws in the Win32 API for privilege escalation - Shatter Attacks - How to break Windows
     
    Mystere, Aug 25, 2015
    #11
  12. tbcam88 Win User
    Hi,

    No, I moved from XP to 7 not too long after it was released, bypassing Vista completely (for obvious reasons...)

    I definitely never has this problem with 7, but then again, I may not have had to run programs as Administrator in order to bypass these annoying nags regarding user privileges.

    There's always the possibility "jBridge" is to blame as it's third party software which may not yet be fully compatible with W10. Somehow I doubt it though. I've encountered far too many problems since upgrading re user privileges to believe otherwise. I'll try replicate some of the others and post the relevant errors. *Huh
     
    tbcam88, Aug 25, 2015
    #12
  13. tbcam88 Win User

    Windows 10 Admin Privileges causing issue

    If I backup the registry for example...

    This is what happens when I try execute the backup key:


    Windows 10 Admin Privileges causing issue [​IMG]
     
    tbcam88, Aug 25, 2015
    #13
  14. tbcam88 Win User
    Another when trying to update a dll file needed to launch a certain video game:


    Windows 10 Admin Privileges causing issue [​IMG]
     
    tbcam88, Apr 4, 2018
    #14
Thema:

Windows 10 Admin Privileges causing issue

Loading...
  1. Windows 10 Admin Privileges causing issue - Similar Threads - Admin Privileges causing

  2. Lost admin privileges

    in Windows 10 Ask Insider
    Lost admin privileges: I was downloading a game when i accidentally turned my computer off. I turned it back on and i had lost my admin privileges. I've tried making a new admin account which doesn't work for some reason. Does anyone know what i should do? submitted by /u/PeepMcChicky [link]...
  3. windows stuck in admin privilege

    in AntiVirus, Firewalls and System Security
    windows stuck in admin privilege: Dear all , is there any fix for that [ATTACH] https://answers.microsoft.com/en-us/windows/forum/all/windows-stuck-in-admin-privilege/2ed5dd64-2dfa-4979-941c-37d46a9a354f"
  4. admin privileges to my windows account

    in Windows 10 Network and Sharing
    admin privileges to my windows account: I have an old laptop that has windows 10 on, I would like to add admin privileges to my winows 10 account. my question is how do I do it? https://answers.microsoft.com/en-us/windows/forum/all/admin-privileges-to-my-windows-account/ab65f857-f0bf-4d89-adc9-1bf814537d49"
  5. lost admin privileges?

    in User Accounts and Family Safety
    lost admin privileges?: Good evening., I don't know why I lost admin privlages, but I cant get on task manager, I cant download, I cant "run as administrator, although I am signed in on an administrator account, which I had just set up a new one and signed out of the old one because of the issue I...
  6. admin privileges

    in Windows 10 Network and Sharing
    admin privileges: Hi, Even since I bought my PC, I noticed that whenever I needed to make a change in setting I received a message saying I was not the administrator. In order to run CDM to try to make a change, it tell me that the operation requires elevation (run as administrator) Why is...
  7. Multiple admin accounts privileges

    in AntiVirus, Firewalls and System Security
    Multiple admin accounts privileges: Hi, Can i have 2 admin accounts in windows 10 and win server 2016 where i can develop the following scenario 1. The admins cannot change the password of each other's. 2. The admins can only view their own folders? Is their a doc illustrating this? Thanks....
  8. Need help with Admin privileges

    in User Accounts and Family Safety
    Need help with Admin privileges: I need to install a software but when I click the file the UAC comes out and asks the usual questions. What I find weird is it does not give me the option to click YES. Only the NO button shows up. I checked and it seems that I am logged in as a local account. I tired...
  9. No Admin privileges.

    in Windows 10 Support
    No Admin privileges.: I purchased a new Alienware computer 2 weeks ago and a couple days ago I noticed I couldn't access my Pictures folder. I also noticed I couldn't do any Admin tasks. I can't open task manager, Open any exe. files and when I right click on C drive I get Access is denied. I...
  10. Set Admin Privileges

    in Windows 10 Support
    Set Admin Privileges: How can I setup Windows 10 so it permanently has Administrative priveleges ? I am the only user here. Thanks, rs 13816