Windows 10: Administrator Privileges problems

Discus and support Administrator Privileges problems in User Accounts and Family Safety to solve the problem; I know we have touched on this before when I had tried to handle something in file explorer, and now the frustration has extended itself to the... Discussion in 'User Accounts and Family Safety' started by brucemc777, May 2, 2016.

  1. Administrator Privileges problems


    I know we have touched on this before when I had tried to handle something in file explorer, and now the frustration has extended itself to the desktop.

    I am really sick of W10 telling me that I need Administrator Privileges. This time it is to perform an operation to a shortcut on my desktop, but frankly, as I made my account an admin account purposely, for anything.

    Has anyone found a way to make any Admin account actually have full Administrator Privileges?

    :)
     
    brucemc777, May 2, 2016
    #1

  2. administrator privileges

    The game is The Settlers Heritage Of Kings/settlers 5 (CD-Disk), it worked on windows 7-8 but ever since Windows 10, the game won't even load or it will ask me to "log in with administrator privileges and try again" windows features are turned on.
     
    MitchellHarkins, May 2, 2016
    #2
  3. Administrator privileges.

    Hi,

    For us to provide the best solution to your concern, we'd like to ask additional information. Kindly answer the following questions below:

    • Are you trying to delete the folder stored on your laptop?
    • Is your friend getting any error messages when trying to delete the said folder? If yes, we'd like to ask a screenshot of the error message.

    We'll keep an eye out for your response.
     
    Martin Bar, May 2, 2016
    #3
  4. Administrator Privileges problems

    As far as I know, the only true admin account with full access is the built in Administrator account, which is disabled by default.

    Honestly, if you know what you are doing with the computer, you can turn off UAC, but that's about it. As long as you are aware of the risks, it cuts down on almost all prompts. I disable it on all of my computers, but that doesn't mean I tell everyone to do so.

    If you think Windows 10 is annoying, then try OSX or Linux. Those prompts are there for a reason, and as someone who works in corporate IT, I'm thankful that Windows has been locked down.
     
    DeaconFrost, May 2, 2016
    #4
  5. Mystere Win User
    Turning off UAC will give you full permissions, however if you do that a lot of functions of the OS won't work anymore, such as the Settings menu, Edge, and pretty much any app.

    This function is there for a reason, and given the propensity of ransomware today, I would take every possible security advantage I can find, not purposely cripple them.

    FYI, if you need admin permission for an icon on the desktop, it's because the icon was created with administrator rights. This is the sort of thing that UAC actually helps with, by giving you the rights you need when you need them
     
    Mystere, May 2, 2016
    #5
  6. fdegrove Win User
    Hi,

    Sounds as if the ACLs are messed up though.

    Download and install this program here :

    https://www.microsoft.com/en-us/down....aspx?id=23510

    Then copy paste this in notepad, change the .txt extension to .bat and run with admin rights.

    Cheers, *Wink
     
    fdegrove, May 2, 2016
    #6
  7. I have shut off UAC; I found it annoying. Perhaps we are using different terms here, for I still run Settings without any noticeable difference. I use Malwarebytes Anti-Ransomware beta and though have had two false positives, I feel if I ever do something stupid, it gives me enough extra margin of protection to have a comfort margin and if I ever was important enough to become target of an APT, sooner or later I suppose they would get me, but my assets are pretty much a waste of time.

    I have a mild understanding the problems of corporate environment IT and am very happy that this is not my headache (for my time in a large corporate environment I became good friends with IT and also thought upper management (at Xerox) were complete horse's asses in many respects, including how they treated these guys).

    I want full control.

    Funny enough, the icon that I would like to blow away is the regular Malwarebytes desktop icon, and when I have a moment I will re-logon with the built in Admin account to get at it.
     
    brucemc777, May 2, 2016
    #7
  8. Administrator Privileges problems

    I have three computers of my own, plus 20 that have been rolled out in our company, all with UAC disabled, and we haven't had any issues yet. I've disabled UAC on my personal computers since the feature was first added to 7, and haven't ever been denied a feature or function of the OS.
     
    DeaconFrost, May 2, 2016
    #8
  9. All in all, I honestly do appreciate the safeguards being offered, and if they were simply offered as opposed to forced, I would be very happy.

    I have seen people who purport to be computer savvy do incredibly stupid things (and one walk right into a ransom-ware trap, like seeing someone fall right into an open manhole).

    I am simply looking for the ability to decide for myself and assume the consequences. It seems MS is acting like big government more and more; I find this repugnant, but also out of character; so I keep searching for someone who knows of the "off switch" to this admin rights double standard.
    @fdegrove: Thanks, but I still am not allowed to delete the desktop icon. Time to reboot once again...
     
    brucemc777, May 2, 2016
    #9
  10. fdegrove Win User
    Hi,

    Just an idea. Are you sure it's just a shortcut on the desktop and not the full executable? For, if it is then you'd first need to stop the program from running before you can delete it or move it to where you want it.

    I've run into similar oddities as yourself and I know of a few things that can cause these. The Subinacl.exe batch file invariably solved it and put things back to their defaults.

    UAC can be a PITA but not to the point of not letting you do standard operations such as you described.

    Cheers, *Wink
     
    fdegrove, May 2, 2016
    #10
  11. Mystere Win User
    Well, that may in fact be your problem. When you disable UAC, or enable and disable it at various times, different objects are created with different permissions, and you can basically end up with an unmanageable mess of ACL's assigned to things, with varying degrees of accessibility.

    You should pick one or the other. Either run without UAC from the start, or always use UAC, don't do some of one and some of the other.
     
    Mystere, May 3, 2016
    #11
  12. @Mystere: I apologize if I worded my post in a confusing manner; sometimes what I think I am saying, no matter how many times I preview and read through the post, has items of "presumption" in it.

    The only time I EVER have UAC on is when W10 has updated itself and turned it on "for me". It seems to like to do that... *Wink
     
    brucemc777, May 3, 2016
    #12
  13. NovHak Win User

    Administrator Privileges problems

    I don't think there's any account on W10 that can directly do everything. No matter you're a member of the administrators group, the administrator user or the system user... and this was the case with W2000 already, and probably WNT4 too.

    Now back to your case, it's very possible that disabling UAC is the cause of the problem. The UAC-elevated environment is somehow "normalized", i.e. doesn't depend on the calling user for the most part. As an example, in the old pre-UAC times (before Vista), suppose you had two admin accounts Alice and Bob, creating a file in a directory such as Program Files wasn't different than creating one on your desktop, it would have a different security descriptor (i.e. owner and ACL) depending on the admin account used. Disabling UAC makes this happen again.

    Anyway, you should have a look at the ACLs of 1:the file you're trying to remove and 2:its parent directory. Unlike it seems, the parent directory is likely not your desktop, but the public desktop : "C:\Users\Public\Desktop". You can check the ACLs either from the security tab in the file/directory properties, or from the command line, typing icacls <file/directory path>, e.g. icacls "C:\Users\Public\Desktop". The advantage with an icacls output is that it's easier to copy/paste here.

    Knowing the owner of the file and its parent directory can be useful too, since the owner can modify the ACL of the owned file/directory at will, no matter what the explicit ACL is (except in one case, if the OWNER RIGHTS special entry denies that). You can get the owner from either the advanced button of the security tab, or from the command line with the dir /Q command.
     
    NovHak, May 3, 2016
    #13
  14. I'm not sure where you are getting this, but if you feel this is true, you may have some other issues going on. Disabling UAC can expose a user to threats, but it doesn't cause any issues with the existing system.
     
    DeaconFrost, May 3, 2016
    #14
  15. Mystere Win User
    It can. The reason is related to how UAC works. It has a function called "folder virtualization" among others. Let's say you install an app that assumes it can write to the System folder, or to Program Files. UAC causes these file writes to be redirected to a different location, that is "virtualized". If you then turn off UAC, the app tries to read the files from the real locations instead of the virtual ones, causing a number of kinds of problems. This is just one example, there are tons of other situations in which UAC subtly changes the way permissions are created, ACL's are created, etc..
     
    Mystere, May 3, 2016
    #15
Thema:

Administrator Privileges problems

Loading...
  1. Administrator Privileges problems - Similar Threads - Administrator Privileges problems

  2. Administrator privilege setting

    in AntiVirus, Firewalls and System Security
    Administrator privilege setting: Windows 10 Home, I am the administrator in trying to delete a folder/file the message "requires administrator privilege" What is necessary: https://answers.microsoft.com/en-us/windows/forum/all/administrator-privilege-setting/dd20c099-61e6-44dd-858a-39c729c22e34"
  3. Administrative account with no administrative privileges

    in Windows 10 Network and Sharing
    Administrative account with no administrative privileges: Lead up I have been working on an issue where a user cannot open attachments from Outlook in Word. This problem is caused by Word not being able to access the Fonts folder, I need to change the privileges, no clue how it keeps getting changed. Problem I cannot change the...
  4. Administrator with no privileges?

    in AntiVirus, Firewalls and System Security
    Administrator with no privileges?: I have an administrator account on windows 10 desktop. I have a program (MySQL workbench) that was installed, uninstalled, and some months later reinstalled because after all I do want to use it. The program according to MySQL forum did not uninstall some of the old files -...
  5. Administrator privileges

    in Windows 10 Installation and Upgrade
    Administrator privileges: I need help with changing the administrator on an HP Pavilion desktop. While setting the PC I gave it a name/gmail address without having the actual gmail-email configured. Presently this is causing a host of problems: I am unable to download apps or access the Admin name...
  6. Administrator privilege lost

    in AntiVirus, Firewalls and System Security
    Administrator privilege lost: After 5 years as owner/single user of my W10 desktop, now I cannot access Device Manager. I get "This app has been blocked for your protection". Could a recent update have caused this? How can I reclaim my administrator's privileges?...
  7. administrative privileges

    in Windows 10 Network and Sharing
    administrative privileges: Running Windows 10 with latest updates and am attempting to execute "netsh wlan show wlanreport" from comand prompt. I go to start menu, select command prompt, right click it, and select "run as administrator". From the resulting command prompt, I can execute various NETSH...
  8. administrator privileges...

    in User Accounts and Family Safety
    administrator privileges...: I have recently had problems getting certain programs to work properly (Alzip, Finale 2012 and others), and I've discovered that somewhere along the line, presumably after the last big Windows 10 upgrade, my permissions must have changed. The result of this is that I now have...
  9. Administrative privileges?

    in User Accounts and Family Safety
    Administrative privileges?: I recently down loaded a game to my lap top and when I click the icon it gives me a "Please login with administrative privileges and try again" message. I am the only user on this computer and have administrative privileges. Any ideas as to what I need to do to resolve the...
  10. Administrator has Insufficient privileges

    in User Accounts and Family Safety
    Administrator has Insufficient privileges: Hi, I would like to modify an .inf file located here: Code: C:\Windows\System32\DriverStore\FileRepository\android_winusb.inf_amd64_bd75d06c56998078[/quote] but windows don't let me do it. Pretexting that I don't have enough rights to do it. I tried with the super...