Windows 10: Anniversary update fails with error 0xC1900101 - 0x20017

Discus and support Anniversary update fails with error 0xC1900101 - 0x20017 in Windows 10 Updates and Activation to solve the problem; Windows 10 1511 will not update to 1607 by any method. Updates always complete to 100% then revert. Computer is a Dell Vostro 1720. Background: The... Discussion in 'Windows 10 Updates and Activation' started by Michael Purcell, Sep 22, 2016.

  1. Anniversary update fails with error 0xC1900101 - 0x20017


    Windows 10 1511 will not update to 1607 by any method. Updates always complete to 100% then revert. Computer is a Dell Vostro 1720.

    Background: The computer never appeared to update automatically, but there was never any error code. I tried to use the Windows 10 upgrade assistant. The upgrade would go through download and install to 100% but then restart back to version 1511 with no error message. Finally, I downloaded the 1607 iso, extracted it to my hard disk, and installed from there. Again the update went to 100% and then reverted back to 1511, but this time it gave the error message 0xC1900101 - 0x20017 "The installation failed in the SAFE_OS phase with an error during BOOT operation."

    I have found several threads about this error, and it seems most likely that there is a driver conflict of some kind. I have looked at the setuperr.log from $WINDOWS.~BT/Sources/Panther/ directory but I do not see what is causing the error. Can anyone help with guidance on this?

    setuperr.log text:

    2016-09-21 19:53:52, Error CONX Windows::Compat::Appraiser::Utilities::SendRequest (1259): Failed to connect to the internet or send request: [12007].[gle=0x80072ee7]
    2016-09-21 19:53:52, Error CONX Windows::Compat::Appraiser::Utilities::ResolveForwardLink (1319): Failed to send request using default proxy[gle=0x80072ee7]
    2016-09-21 19:54:32, Error CONX Windows::Compat::Appraiser::Utilities::SendRequest (1259): Failed to connect to the internet or send request: [12007].[gle=0x80072ee7]
    2016-09-21 19:54:32, Error CONX Windows::Compat::Appraiser::Utilities::ResolveForwardLink (1327): Failed to send request using auto proxy[gle=0x80072ee7]
    2016-09-21 19:54:32, Error CONX Windows::Compat::Appraiser::Utilities::ExtractCosConnectionString (435): Failed to resolve forward link: [0x80072ee7].[gle=0x80072ee7]
    2016-09-21 19:54:32, Error CONX Windows::Compat::Appraiser::CosDeviceDataSource:*Tongue refetchData (492): Could not resolve COS FwLink: [0x80072ee7].[gle=0x80072ee7]
    2016-09-21 19:58:45, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\DefaultAppPool. NetUserGetLocalGroups failed 0x000008AD
    2016-09-21 19:59:01, Error SP pSPRemoveUpgradeRegTree: failed to delete reg tree HKLM\SYSTEM\Setup\Upgrade[gle=0x00000005]
    2016-09-21 19:59:22, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\DefaultAppPool. NetUserGetLocalGroups failed 0x000008AD
    2016-09-21 19:59:29, Error [0x080831] MIG CSIAgent: Invalid xml format: FormatException: "id" attribute is mandatory. void __cdecl Mig::CMXEMigrationXml::LoadSupportedComponent(class UnBCL::XmlNode *,int,class Mig::CMXEMigrationXml *,class Mig::CMXEXmlComponent *)
    2016-09-21 20:00:13, Error CSI 00000001 (F) 80220008 [Error,Facility=FACILITY_STATE_MANAGEMENT,Code=8] #82785# from CWcmScalarInstanceCore::GetCurrentValue(options = 393216 (0x00060000), status = [6]"(null)", value = { type: 40972 (0x0000a00c), bytes ( 12 (0x0000000c) ): 65006e002d00550053000000 })
    [gle=0x80004005]
    2016-09-21 20:01:06, Error CSI 00000002 (F) 80220008 [Error,Facility=FACILITY_STATE_MANAGEMENT,Code=8] #162907# from CWcmScalarInstanceCore::GetCurrentValue(options = 393216 (0x00060000), status = [6]"(null)", value = { type: 40972 (0x0000a00c), bytes ( 12 (0x0000000c) ): 65006e002d00550053000000 })
    [gle=0x80004005]
    2016-09-21 20:01:18, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\DefaultAppPool. NetUserGetLocalGroups failed 0x000008AD
    2016-09-21 20:01:28, Error [0x080831] MIG CSIAgent: Invalid xml format: FormatException: Component with display name: Plugin/{C939EC0F-2F56-4CE8-AF56-2336596A5FA7} already loaded __cdecl Mig::CMXEMigrationXml::CMXEMigrationXml(class Mig::CPlatform *,class UnBCL::String *,class UnBCL::XmlDocument *,class UnBCL::String *,class UnBCL::String *)
    2016-09-21 20:05:48, Error [0x0808fe] MIG Plugin {526D451C-721A-4b97-AD34-DCE5D8CD22C5}: [shmig] Failed to get preferred homegroup with hr=0x80070490
    2016-09-21 20:06:36, Error CSetupAutomation::Resurrect: File not found: C:\$WINDOWS.~BT\Sources\Panther\automation.dat[gle=0x00000002]
    2016-09-21 20:06:36, Error SP CSetupPlatform::ResurrectAutomation: Failed to resurrect automation: 0x80070002[gle=0x00000002]
    2016-09-21 20:06:37, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\DefaultAppPool. NetUserGetLocalGroups failed 0x000008AD

    :)
     
    Michael Purcell, Sep 22, 2016
    #1

  2. Windows defender closing instantly

    0xC1900101 - 0x20017

    The installation failed in the SAFE_OS phase with an error during BOOT operation
     
    ChristianSchau, Sep 22, 2016
    #2
  3. voca(2) Win User
    Windows 10 will not update

    Installation failed in the SAFE_OS phase with an error during BOOT operation.

    0xC1900101 - 0x20017
     
    voca(2), Sep 22, 2016
    #3
  4. MerlinC Win User

    Anniversary update fails with error 0xC1900101 - 0x20017

    Same issue on my computer - the implementation of the update function is really disappointing.

    After a clean installation it works a view weeks an afterwards it gets messed up again.
     
    MerlinC, Sep 22, 2016
    #4
  5. CmmTch Win User
    I have the exact same issue and error message, I have tried many things, all drivers are up to date (except the video adapter driver, the most recent won't allow 1600x900 so I rolled back) updated my MB BIOS to the most recent, no change.

    There's been enough time wasted on updating to the AU, I might try again in a few weeks, maybe not at all. The initial RTM installed no problems, the November update to 1511 wouldn't install on an update, had to use the iso. This shows W10 does run on my computer, but for whatever reason it won't install the latest AU update either with WU or iso.

    I am not willing to do a clean install, there's no guarantee that would change anything, if it is a driver nothing will change. The major change would be setting the partitions on the C drive, right now the recovery partition is at the end of the drive, W10 set it like this at some point, I wouldn't move those around. I did see somewhere it would be created at the end of a drive to allow the OS to change it's size. When it's at the front of the drive it can't easily expand.


    Anniversary update fails with error 0xC1900101 - 0x20017 [​IMG]
     
    CmmTch, Sep 23, 2016
    #5
  6. Thank you both for responding. @CmmTch, your experience is not very encouraging.

    Today I deleted all temporary directories related to the update, removed the external hdd and other usb devices from the computer, and ran the .iso install again. I get a slimmed down setuperr.log, but no hint as to what is causing the error, as far as I can tell.

    todays setuperr.log:

    2016-09-24 13:19:49, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\DefaultAppPool. NetUserGetLocalGroups failed 0x000008AD

    2016-09-24 13:20:09, Error SP pSPRemoveUpgradeRegTree: failed to delete reg tree HKLM\SYSTEM\Setup\Upgrade[gle=0x00000005]

    2016-09-24 13:20:33, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\DefaultAppPool. NetUserGetLocalGroups failed 0x000008AD

    2016-09-24 13:20:43, Error [0x080831] MIG CSIAgent: Invalid xml format: FormatException: "id" attribute is mandatory. void __cdecl Mig::CMXEMigrationXml::LoadSupportedComponent(class UnBCL::XmlNode *,int,class Mig::CMXEMigrationXml *,class Mig::CMXEXmlComponent *)

    2016-09-24 13:21:38, Error CSI 00000001 (F) 80220008 [Error,Facility=FACILITY_STATE_MANAGEMENT,Code=8] #82785# from CWcmScalarInstanceCore::GetCurrentValue(options = 393216 (0x00060000), status = [6]"(null)", value = { type: 40972 (0x0000a00c), bytes ( 12 (0x0000000c) ): 65006e002d00550053000000 })

    [gle=0x80004005]

    2016-09-24 13:22:40, Error CSI 00000002 (F) 80220008 [Error,Facility=FACILITY_STATE_MANAGEMENT,Code=8] #162907# from CWcmScalarInstanceCore::GetCurrentValue(options = 393216 (0x00060000), status = [6]"(null)", value = { type: 40972 (0x0000a00c), bytes ( 12 (0x0000000c) ): 65006e002d00550053000000 })

    [gle=0x80004005]

    2016-09-24 13:22:53, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\DefaultAppPool. NetUserGetLocalGroups failed 0x000008AD

    2016-09-24 13:23:05, Error [0x080831] MIG CSIAgent: Invalid xml format: FormatException: Component with display name: Plugin/{C939EC0F-2F56-4CE8-AF56-2336596A5FA7} already loaded __cdecl Mig::CMXEMigrationXml::CMXEMigrationXml(class Mig::CPlatform *,class UnBCL::String *,class UnBCL::XmlDocument *,class UnBCL::String *,class UnBCL::String *)

    2016-09-24 13:27:54, Error [0x0808fe] MIG Plugin {526D451C-721A-4b97-AD34-DCE5D8CD22C5}: [shmig] Failed to get preferred homegroup with hr=0x80070490

    2016-09-24 13:28:50, Error CSetupAutomation::Resurrect: File not found: C:\$WINDOWS.~BT\Sources\Panther\automation.dat[gle=0x00000002]

    2016-09-24 13:28:50, Error SP CSetupPlatform::ResurrectAutomation: Failed to resurrect automation: 0x80070002[gle=0x00000002]

    2016-09-24 13:28:50, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\DefaultAppPool. NetUserGetLocalGroups failed 0x000008AD
     
    Michael Purcell, Sep 23, 2016
    #6
  7. I found this Windows 10 upgrade error troubleshooting page which includes the following:

    As far as I can tell, all drivers are already up to date. How would I pinpoint one that is not up to date?

    %windir% represents the current windows directory, which in my case is C:\Windows. According to this page, the only time C:\Windows\Panther\Setuperr.log and ~Setupact.log are created is when the upgrade is successful. Therefore, these two log files are, I would assume, from the successful upgrade from build 10240 to version 1511. Why would I be directed to look in these two log files to see why the attempted upgrade from 1511 to 1607 failed? I'm not suggesting that the guidance is wrong, but I don't understand the connection.

    Secondly, the Setuperr.log is not long, but the Setupact.log is very long. How does one parse any useful information from these two files according to the instructions: "and then locate the problem drivers?" Apparently, these helpful troubleshooting instructions are for individuals who already know how to read these files?
     
    Michael Purcell, Sep 26, 2016
    #7
  8. CmmTch Win User

    Anniversary update fails with error 0xC1900101 - 0x20017

    I followed the directions C: > Windows > Panther and found the two text files, setuperr dated 9-15-2016 on a failed attempt


    Anniversary update fails with error 0xC1900101 - 0x20017 [​IMG]


    Setuperr below, appears ATI drivers are listed at the top. Maybe this is what the troubleshooting page refers to, I'm not uninstalling them. W10 should replace them with MS working drivers if the W10 AU can't handle them. It could be the problem, but it wasn't a problem the first RTM or the November update.

    Since the AU is now considered the "paid" version for those that didn't take advantage of the free upgrade W10 may be picky about an install. I'm not doing a clean install, if W10 is now the new "running as a service OS" it should be able to update itself without issue. Meaning any computer running any version of W10 without problems should upgrade without problems.


    Anniversary update fails with error 0xC1900101 - 0x20017 [​IMG]
     
    CmmTch, Sep 26, 2016
    #8
  9. Interesting. The log files in my C:\Panther directory have the last modified date of 3/29/2016, which is presumably when my Windows 10 was updated to the 1511 version. In fact, every file in the Panther directory has that date. I did notice, however that there is a C:\Panther\NewOs\Panther directory which has the log files with the date of 9/24/16, which is the last time I ran the iso setup. The setuperr.log file in that directory is fairly short, and does not have any of the Conx type errors. I don't see anything in it that would be helpful. See below.

     
    Michael Purcell, Apr 5, 2018
    #9
Thema:

Anniversary update fails with error 0xC1900101 - 0x20017

Loading...
  1. Anniversary update fails with error 0xC1900101 - 0x20017 - Similar Threads - Anniversary update fails

  2. The installation Failed is SAFE_OS Phase 0xc1900101-0x20017

    in Windows 10 Installation and Upgrade
    The installation Failed is SAFE_OS Phase 0xc1900101-0x20017: Hi all, I am out of ideas here on how to upgrade from 1803 to 1903, I have been googling and trying things almost all night to no avail. I learned this is some sort of driver that is outdated, what is the best way to find which driver it is? Are driver update programs like...
  3. Windows b1903 update, error 0xC1900101 - 0x20017

    in Windows 10 Installation and Upgrade
    Windows b1903 update, error 0xC1900101 - 0x20017: I am unable to upgrade a Windows 10 machine to the 1903 Feature Update, with the above error. The computer in question is an Acer Aspire 6500U All-in-One, with a Core i3-3110M CPU, 4GB RAM and a 500GB SSD, and war running build 1803. I have tried installing the 1903 update...
  4. Windows 10 Upgrade Failed - Error: 0xC1900101 - 0x20017

    in Windows 10 Installation and Upgrade
    Windows 10 Upgrade Failed - Error: 0xC1900101 - 0x20017: Hey there! I am trying to upgrade my Win10 18334 to 18836 using an ISO but I get this error 0xC1900101 - 0x20017 - The installation failed in the SAFE_OS phase with an error during BOOT operation Is there anyway to fix it? I uploaded my error log too! Thanks in advance!...
  5. Windows update can't be performed due to 0xC1900101-0x20017 error

    in Windows 10 Installation and Upgrade
    Windows update can't be performed due to 0xC1900101-0x20017 error: Good day community, I've trying to update Windows Insider preview but every time get 0xC1900101-0x20017 error. Sometime after months of trying Windows updates to a newer version but it's rare occasion. I can perform clean reinstall of Windows, so there is not a particular...
  6. 1703 to 1709 update fails with 0xC1900101 - 0x20017 error code

    in Windows 10 Installation and Upgrade
    1703 to 1709 update fails with 0xC1900101 - 0x20017 error code: Trying to update an existing Win10 1703 to 1709. It fails consistenly with the following error messages: ======================= We couldn't install Windows 10 We've set your PC back to the way it was right before you started installing Windows 10 0xC1900101 - 0x20017...
  7. Anniversary update error 0xC1900101 - 0x3000D

    in Windows 10 Installation and Upgrade
    Anniversary update error 0xC1900101 - 0x3000D: I tried installing the Anniversary update using the Media Creation tool and I get this error when I log back in after the setup reverted my installation: 0xC1900101-0x3000D The installation failed in the FIRST_BOOT phase with an error during MIGRATE_DATA operation Any...
  8. 0xC1900101-0x20017 Error during BOOT

    in Windows 10 Support
    0xC1900101-0x20017 Error during BOOT: [img] Windows 10 goes through the entire download/installation process, restarts, blue screens with a "system thread exception not handled (iastora.sys). It then restarts and shows this error for windows 10. Am I screwed? It goes back to the desktop and works somewhat (other...
  9. Windows 10 Anniversary Upgrade error 0xc1900101-0x20017

    in Windows 10 Installation and Upgrade
    Windows 10 Anniversary Upgrade error 0xc1900101-0x20017: Can anyone help me with this error? I get it every time when trying to get version 1607. I have checked many times; this is not related to any drivers but to something I do not understand. Here are included my Panther and Rollback folders. Sources.zip - Google Drive 61724
  10. Windows 1511 10586.545 Anniversary Udate fails 0xC1900101 0x20017

    in Windows 10 Installation and Upgrade
    Windows 1511 10586.545 Anniversary Udate fails 0xC1900101 0x20017: This x64 system was upgraded from Windows 7 Ultimate in August 2015. All the patches and updates have been applied successfully. I have eliminated all but one error. I have been working on this for days. I would appreciate any help resolving this error: 2016-08-24...
Tags: