Windows 10: Automatic Keyboard input language change

Discus and support Automatic Keyboard input language change in Windows 10 Customization to solve the problem; Hello, I'm using surface pro 4 in Korea which was bought directly from America. So, English, (United States) US Keyboard and Korean IME are both on... Discussion in 'Windows 10 Customization' started by KimDaveJinsoo, Sep 6, 2018.

  1. Automatic Keyboard input language change


    Hello, I'm using surface pro 4 in Korea which was bought directly from America. So, English, (United States) US Keyboard and Korean IME are both on language preference. When I write something, I start with Korean IME and shift Korean to English and vice versa with simple 'Alt' key. But, when deleting letters written in English from Korean IME keyboard, language preference automatically changes to US keyboard. It doesn't happen when I'm writing Korean. So, that makes me change language preference with 'Window' key + Space bar.


    I want the language preference be stable and unchanged unless I press 'window' + space bar.


    I tried to delete English language pack and set Korean as a default language but that makes me not to use Cortana, which was the primary reason I bought surface on Amazon.


    Thank you very much for your interest and please help me giving some brilliant solution.



    ***Moved from: Surface Pro 4 / Install, update, and repair.***

    :)
     
    KimDaveJinsoo, Sep 6, 2018
    #1

  2. Change input language based on keyboard?

    Hi Tim,

    Thank you for your interest in Windows 10.

    We understand that, you face issues with automatically switch input languages based on which keyboard on Windows 10 and I'd be certainly help you.

    For a better clarity of your issue, please answer these queries below:

    • Do you wish to perform this task, on any particular Windows

      application?
    • Why do you want to perform this task?
    The Automatically switch keyboard to match language of surrounding text option is only available in OneNote, Outlook, PowerPoint, Publisher, and Word.

    When the Automatically switch keyboard to match language of surrounding text option is turned on, it changes the keyboard's layout to the language that matches the language of text adjacent to the cursor's position.

    For more information, refer to the link below:

    Turn on automatic language options:
    Turn on automatic language detection

    Your default keyboard layout or input method is the one that’s automatically used with the language you see Windows in (for example, the QWERTY keyboard for American English). If you want to keep your Windows language the same but use a different keyboard
    automatically, follow these steps:

    1. Open Control Panel by entering Control Panel in the search box, and then

    tapping or clicking Control Panel.

    2.Enter Add a language in the search box, and then tap or click Add a

    language.

    3.Tap or click Advanced settings.

    4.Under Override for default input method, choose the keyboard layout or input method you'd like to be your new default, and then tap or click Save.


    For more information, refer to the link below:

    Change your language or keyboard:
    http://windows.microsoft.com/en-in/windows-8/add-language-keyboard

    Please feel free to contact us, if you face any issues with Windows.



    Thank you.
     
    AntonyJose, Sep 6, 2018
    #2
  3. Mohan B P Win User
    Input language English, Keyboard German

    Hi,



    I realize that you are facing the issue with the Keyboard layout in Windows 10, let me assist you.

    This issue might occur if the input method settings are not configured properly.

    I suggest you to follow the below steps and check if it helps.




    • Press Windows key + X key and select
      Control Panel from the menu.

    • Click on Clock, Language, and Region option.

    • Click on Language and click on
      Advanced settings
      in the left pane.

    • Select the required input in the drop down menu under
      Override for default input method
      .

    • Click on Save.


    If the required language is not listed, follow the steps below to add the required language and then perform the above mentioned changes.




    • Press Windows key + I
      key and select Time & Language.

    • Click on Region & language in the left pane, click on
      Add a language and select the required language from the list.


    Hope the information helps. Kindly write back to us with the updated status of the issue for further assistance on Windows. We will be glad to assist you.
     
    Mohan B P, Sep 6, 2018
    #3
  4. Automatic Keyboard input language change

    Language keyboard input doesn't equal output

    Hi,

    Language input may vary depending on the Input method set on your keyboard settings. To sort your concern, we suggest that you check if the desired input is set correctly by following these steps:

    • Type in Language and keyboard options on the search box.
    • Select the desired language that you're trying to set up.
    • Once you've selected the language, select Options.
    • Under Keyboards, select Microsoft IME and click
      Options.
    • Scroll down and select Open advanced settings.
    • A window will pop up. Under General tab, click the drop-down arrow for
      Input method and select the desired input.
    • Click OK.

    Let us know if you encounter any challenges along the process.
     
    Darwin Dim, Sep 6, 2018
    #4
Thema:

Automatic Keyboard input language change

Loading...
  1. Automatic Keyboard input language change - Similar Threads - Automatic Keyboard input

  2. My keyboard input method (language) sometimes changes itself

    in Windows 10 Ask Insider
    My keyboard input method (language) sometimes changes itself: I've disabled shift+alt, which works, since it doesn't change the keyboard input method when I press it. It might be Win+space, but I never get the popup, and I doubt I accidental press those keys. But can I disable this, just to make sure? Keysequence are all set to none....
  3. Keyboard shortcut to change language input not working

    in Windows 10 Customization
    Keyboard shortcut to change language input not working: I constantly change between Korean and English keyboard. So these are the ways to quickly change INPUT language of keyboard: 1. click the letter icon beside language bar in taskbar 2. press left Alt + Shift or windows logo + space I want the second one because it's...
  4. Keyboard Input change

    in Windows 10 Customization
    Keyboard Input change: Hello Support, I am a translator so I use different languages on my laptop. After a recent update, my computer is acting weird and changing the keyboard settings automatically. Even when I am working in a word document/RTF/ PDF, and select Hindi or Punjabi, it changes it...
  5. keyboard shortcuts input language

    in Windows 10 Customization
    keyboard shortcuts input language: I set keyboard shortcuts input language in order to quickly change from one language to another in my keyboard. I set ctlr+uppercase+1 and ctlr+uppercase+2 for the two languages I use. The problem is that after a while, I do not know why exactly, these settings are gone!...
  6. Keyboard input language issues.

    in Windows 10 Customization
    Keyboard input language issues.: my keyboard now produces é instead of backslash and É instead of question mark How do I repair ***Original Title: Keyboard*** https://answers.microsoft.com/en-us/windows/forum/all/keyboard-input-language-issues/50445bf1-de0a-4629-bf99-738c8bd491da
  7. Input language and keyboard language are different.How to set as default.

    in Windows 10 Customization
    Input language and keyboard language are different.How to set as default.: I use English as a language, but living in Spain I use a Spanish keyboard. (Sometimes I write in Spanish) Every time I turn on my Surface I have to manually change the settings to ENG/ES - ENG being the input language and ES being the keyboard input. Every time, if I...
  8. change input language

    in Windows 10 Customization
    change input language: Hello, I just bought a hp Pavillion 360. Since my first language is Japanese, I tried to change the input language from English to Japanese. The basic language on display has been changed to Japanese successfully. However, I still have a difficulty in typing in Japanese. The...
  9. Automatic Keyboard input language change

    in Windows 10 BSOD Crashes and Debugging
    Automatic Keyboard input language change: Hello, I'm using surface pro 4 in Korea which was bought directly from America. So, English, (United States) US Keyboard and Korean IME are both on language preference. When I write something, I start with Korean IME and shift Korean to English and vice versa with simple...
  10. Problem with input languages (changing)

    in Windows 10 Support
    Problem with input languages (changing): Hello to all! I have a weird problem and it doesn't happen all the time, so I can't reproduce it. I spotted it 7-8 months ago and it happens again and again, more and more. The truth is that it's more irritating, than an actual problem. I use a computer that has two...