Windows 10: CANON LIDE 210 - problem with WIA/TWAIN

Discus and support CANON LIDE 210 - problem with WIA/TWAIN in Windows 10 Drivers and Hardware to solve the problem; I own a Canon Lide 210 scanner since about 2011 which worked fine using WIndows 7 since then and still does. But after I upgraded all my computers (2... Discussion in 'Windows 10 Drivers and Hardware' started by sergiot, Sep 15, 2015.

  1. sergiot Win User

    CANON LIDE 210 - problem with WIA/TWAIN


    I own a Canon Lide 210 scanner since about 2011 which worked fine using WIndows 7 since then and still does.
    But after I upgraded all my computers (2 laptops and one desktop) to WIndows 10 it does not work anymore on the desktop to which it is connected.

    The newest scanner driver and application from Canon is installed.
    Sometimes it works for one or two pages. But then the scanner just stuck in the middle of the scan
    and the application just freezes. In the device manager I have no problem.

    As I thought it is the problem with the Windows upgraded from WIndows 7 to WIndows 10 and so
    I decided to install Windows 10 new. Result was the absolut same problem.
    On my both Notebooks (Lenovo T440p, HP 840 G1) the scanner works without any problem, just I don't use it with these devices.

    Sometimes I get the error code 2, 155,177 from ScanGear ... I also don't know how to use this values.

    :)
     
    sergiot, Sep 15, 2015
    #1

  2. Canon MP495 scanner function not recognised by Windows 10 - printer works OK?

    Same problem with Canon MP 210, it appears the driver lacks a part called "WIA" (I forget what that is an acronym for). And it is unclear to me whether it is up to Canon to change the driver or for Microsoft to fix Windows 10. As previous versions of Windows
    had WIA, it would look to be a Microsoft problem
     
    DonaldMacDonald-Ross, Sep 15, 2015
    #2
  3. canoscan Lide 210 with w10 "Internal Error" message claiming Scanner driver will be closed; cod 5,202,52

    Hi team, bought a new pc with w10 and after downloading the latets update from canon my Lide 210 worked the first time, but now I when i click the scan button I get the scanner warming up message, then an "Internal Error" message claiming Scanner driver
    will be closed; cod 5,202,52 Any suggestions ?

    OT:

    canoscan Lide 210 with w10
     
    RaiderMoto, Sep 15, 2015
    #3
  4. artemp Win User

    CANON LIDE 210 - problem with WIA/TWAIN

    I have new desktop PC with Windows 10 x64 preinstalled, also with ASUS motherboard. Two days ago I bought Canon Lide 220, installed the compatible drivers and ScanGear software from Canon website. I experience exactly same problem — the scan progress freezes and in Canon scan software I get the "2, 156, 177" connection error.
    Tested the scanner with Win 7 x64 PC — works perfectly with USB 2.0/3.0 ports and in all image color/DPI settings.
    Now I'm curious. It seems that the problem happens in Windows 10, or, maybe, the USB controller, which ASUS uses in their motherboards is also involved.
     
    artemp, Nov 2, 2015
    #4
  5. artemp Win User
    artemp, Nov 2, 2015
    #5
  6. eLPuSHeR Win User
    I also had troubles with my LiDE 210 scanner and my usb 3.0 ports (Intel x99 chipset). Tweaking usb mode in bios solved the problem.
     
    eLPuSHeR, Nov 2, 2015
    #6
  7. artemp Win User
    I've tried to connect the scanner to USB 2.0 and USB 3.0 ports — same issue appears. How exactly did you tweak the USB mode?
     
    artemp, Nov 2, 2015
    #7
  8. eLPuSHeR Win User

    CANON LIDE 210 - problem with WIA/TWAIN

    That's for Intel USB3 chipset. There were several options to choose from: smart auto, disabled, etc.. I chose one that seemed semi-auto, without completely disabling usb3 capabilities. Smart auto is a fiasco though.
     
    eLPuSHeR, Nov 3, 2015
    #8
  9. artemp Win User
    I think, I've solved the problem in my case. In device manager I've deleted all "USB controller" devices in order to ensure, that windows loads default Microsoft drivers after restart. Than I've restarted the PC and in BIOS changed "Intel xHCI Mode" to "Disabled". Haven't checked yet whether I have USB 3 support now, but, voil , the scanner works.
     
    artemp, Nov 3, 2015
    #9
  10. eLPuSHeR Win User
    If you set xHCI mode to disabled all your USB3 ports will act as USB2. I am going to check the setting in my bios.

    There are two options for xHCI in my bios. One is called something like "xHCI handshake" or something like that. It can be disabled or enabled. It's currently enabled.

    And the other one that allowed me to use my LiDE 210 scanner.
    xHCI mode: Smart Auto, Auto, Enabled, Disabled, Manual

    Currently set at Manual. I can still get usb3 speeds when using usb3 enabled external hard drive storage (reached 80mb/s reading).
     
    eLPuSHeR, Nov 4, 2015
    #10
  11. Tony62 Win User
    I had exactly the same problem with my Lide 210 scanner. I upgraded from Windows 8.1 to Windows 10 and started to get USB communications errors during scans.

    My motherboard is an ASUS Sabertooth Z97 Mark 2. The USB 3 drivers are from AsMedia.

    I upgraded the USB drivers from a third-party site, as I couldn't find any newer drivers on the Asus support site, but it did not help, I still had the errors.

    I contacted Canon and (after some persuasion) they tried to help, but they couldn't find the problem. They said nobody else has reported problems with the scanner on Windows 10 (ha, ha, ha, I don't believe them). They eventually said that the problem is due to my copy of Windows 10 because they accessed the Windows Error Logs and found errors there. Actually, almost every Windows PC will have errors in its Error Log so that's not the problem, because the errors in there were not related to scanning.

    So I did what was suggested in the answers to this post. I entered the BIOS settings, selected Advanced, then USB settings and set the 'xHCI mode' to 'disabled'. This sets all of the USB ports to be 2.0 rather than 3.0. The scanner then worked without errors.

    Although the scanner now works, I'm not happy with this solution because I don't want all my USB ports to be USB 2.0
    I recently upgraded to this motherboard to have the latest hardware, not legacy hardware.

    If anyone finds a better solution (such as driver updates) I would be very interested.

    Tony
     
    Tony62, Dec 5, 2015
    #11
  12. milic Win User
    +1 !!! this is definetely a driver issue: on my Asus card, USB drivers are INTEL and ... my 210 works perfectly in a Virtual Machine under Windows 7 and same drivers fetched on Canon site!!! *Mad*Mad*Mad but not under WIN10

    I understand Canon doesnt care enough to do this?!! and will develop drivers for future products but like some Epson printers in the past, next scanner will be HP but no Canon ...
    Not everything is disposable ... *Sad
     
    milic, Jan 5, 2016
    #12
  13. CANON LIDE 210 - problem with WIA/TWAIN

    I'm having the same issues with my Dell XPS 8900 and Canoscan LIDE210. Its maddening. The scanner continues to work on a Windows 7 machine I upgraded to Windows 10, but DOES NOT work on my new Dell XPS8900 that came with Windows 10 installed. I have looked for these settings in my BIOS and they are not there. Not sure what to do to find them?
     
    brenkworth, Feb 17, 2016
    #13
  14. makrameus Win User
    Just I have had the same problem with a clean installed Windows 10 (x64) on an ASUS H97-PLUS Mainboard. I get the Error-Codes 5,202,54 or 2,155,177 when I tried to use my Canon Lide 110.

    The answers in this post give me the right idea. After trying some BIOS-settings I get a very good solution: In the BIOS settings, selected Advanced, then USB settings I changed the ‘Legacy USB Support’ from [Enabled] to [Auto]. I don’t change the settings from 'xHCI mode' (it is still [Smart Auto] and EHCI-Handoff is [disabled]). After chancing the ‘Legacy USB Support’-setting the Lide 100 works seamlessly and USB 3.0 support is still available. Maybe this helps someone. *Smile
     
    makrameus, Apr 7, 2016
    #14
  15. eLPuSHeR Win User
    Thanks for the idea. I will need to test that further.
     
    eLPuSHeR, Apr 8, 2016
    #15
Thema:

CANON LIDE 210 - problem with WIA/TWAIN

Loading...
  1. CANON LIDE 210 - problem with WIA/TWAIN - Similar Threads - CANON LIDE 210

  2. Problem with 260ci WIA Driver

    in Windows 10 Drivers and Hardware
    Problem with 260ci WIA Driver: Tried downloading my pictures to my laptop but not possible but when trouble shoot, it shows 260ci WIA Driver has a driver problem. https://answers.microsoft.com/en-us/windows/forum/all/problem-with-260ci-wia-driver/3d131ae0-7421-4a19-bca7-371d6294f376
  3. Twain Drivers

    in Windows 10 Drivers and Hardware
    Twain Drivers: Is there a link to a location where I can download the Twain Driver for Windows 10? https://answers.microsoft.com/en-us/windows/forum/all/twain-drivers/f45625ae-896b-431c-966e-574d27b9f9cf
  4. problem with image driver 260ci WIA (SUB)

    in Windows 10 Drivers and Hardware
    problem with image driver 260ci WIA (SUB): How do you fix the driver 260ci WIA (SUB) Thank You. https://answers.microsoft.com/en-us/windows/forum/all/problem-with-image-driver-260ci-wia-sub/310df361-34b3-4dbf-b918-0daf1db024db
  5. Twain

    in Windows 10 Drivers and Hardware
    Twain: When I open a .jpg file, I first get this message: [img] . Is there a good web site for finding out how to do that (re-installing the Twain drivers) in Windows 10? 124680
  6. Twain

    in Windows 10 Performance & Maintenance
    Twain: When I open a .jpg file, I first get this message: [img] . Is there a good web site for finding out how to do that (re-installing the Twain drivers) in Windows 10? 124680
  7. Driver 260ci WIA

    in Windows 10 Drivers and Hardware
    Driver 260ci WIA: Troubleshoot cannot fix this problem. What can I do ? [ATTACH] https://answers.microsoft.com/en-us/windows/forum/all/driver-260ci-wia/fe3e8763-ef6f-497b-bead-c3fc5d6a0621
  8. Problem with Canon printer

    in Windows 10 BSOD Crashes and Debugging
    Problem with Canon printer: I have a problem - my printer Canon Pixma MG 3620 is not printing. I don’t know when this problem appeared, I just tried to print with no effect https://answers.microsoft.com/en-us/windows/forum/all/problem-with-canon-printer/4e6d3a54-dda7-4dfc-8dbf-83827f47dc3d
  9. WIA Driver

    in Windows 10 Drivers and Hardware
    WIA Driver: Hi I am trying to get my Canon i-sensys MF4780W printer's scanner to work from my laptop. I get message WIA Driver required to perform this action. I have windows 10, 64 bit. My WIA driver is running. Please can I get some advice on this matter. Marinda...
  10. WIA Driver for Canon MG8220

    in Windows 10 Drivers and Hardware
    WIA Driver for Canon MG8220: I read your entries for similar questions/issues with other Canon scanners. Mine worked perfectly, including last night, but after Microsoft did an overnight update, the message appeared, requiring a WIA driver and refusing to recognize my scanner. Can you suggest a link to a...

Users found this page by searching for:

  1. canon lide 210 WIA driver windows 10

    ,
  2. canon lide 210 scanner problems