Windows 10: Can't access NAS by name

Discus and support Can't access NAS by name in Windows 10 Network and Sharing to solve the problem; Yesterday I did a clean (re)install of Windows 10. All seemed ok, but today I cannot access a NAS disk by name. I can access it by IP address, and... Discussion in 'Windows 10 Network and Sharing' started by pokeefe0001, Apr 16, 2016.

  1. Can't access NAS by name


    Yesterday I did a clean (re)install of Windows 10. All seemed ok, but today I cannot access a NAS disk by name. I can access it by IP address, and nslookup correctly resolve both name and addresses. But if I try to access \\MyBookLive (I know, - a cleverly original name.) - I get an error saying "Windows cannot access \\MyBookLive", giving an error code 0x80004005.

    For the time being, I've mapped the IP address so I can access the drive, but I recall getting security warning popups in the past when I've done that so I hope this is temporary. And the IP address is set DHCP so I can't guarantee it will stay the same.

    Any idea how to resolve this?

    :)
     
    pokeefe0001, Apr 16, 2016
    #1

  2. homegroup with windows 10 & windows 7.

    On the windows 8.1 machines: When I first tried to access the NAS network credentials were asked for. I signed in with the user names and passwords established in the NAS and checked for them to be saved. This provided me with seems access. By the way
    the machine already saw the NAS on the network. The NAS was is setup as DHCP, not static.

    As for Windows 10: The machine doesn't see the NAS on the network (the NAS has all the same settings and passwords). Only sees it after a reboot, power cycle or factory reset of the NAS; for a limited time and then it can't find it again. When I accessed
    the NAS through the app on the win10 machine, network credentials were asked for given and saved, access to the NAS was given. When win10 sees the NAS, I have access to it.

    Therefore the credentials must be established.

    If there is something extra to do in win10, I'm not aware of it. If the NAS has to be a static IP, I'm not aware of it. If you mean something else or have further direction, like how to create said network credentials, I'm reading.
     
    LorenCarlson, Apr 16, 2016
    #2
  3. PFriedl Win User
    Windows 10 can't access NAS by IP \\192.168.1.xxx or by name \\NASName - HELP!

    This started several weeks ago. I have a Buffalo Storage 1TB NAS that has been working for a couple years, and is still accessible by other systems in my house.

    However, my main PC all of a sudden couldn't access the drive by it's network name (\\BigBuffalo). Now today, I can't even access it by its IP address: (\\192.168.1.155)

    To be clear, I can access the drive via browser, and other systems in my house have no issues accessing the drive. I've seen multiple fixes that simply don't work. PLEASE HELP. I need access to my NAS badly!
     
    PFriedl, Apr 16, 2016
    #3
  4. AndreTen Win User

    Can't access NAS by name

    WD has some useful applications. Try WD quickview, it will give quick access to state of drive and also a way to go to drive.
    Just a suggestion.

    Also host name may have changed with some firmware updates.
     
    AndreTen, Apr 16, 2016
    #4
  5. The WD application that maps drives seems to use the address rather than name of the server. Two other PCs are accessing the server by name so I'm pretty sure the name hasn't changed. (But that doesn't mean I used the right name or specified it correctly in the Map process.) I'll dig around some more.
     
    pokeefe0001, Apr 16, 2016
    #5
  6. AndreTen Win User
    Do you have network discovery turned on? New installations of Windows sometimes needs few days to get all connectivity...
     
    AndreTen, Apr 16, 2016
    #6
  7. Yes, I have network discovery turned on ... at least on the place you showed. I don't know about other options I might have wrong. In a detail display of the Network part of the file explorer display, Windows says it uses SSDP to discover the NAS server. I have no idea if that's what I should be using (or how to change it if it's not right).
     
    pokeefe0001, Apr 16, 2016
    #7
  8. AndreTen Win User

    Can't access NAS by name

    It most probably doesn't matter.

    Can you connect to your WD and check name? I can connect to mine with clicking on MyBookLive icon in windows explorer, or by giving IP number in browser. Check for name setting (if you have change it) or for quick solution to give it static IP number.

    Edit: also download and run WD Discovery app from WD site. It may help.
     
    AndreTen, Apr 16, 2016
    #8
  9. AndreTen Win User
    I found a thread on WDC forums and some possible solutions to your problem.

    If you didn't already, you ca read the from this post on...
     
    AndreTen, Apr 17, 2016
    #9
  10. I've now read that post - I had missed it. I'm a little reluctant to mess with the LAN Manager Security Level because
    • it worked on the now problematic PC before I did a clean reinstall of Windows 10 (although sometimes not right after a reboot)
    • it works correctly on 2 other PCs - 1 running Win10, the other running Win7. I didn't have to do anything special on those PCs.
     
    pokeefe0001, Apr 17, 2016
    #10
  11. AndreTen Win User
    Must agree with you. It works for me on Windows Insider and on RTM Windows 10 with clean install.

    Try first with some of the WDs tools. I will come back on the (my) afternoon.
     
    AndreTen, Apr 17, 2016
    #11
  12. bro67 Win User
    Just means that the Tables are screwed up and need flushed. Unplug the router and make sure that it flushes the tables, along with reset the Winsock on the machines.

    Names are great when a device may have a DHCP vs. Static IP. If the device has a static IP. Use that, vs the name.

    Western Digital does some screwball stuff with their version of Samba for the embedded Linux they use.
     
    bro67, Apr 17, 2016
    #12
  13. Can't access NAS by name

    Ha! That did it. Maybe because the reinstall of Widows changed the "Computer Name" associated with the PC? For whatever reason, it worked.
    I could give the NAS drive a static address, but I'd rather refer to it by name. Windows gives an irritating warning popup (saying things from the internet can't be trusted) when executing a program from a NAS drive accessed by IP addr rather than name. Since save all installation files for installed software on my NAS so I get that warning a lot when the drive is accessed by addr.
     
    pokeefe0001, Apr 17, 2016
    #13
  14. bro67 Win User
    Internet Explorer and edge will do that, along with a Firewall.

    I have those devices that need to be set as a static, like my printer, NAS, Access Points, because I use the IP's in the shortcuts for them.
     
    bro67, Apr 5, 2018
    #14
Thema:

Can't access NAS by name

Loading...
  1. Can't access NAS by name - Similar Threads - Can't access NAS

  2. Can't access NAS drives in Windows 10 Pro

    in Windows 10 Network and Sharing
    Can't access NAS drives in Windows 10 Pro: This is a strange fault as it happened all of a sudden, I shut down the PC one night when everything was fine, then the following day after bootup I couldn't access the NAS drives although they do show in Windows File Explorer, I just get the error 0x80070035 The network path...
  3. Can't see the NAS

    in Windows 10 Network and Sharing
    Can't see the NAS: Hi, I just bought a Surface Book2 (Win10 and update), I can't find my NAS or any other device through my network. I have checked through the advance network sharing setting and also adjusted the FDPHost & FDResPub into automatically. The NAS & other devices can show...
  4. Can't access NAS files in file explorer

    in Windows 10 Network and Sharing
    Can't access NAS files in file explorer: Hi, I have a small home office with two computers. I decided to invest in a NAS so that the two computers have access to the same files. The newer computer, a lenovo AIO, had no problem connecting to the nas through a network switch which both computers are connected to,...
  5. Can't see the Computers on WorkGroup, or access an NAS shared folder

    in Windows 10 Network and Sharing
    Can't see the Computers on WorkGroup, or access an NAS shared folder: Hi, I have a home network that is a simple workgroup. There is an NAS that has some shared folders on the network, with some media servers, etc. I have a desktop computer attached to the router through cable, some laptops, tablets, cell phone, etc. that are attached to the...
  6. Can't access NAS without internet

    in Windows 10 Network and Sharing
    Can't access NAS without internet: My access to my Synology NAS is not working anymore since I have moved. At my new place, I don't have internet (yet) and it looks like that is tripping off Windows (maybe it increased security settings???). I have my folders mapped, I used to be able to access my NAS folders...
  7. No Access to NAS Drive

    in Windows 10 Network and Sharing
    No Access to NAS Drive: Hi Folk, I can see that this seems to be a common problem on here! I have a Lacie cloudbox NAS drive. On WIn7 pro it worked just fine. Windows say the drive in the network group and I could access it like a normal folder. After I did the Win10 upgrade and it initially...
  8. Windows Explorer Can't Access NAS Storage

    in Windows 10 Network and Sharing
    Windows Explorer Can't Access NAS Storage: I have a WD EX2Ultra NAS on my home network. Everything worked perfectly until a recent Windows 10 update to Version 1703 Build 15063.540 on my laptop. Now my Windows 10 laptop cannot access the HDs in the NAS. But, my wife's Windows 7 desktop still has access to the NAS HDs....
  9. NAS looses DNS name

    in Windows 10 Network and Sharing
    NAS looses DNS name: Since two weeks, I can not find my QNAP NAS with the name, only with the ip address. After a forced restart, everything is back. But after the automatic shut down over the night and automatic restart the day after, the problem is back. The only difference between the...
  10. Can't Access NAS from Windows Explorer

    in Windows 10 Network and Sharing
    Can't Access NAS from Windows Explorer: I have 2 NAS drives connected to my network, one is a Buffalo NAS and the other is a LaCie NAS. When I try to access the NAS on my Windows 10 Pro PCs, I get a message stating Error code 0x80070035 The network path was not found. I can access the management console for...