Windows 10: Can't connect to shared external USB from Linux/Android,can from Win10

Discus and support Can't connect to shared external USB from Linux/Android,can from Win10 in Windows 10 Network and Sharing to solve the problem; I've got a weird one that I can't seem to solve. I have a Windows 10 Home desktop with a permanently attached external USB HD. The internal... Discussion in 'Windows 10 Network and Sharing' started by gtr33m, Oct 11, 2016.

  1. gtr33m Win User

    Can't connect to shared external USB from Linux/Android,can from Win10


    I've got a weird one that I can't seem to solve.

    I have a Windows 10 Home desktop with a permanently attached external USB HD.

    The internal drives are share from with everyone privileges at a folder level and a drive level (for testing). Homegroup is turned off completely.

    From a Windows 10 machine I can access all shares without issue. Read and write files.

    From any non Windows machine I can access the internal drive (c*Smile including the public folder, but not the external drive. The shares are seen, but trying to connect produces an unknown error.

    I've tried replacing permissions on the external drive at the root level and replacing them on all child objects with no change. As far as I can tell the everyone read and write permission essentially removes security, so I don't think it's a username and password issue.

    I have no meaningful error messages from android or linux, but have not checked windows.

    Anyone have any ideas?

    :)
     
    gtr33m, Oct 11, 2016
    #1
  2. fanless Win User

    Share an external USB Drive on WINDOWS10,have lots of BUG!


    Can't connect to shared external USB from Linux/Android,can from Win10 [​IMG]


    PC(win8/win10)---USB HUB---USB external drive WIN7/WIN8/WIN10 can connect, but XP/ES File Explorer

    /X-plorer can't connect

    PC(win8/win10)---USB external drive both WIN7/WIN8/WIN10/XP /ES File Explorer/X-plorer can connect

    PC(win8/win10)---sata drive both WIN7/WIN8/WIN10/XP /ES File Explorer/X-plorer can connect

    PC(win7)---USB HUB---external drive both WIN7/WIN8/WIN10/XP /ES File Explorer/X-plorer can connect

    i have changed 3 usb hubs, i got the same result.

    i think this is a very very serious bug of WIN8/WIN10。

    i didn't test whether linux samba could connnet (PC(win8/win10)---USB HUB---USB external drive ), but i think linux would not connect it neither.

    there are a few NAS device only have one USB, so,must use USB HUB.

    you can send me email: *** Email address is removed for privacy ***
     
    fanless, Oct 11, 2016
    #2
  3. jopemoro Win User
    Cannot access USB shared drives after upgrade to Windows 10

    Title says it all.

    I had external USB drives shared under Win8.1, accessible from a WD TV Live box through windows shares.

    Since upgrading to Win10, I can't see the folders shared in those USB drives anymore from the WD TV Live. I can see folders shared from internal drives, though. I've tried removing the shares and recreating them, to no avail.

    Anyone knows if I am missing something, or did Win10 break something with USB drive sharing?

    I only installed Win10 a couple of days ago, so I can go back to Win8.1 if needed. Would rather not go through the process, but this is a deal breaker for me Can't connect to shared external USB from Linux/Android,can from Win10 :(

    Tx in advance!
     
    jopemoro, Oct 11, 2016
    #3
  4. bro67 Win User

    Can't connect to shared external USB from Linux/Android,can from Win10

    It helps to know what this USB drive is hooked into, along with what brand and model that it is. Nothing really that we can do unless we know how it was formatted, how it is connected to either network or the computer and were you able to use it before this problem occurred.
     
    bro67, Oct 11, 2016
    #4
  5. PKH
    pkh Win User
    I have searched for a solution to my problem and come to this. op seems to have the exact same problem as mine but too bad there is no fix here.

    My problem is that i just bought a cenovo (apple tv size) mini pc pre-installed with win 10. When I shared any folder from usb external hard drives or usb thumb drives, the cenovo and shared drives can be seen from android phones and tablet using es file explorer, but the folder can't be opened and nothing happen when click. on the other hand any shared folder from the cenovo internal c: and sd card inserted can be access perfectly from android. i have compared all the share permission and security between those shared folders and see no difference. yet i can easily open the shared folders from c: and sd card from android but not anything connect through usb. i am puzzled.

    What is more puzzling is that i have a few desktop windows pc ranging from vista to 10 and they can all access any shared folders from Cenovo no matter from C:, sd card or usb. it is only from android and cenovo usb that is causing share problem. and my android phones and tablet can access any shared folders from all of my desktop pc including win10 perfectly no matter internal or usb.

    I have tried other android file managers and at least they gave me some form of error message when i click those cenovo usb shared folder. astro file manager gives the error "blueerror gen_failure". another filer manager gave error "0xC0000205". May be these means something to experts here.

    I am running out of idea after all the googling. Hope someone had run into a similar situation and found a fix. Thanks in advance.
     
  6. bro67 Win User
    Limitations of the hardware, since it can run both Android os and windows. most likely they are running windows inside a virtual machine on the android os that runs that unit.
     
    bro67, Nov 18, 2016
    #6
  7. valihrach Win User
    Tried it, it seems that es file explorer (smb client) cannot connect to admin shares (c$, d$ etc), whilst windows clients can. you have to share the root of your external disk again (properties - sharing - advanced - add) using new sharename, then it will be accessible from non-windows clients. (At least it should, I don't know whether it work with Anniversary Update installed, v1511 is ok.)

    Also non-ASCII charaters in the sharename may cause problems while connecting, avoid them.
     
    valihrach, Nov 18, 2016
    #7
  8. PKH
    pkh Win User

    Can't connect to shared external USB from Linux/Android,can from Win10

    Thanks for all the prompt replies. *Smile

    My Cenovo is a Win10 only machine and not a dual boot. Don't know if that makes a difference.
    @valihrach
    I have tried your method to share the whole drive (both USB external hard disk and thumb drive) and gave it a new simple share name but no difference. Some more testing shows that the same problem actually occurred with my desktop Win10 using USB thumb drive, but share is fine with USB hard drive. Weird.

    Share from Cenovo's whole internal C: and D: (SD card) works straight away, which shown as C and D in ES File Explorer, as well as the Users folders.

    Is that something Win10 is waiting to be fixed? There is no such problem with Win7 and Android so may be I have to ditch Win10 for now. So sad if there is no simple fix. *Sad Hope to try more suggestions before giving up.
     
  9. valihrach Win User
    Strange, but I think the problem lays in some combination of settings. Please try this:
    - make sure you have Homegroup disabled
    - make sure you have Simple file sharing (Use Sharing Wizard) disabled
    - create a new share using Advanced Sharing button
    - check if Everyone has at least Write in BOTH the Share Permissions AND the NTFS Permissions, or add it
    - use the Admin account (with right password) to connect to the share from ES FIle Explorer.
    Can you connect to the share this way?
     
    valihrach, Nov 18, 2016
    #9
  10. bro67 Win User
    It has nothing to do with Dual boot. That unit is a Android device that they are running Windows on top of the Core Android OS built into it. It will not work like a real computer that will just tun Windows10, because it has to pass through the Android Layer.

    It is a cheap Chinese knockoff that if you do a search, hundreds of people that bought it to use for Windows are dealing with issues on it.

    You could buy a decent Shuttle with the Atom CPU that would run circles around that Chinese knockoff. Just because the price is decent, does not mean that it is going to even run. Most people do not post reviews on this stuff, because they tend to get embarrassed that they threw away hard earned money on something that does not work and has no backing from any manufacturer.
     
    bro67, Nov 18, 2016
    #10
  11. PKH
    pkh Win User
    Thanks again.
    @bro67
    I also have that thought before but since more testing shows that the same problem arise on my desktop HP 8100 running Win10 when sharing a USB thumb drive to my Android phones, but no problem sharing a USB hard drive from it. Usually I don't share my thumb drive so I don't know about this problem until now. When I boot the same HP 8100 into Win7, all share works perfect to Android phones and all PC. So I can't help thinking it is Win10 setting related.
    @valihrach
    I have follow all your steps but still no luck. *Sad Only difference is that I can open the Admin$ folder from Android phone.

    To put it short, using my Android phone and tablet, all shared folders from my Cenovo mini pc's internal C: and D: (SD card) works, but no shared folder from any plug in USB storage can be opened. Again there is no sharing problem between any Win PC.
     
  12. valihrach Win User
    Hi pkh,

    try this combination: Win10 v1511 (not the AU) and ES explorer in attachment (please extract it from zip); it works for me like a charm (except the admin shares). Tested on both USB3 external enclosure with 4TB drive and on 64GB USB3 flash drive, both formatted as NTFS. I have anonymous sharing fully disabled and no homegroup created.

    Also you may enable Account Logon audit in gpedit.msc if you have Pro version. If you have Home, please follow this thread: How to Enable (gpedit.msc) in Home and Starter Editions of Windows 7 and Later - AskVG and check your Security log.

    If you can connect to the share on external drive from other Windows but not from other SMB client (I assume the same login name and pasword used from both) then incompatibility of SMB client may be the problem but I don't know the exact cause - mine is working, you may test it too.
     
    valihrach, Nov 19, 2016
    #12
  13. PKH
    pkh Win User

    Can't connect to shared external USB from Linux/Android,can from Win10

    Thanks valihrach for your time and help. Looks like it is not a simple straight fix. Will spend more time with it later. Thank you so much.
     
  14. jimbo45 Win User
    Hi there

    If the USB can be mounted on the Linux device then you should be fine

    Do the following as Root on the Linux device

    1) Create a read / write directory in Linux directory /mnt say DV (data volume)

    2) if the device is say /dev/sdd then mount it : mount /dev/sdd -t auto -o rw /mnt/DV
    (If device is already mounted via automount etc simply unmount it first : umount /dev/sdd before doing step 1.

    Auto means you don't have to specify the file system --even if it's FAT32 or NTFS but:
    Ensure though that package ntfs-3g is installed if the file type is ntfs. Most distros have it by default but not all e.g Centos - so you might have to install it with your package manager. Linux can read / write to NTFS these days.

    3) check now you can create a file on /mnt/DV you might need to be root to do it first time.

    4) allow permission of access you want to directory and all subdirectories (via permissions / properties).

    5) add a share /mnt/DV to your SAMBA smb file (smb.conf) for example :

    [Datastore]

    comment VM's, Backups, data vol
    path = /mnt/DV
    guest ok = yes
    writeable = yes
    browseable = yes

    6) restart samba (usually two services required smb and nmb (or smbd nmbd depending on your distro).

    Now if the file is attached to windows only then things go bonkers with some smart TV's etc as they just won't connect so I'd solve the problem from the Linux end as above - it usually always works.

    I've had external USB Hdd's on Windows that just aren't seen by ez file explorer or smart TV's - but when attached to a Linux machinre either via a VM or a real machine no problem at all with connections. Linux BTW handles NTFS file systems these days for both read and write.

    Works fine too on things like Amazon Fire stick / TV box - if you do it the Linux way -- VLC on the remote device can see and play files on your external USB.

    VLC is standard on Amazon fire sticks / TV boxes- often better than PLEX as it can play more codecs without transcoding being needed. Plex is supported BTW on those Firesticks (and Google chromecast type of devices too).


    I've found creating a small Linux VM just for sharing HDD's and multimedia is well worth it -- create the external HDD as ext4 - that file system is so much more efficient than NTFS that the overhead (very small) of the VM when you want to access the files on Windows via samba is well worth it. Of course though if you have other windows machines that can't access your Linux samba server then of course you'll have to stick with NTFS if you need to remove the HDD and connect to other computers from time to time.


    Cheers
    jimbo
     
    jimbo45, Apr 5, 2018
    #14
Thema:

Can't connect to shared external USB from Linux/Android,can from Win10

Loading...
  1. Can't connect to shared external USB from Linux/Android,can from Win10 - Similar Threads - Can't connect shared

  2. delete linux mate from USB

    in Windows 10 Network and Sharing
    delete linux mate from USB: downloaded Linux Mate onto my USB using Image Burn. Now unable to save file into USB or delete Linux file from USB using "reformat". Whats the solution??? https://answers.microsoft.com/en-us/windows/forum/all/delete-linux-mate-from-usb/e3a9dca2-105f-4eba-9bfc-d92ae3ca7680"
  3. Can't boot from USB

    in Windows 10 Installation and Upgrade
    Can't boot from USB: Hello. I had planned to perform a clean install of Windows 10 (I have a 32-bit now and want to change it to 64-bit). However, I cannot find any options for accessing my USB upon boot up, after going to Settings>Recovery>Advanced Startup>Restart Now. I also have the Legacy...
  4. Can't boot from USB while HDD is connected

    in Windows 10 Installation and Upgrade
    Can't boot from USB while HDD is connected: I'm trying to boot a non-working-windows laptop from an external HDD with bootable windows installation in order to access repair tools, and it is working fine as it is tested on a working machine. The boot order in BIOS is fine, the external HDD is set as the 1st priority...
  5. Windows HOST, attach Linux external USB to Linux VM

    in Windows 10 Virtualization
    Windows HOST, attach Linux external USB to Linux VM: Hi there I usually run a LINUX HOST for testing Windows VM's - but I need to test some new releases of various Linux distros so I've created some VM's --easy enough and running them on a Windows Host. However I can't attach a USB drive with a Linux file system (XFS) to...
  6. Can't boot from USB

    in Windows 10 Drivers and Hardware
    Can't boot from USB: I have a Hp pavillion. I made a usb flash boot drive with acronis 2016 I cant boot to it. This tutorial says that I must boot from within windows 10. I dont see in this post how to do that I only see it fort 8 is 8 the the same. ? 53114
  7. Can't connect to SMB shares from 7..?

    in Windows 10 Network and Sharing
    Can't connect to SMB shares from 7..?: Hello, I installed 10 on a PC with same username & pass as usual. Then from 7 I tried to reach d$ but it ask me pass & login, while normally it doesn't ask any (since it's the same!).. Can't understand that, would you please explain me/us..? Thanks! 33097
  8. Shared Folders from External HDD Folders Not Accessible in Android

    in Windows 10 Network and Sharing
    Shared Folders from External HDD Folders Not Accessible in Android: All of my shared folders from internal HDD are accessible from my android phone via es file explorer (latest version). But all of my shared folders from external HDD Folders visible but NOT accessible! I'm really out of ideas. I have already tried removing workgroup....
  9. Installing Win10 Pro from USB

    in Windows 10 Installation and Upgrade
    Installing Win10 Pro from USB: Hi Have another issue with upgrading OS on new laptop that has Win10 Home. I am going to double check that I have indeed burned the correct iso but I think I have. The laptop goes through the install routine from the USB but still shows windows home as activated rather...
  10. Can't boot x64 Win10 setup from USB or DVD

    in Windows 10 Installation and Upgrade
    Can't boot x64 Win10 setup from USB or DVD: Trying to do a clean install booting from DVD or USB created w Media Creation Tool: Windows 7 x86 and x64 boots from DVD or USB Windows 10 x86, boots from DVD or USB. Windows 10 x64, from DVD loads the blue window and then nothing more. Have to switch off/on to get out...