Windows 10: Can't enter BIOS/UEFI or boot from a device

Discus and support Can't enter BIOS/UEFI or boot from a device in Windows 10 Support to solve the problem; Hello! There is a frustrating situation on my new laptop Lenovo ideapad 3, any help would be much appreciated. I starterd a clean install of... Discussion in 'Windows 10 Support' started by igork, Feb 10, 2021.

  1. igork Win User

    Can't enter BIOS/UEFI or boot from a device


    Hello!

    There is a frustrating situation on my new laptop Lenovo ideapad 3, any help would be much appreciated.

    I starterd a clean install of Windows 10, booted from USB, and in the setup I deleted all the existing partitions (which is my primary suspect for the cause of my problem), made a new one and the installation started. An error occured and I had to cancel the installation. I did another attempt which was succesful, but I set up boot order from a simple boot manager, not from BIOS/UEFI. Windows run normally but I can not enter BIOS/UEFI to make some changes. What I have tried:

    1. Pressing all the hotkeys upon startup. For Lenovo it is F2, but I tried every F key, with and without Fn key.
    2. In the Recovery tab, Advanced startup, Restart now option there is no restart to UEFI firmware option. It is simply missing.
    3. From CMD I have tried shutdown /r /fw. Did not work.
    4. I wanted to boot from USB Windows installation disk so I could manualy recreate EFI drive, but a) I can not set to boot from USB in BIOS/UEFI, and b) there is no Use this device option Advanced startup options. I have failed to boot from USB,and do not know if there is a workaround.
    5. I did a full reset of the Win 10 pro from Advanced startup options. Use this device and Restart in UEFI firmware options are still missing.

    I did not open the notebook to mess with the BIOS battery and clear the CMOS because it has valid ongoing warranty.
    The computer supports UEFI, but under Sys info it says that it is in Legacy mode.

    Thanks for all the answers in advance!

    :)
     
    igork, Feb 10, 2021
    #1
  2. erixx Win User

    Sabertooth 990fx won't boot to windows logo, it shuts down

    to boot and enter bios and load windows, any todays PSU (with the correct plugs) will work, AFAIK

    to enter BIOS only low wattage is used.
    Then, during boot, the HDD and a bit later the videocard card start to demand juice, then the other devices and periphericals... so the total demand during boot up is incrementing step by step, that's why a failure halfway could indicate a PSU problem....
     
    erixx, Feb 10, 2021
    #2
  3. UEFI boot options disappeared from BIOS; now getting reboot and select proper boot device

    In short, I need to get the system/BIOS to allow UEFI booting of the SSD.

    Computer started up today with default BIOS settings.

    • Only SSD 1(Windows boot) and SSD 2 were listed in BIOS; HDD 1 and HDD 2 were not visible
    • System would not boot. Gave the 'reboot and select proper boot device' message
    • Boot menu has no UEFI/EFI (or Windows Boot Manager) entries anymore
    I went into Partition Magic/Gparted and confirmed :

    • All drives are still showing
    • All drives' data is in tact [EFI volume/partition is still listed (and can be browsed/files accessible)]
    Gparted print out (note dev/sda2 apparently that is normal behavior) :

    /dev/sda1 (locked) EFI System Partition--Fat32--/media/sda1--100.00mb--46.81MiB--53.19MiB--boot,esp
    /dev/sda2 (exclamation mark) Microsoft reserved partition--unknown file system--no mount point--128.00MiB--unused spaced--msftres
    /dev/sda3 basic data partition--ntfs--/media/sda3--118.58GiB--70.78GiB--47.80GiB--msftdata
    /dev/sda4--ntfs--/media/sda4--450.00MiB--327.71MiB--122.29MiB--hidden,diag



    As I am able to boot Windows installation from USB, I tried the standard startup repair. It said it was not able to fix any problems.

    Next I tried to repair the EFI with Diskpart in the shell:

    • sel vol 1 (note that Diskpart states EFI partition is 'hidden')
    • assign letter=z:
    • cd /d z:\EFI\Microsoft\Boot\
    • bootrec /fixboot
    • bcdboot c:\Windows /l en-us /s vz /f ALL
    It completed all tasks successfully. Unfortunately that did not work.

    Other things I have tried :

    • Removing CMOS battery and replacing with a new one - my HDD started showing up again after doing this.
    • Using the old MBR commands(in hopes it would force the Windows startup repair to recognize and fix a problem)
    bootrec /fixmbr
    bootrec /fixboot
    bootrec /scanos
    bootrec /rebuildbcd​
    • Loaded BIOS 'optimized'/defaults (the system did this already once before, hence why I am in this situation, though doing it manually seemed like an option worth trying. Note that after doing this and restarting the system, HDD's stopped showing again)
    • Removed new CMOS battery and left it out of the system for thirty minutes
    • Formatted EFI and msftres partitions, then rebuilt the EFI boot records
    In summary, am looking to force the BIOS to see the EFI partition on the SSD boot drive, as it is not an option any longer.
     
    newconroer, Feb 10, 2021
    #3
  4. Can't enter BIOS/UEFI or boot from a device

    UEFI remove unwanted boot entries from BIOS solved easily

    OK, FINALLY I figured it out. It would appear as though the last few people who used UEFI Shells died years ago, and I'm the only one left. But in case there exists a person who owns a Dell XPS 17 L702x system, here's how you delete boot entries from the BIOS.

    Step 1. Download the Phoenix Technologies UEFI Shell: Dropbox - UefiShellX64.efi - Simplify your life

    Step 2. Format a USB flash drive in FAT32, and create a folder named "EFI", and inside that, create another folder named "boot".

    Step 3. Copy and paste the UEFI Shell utility into the boot folder, and rename the file "bootx64". The full path should look like this: EFI\boot\bootx64.efi

    Step 4. Reboot your computer, and rapidly tap the "F12" key on your keyboard until you get to the Boot Menu. Scroll down to "Setup" and hit Enter.

    Step 5. Now that you're in the BIOS, use the arrow keys on your keyboard to scroll to the Advanced tab. From there, scroll down to Boot Configuration. In Boot Configuration, set UEFI Boot to "Enabled" and Legacy Boot to "Disabled". Hit the Escape key to go back and then go to the Exit tab. Select the option to "Exit SAVING Changes", and go back to rapidly hitting that F12 key on your keyboard.

    Step 6. Once at the Boot Menu, select your USB Mass Storage Device, and you'll boot into the UEFI Utility.

    Step 7. From there, type: bcfg boot dump -b

    This will display a list of boot entries. Take careful note of the "Option" numbers, and make note of the one that you want to delete. In my case, it was Option 05 with a description of "RAID Array". DO NOT CONFUSE OPTION NUMBERS WITH THE BOOT HEX NUMBERS!!! For example, Option 05 had a hex number of "Boot000A". Others will have such numbers as "Boot0005". That is NOT the number you want. You want the option number. It's a two character number after the word "Option". Hit the "Enter" key until the list has fully displayed.

    Step 8. Once you know the Option number of which boot entry you want to delete, simply type this command:

    bcfg boot rm XX (where XX is the Option number of the entry you want to delete).

    For example, in my case, my RAID entry was Option 05. Therefore, my command looked like this:

    bcfg boot rm 05

    Step 9. Hold the power button to turn off your computer (I don't think there's a "shutdown" command for UEFI Shells).

    Step 10. Turn your computer back on, and go back to rapidly tapping that F12 key while doing it. Once at the Boot Menu, go back into Setup. Once in the BIOS, go back to the Advanced Tab, scroll down to Boot Configuration, Set UEFI Boot to "Disabled" and Legacy Boot to "Enabled". Don't forget to exit saving changes.

    And that should do the trick. Hopefully I helped at least one person with this post.
     
    Crazy Gaston, Feb 10, 2021
    #4
Thema:

Can't enter BIOS/UEFI or boot from a device

Loading...
  1. Can't enter BIOS/UEFI or boot from a device - Similar Threads - Can't enter BIOS

  2. Unable to Boot to OS or BIOS/UEFI

    in Windows 10 Installation and Upgrade
    Unable to Boot to OS or BIOS/UEFI: * [Full discloser] I know this is a Microsoft forum, but this also involves Linux so any help is appreciated. So I thought it'd be a fun idea to dual-boot Linux Lite alongside my Windows 10 pro partition. It Started off fine, but I noticed when I restarted to go back to...
  3. Can't enter UEFI

    in Windows 10 Support
    Can't enter UEFI: ASUS ROG GL531GT-RS53 Windows 10 Pro sysinfo > Version 10.0.19041 Build 19041 winver > Version 2004 (OS Build 19041.746) (laptop purchased with Home, paid for & upgraded to Pro) Left the laptop running last night (just closed the lid - set to "do nothing") and when I woke...
  4. Can't boot uefi

    in Windows 10 Installation and Upgrade
    Can't boot uefi: Hello, Recently I helped a friend with upgrading to an SSD and installed Windows 10 Pro. I used a custom .iso and burned it using Rufus gpt. I set the computer to boot uefi, disabled secure boot. The computer worked perfectly, however after sometime they started getting a...
  5. Can't enter bios

    in Windows 10 Ask Insider
    Can't enter bios: Windows 10 with wireless mouse and keyboard and HCl motherboard. Unable to enter bios mode as pc starts directly from blue windows screen. How to enter the bios? I.e. removing any hardware, already tried cmos. submitted by /u/CJ__47 [link] [comments]...
  6. Can't boot after changing UEFI to Legacy from BIOS F2 menu.

    in Windows 10 BSOD Crashes and Debugging
    Can't boot after changing UEFI to Legacy from BIOS F2 menu.: Toshiba satellite p75 A7200. Windows 10 is not recognized and i see empty black screen. How can i revert that change. Nothing gets booted. Toshiba logo is frozen. Hard drive detached goes to single underscore screen. No F button is working with windows 10 drive. Holding...
  7. Bios order of boot and UEFI

    in Windows 10 BSOD Crashes and Debugging
    Bios order of boot and UEFI: Hi there, what is the optimum order of "boot" you need to set the bios at for a quicker start-up? And where do you place the UEFI component in relation to the actual firmware in the order of boot? Thank you, Robert....
  8. BIOS / UEFI - can't USB boot

    in Windows 10 Installation and Upgrade
    BIOS / UEFI - can't USB boot: Hi, Problem I'm trying to boot from a USB pen ( Windows Install, Hirens, Any OTHER ) The problem is it sometimes works , sometimes as in Windows installer works when I wipe the on board drive. I can't get it to boot to anything else even when the on board drive it...
  9. Can't disable secure boot in bios/uefi

    in Windows 10 Installation and Upgrade
    Can't disable secure boot in bios/uefi: I'm having trouble installing windows 10 on my new built. after asking a microsoft employee they told me to disable the secure boot. but for some reason there is no option for that, its either - Other OS - Windows UEFI mode what do i do? My mobo is a Asus Prime...
  10. Cannot boot into UEFI BIOS or Boot Menu

    in Windows 10 Performance & Maintenance
    Cannot boot into UEFI BIOS or Boot Menu: Belarc reports UEFI: American Megatrends Inc. P11-B2 Operating System: Windows 10 Home (x64) Version 1511 (build 10586.494) Installed: 4/27/2016 5:58:22 AM Servicing Branch: Current Branch (CB) Boot Mode: UEFI with successful Secure Boot. This is my brother’s computer:...