Windows 10: Can't run games that run on EasyAntiCheat...

Discus and support Can't run games that run on EasyAntiCheat... in Windows 10 Gaming to solve the problem; I've got a question. Am i the only one that has an issue running EasyAntiCheat games? Like, I wanted to play a game called Apex Legends but as i open... Discussion in 'Windows 10 Gaming' started by SiL3NT._., Feb 8, 2019.

  1. SiL3NT._. Win User

    Can't run games that run on EasyAntiCheat...


    I've got a question.


    Am i the only one that has an issue running EasyAntiCheat games? Like, I wanted to play a game called Apex Legends but as i open the game a window pops up saying "The application was unable to start correctly (0xc00000142)...After i press OK a notification from EasyAntiCheat pops up saying "Untrusted system file windows/system32/winhttp.dll".


    Does anyone know how to fix this issue? If so your help would be appreciated!

    :)
     
    SiL3NT._., Feb 8, 2019
    #1

  2. Unable to run a game on Windows 10.

    Hi,

    Welcome to Microsoft Community.

    - When you say 'ive tried troubleshooting', what are you referring to?

    - Did you check in compatibility mode?

    I suggest to run the game in compatibility mode by following the steps below and check if it helps.


    • Right click on the ‘Setup’ icon for the game and click on properties.

    • Under Compatibility tab, check the option for ‘Run in Compatibility mode’.

    • Select Windows 8.1 from the drop down list.

    • Click on Apply and then OK.


    Please revert with all the necessary information and we will be happy to help you.
     
    Guru Kiran G, Feb 8, 2019
    #2
  3. EasyAntiCheat appeared from nothing


    Hello. I was just looking through my services tab in task manager, when I saw EasyAntiCheat. Why is it running? I'm not playing any games. So my question here is: Why is EasyAntiCheat running in background when I'm not playing games?
     
    TheStrangeTeste, Feb 8, 2019
    #3
  4. Can't run games that run on EasyAntiCheat...

    Wanting to run old games

    Hi Jameson,

    Welcome to Microsoft Community. Your interest in Windows 10 is much appreciated.

    I would suggest you to refer the below link and check the compatibility of the game with Windows 10.

    http://www.microsoft.com/en-us/windows/compatibility/CompatCenter/Home

    You may also try installing the game in compatibility mode.
    Follow these steps to install the game software in compatibility mode and check if that helps.


          • Right-click on the game setup file and click on
            ‘properties’.

          • Click on the ‘compatibility’ tab and check the box
            ‘Run this program in compatibility mode for’ and select Windows 8 operating system from the drop down menu and proceed with the installation. Once this is done, restart the computer and check if the issue persists.
    If the issue still persists, I would suggest you to get in touch with the game manufacturer if it’s specific to that particular game.

    Keep us posted if you face any issues on windows in future. We will be glad to help you.
     
    Annu Singh, Feb 8, 2019
    #4
Thema:

Can't run games that run on EasyAntiCheat...

Loading...
  1. Can't run games that run on EasyAntiCheat... - Similar Threads - Can't run games

  2. GAMES ARE NOT RUNNING

    in Windows 10 Gaming
    GAMES ARE NOT RUNNING: I HAVE WINDOWS 10 ON MY LAPTOP, I TAKE GAMES FROM MY BROTHERS LAPTOP WHO HAVE WINDOWS 7 ULTIMATE . PROBLEM IS SOME GAMES ARE WORKING AND SOME NOT. RATIO IS 1:4. PLEASE HELP ME ....
  3. error on running a game

    in Windows 10 Gaming
    error on running a game: Games are failed to play with the error “THIS APPLICATION REQUIRES A 3-D ACCELERATION TO RUN" and my hardware acceleration is also enabled . https://answers.microsoft.com/en-us/windows/forum/all/error-on-running-a-game/dd7d04c2-bd24-4f9d-bbfd-bead0ff45932
  4. Can't run games anymore

    in Windows 10 Gaming
    Can't run games anymore: Hello, So I've had this issue lately that I'm not able to launch some games, or when I launch them, it will take forever to get them opened, if they don't crash before it opens, or freeze. I can launch some games like Battlefield V from the Origin Store, Dead Cells from...
  5. game process not run

    in Windows 10 Gaming
    game process not run: When I run a game called Euro Truck Simulator 2, it does not happen after selecting Yes in the user account control window. This problem arose a week ago. I have another game with the same platform called american truck simulator running without any problems. All my games...
  6. Can't Run Steam Games

    in Windows 10 Gaming
    Can't Run Steam Games: I just finished building my PC, and I downloaded DirectX but Im getting an alert from Xenuine with error code 00000A00/0019 and MSVCP140.dll, what do i need to download in order to run my games?...
  7. Can't run SFC

    in Windows 10 Performance & Maintenance
    Can't run SFC: All my efforts to run SFC failed. All I get is the following message: "Windows Resource Protection could not start the repair service." I run a search and the net and tried reactivating the “Windows Module Installer“ service. This didn't solve my problem. I ran the same...
  8. Games not running ........................

    in Windows 10 Gaming
    Games not running ........................: Something has changed in win 10 on my pc. Games that have been running perfectly suddenly are telling me that I have to 'use administrator privileges' to play and are refusing to open. I have just reinstalled Doom 3 again to see if it fixed the fault - nothing. I am...
  9. MagicDisc can't run?

    in Windows 10 Software and Apps
    MagicDisc can't run?: Howdy guys, windows has hurt my feelings and I'm in need of assistance! So I've got 2 windows 10 computers, my desktop and my laptop. about 8 months ago, I auto upgraded my laptop from 8.1 to 10, just to see how the new OS ran. At the time I had MagicDisc disc image mounting...
  10. Can't run .exe

    in Windows 10 Software and Apps
    Can't run .exe: An update to AVG was performed on our computer. After that ran, when we try to open any program we receive the message: xxxx.exe- Application error the application was unable to start correctly (0xc0000135). Click OK to close the application. This occurs for any...