Windows 10: Can't Uninstall RSAT (KB2693643)

Discus and support Can't Uninstall RSAT (KB2693643) in Windows 10 Updates and Activation to solve the problem; I accidentally installed the wrong update: Download Remote Server Administration Tools for Windows 10 from Official Microsoft Download Center I... Discussion in 'Windows 10 Updates and Activation' started by ncage, Nov 13, 2017.

  1. ncage Win User

    Can't Uninstall RSAT (KB2693643)


    I accidentally installed the wrong update:
    Download Remote Server Administration Tools for Windows 10 from Official Microsoft Download Center

    I installed WindowsTH-RSAT_WS_1709-x64.msu instead of instead of WindowsTH-RSAT_WS2016-x64.msu. That's fine right just uninstall the wrong update and install the correct one. Well not so easy:


    Can't Uninstall RSAT (KB2693643) [​IMG]


    What i've tried to use to resolve the issue:
    1. DISM /Online /Cleanup-Image /RestoreHealth + sfc /scannow (didn't find any problems)
    2. Windows update troubleshooter
    3. stopped all the windows services and deleted the C:\Windows\SoftwareDistribution
    4. wusa /uninstall /kb:2693643
    5. Uninstalling in safe mode

    I really don't know what else I can try here. It would suck to have to repave the system because of this small thing. Any help would be appreciated. I'm running build 1709.

    thanks....

    :)
     
    ncage, Nov 13, 2017
    #1

  2. Remote Server Administration Tools (KB2693643) installing successfully on Windows 10 Build 10586 but not showing under "add/remove windows features"

    I have upgraded Windows 10 build 10586 and tried to install RSAT using KB2693643, strange is that tools are getting properly but components are not showing under windows add/remove features. can someone please help on this?
     
    Roshan Bhavsar, Nov 13, 2017
    #2
  3. RSAT 1.2 for Window 1607 'The update is not applicable to your computer'

    I just upgraded to Windows v1607. As expected the RSAT tools didn't make the journey. I promptly downloaded the current version of RSAT which appears to have just been released yesterday and I am getting the error
    'The update is not applicable to your computer' when I attempt to install.

    These are the details from the RSAT download page:


    Can't Uninstall RSAT (KB2693643) [​IMG]


    It appears that this was just updated yesterday. I see a lot of references to WindowsTH-KB2693643-x64.msu that was originally released for Windows v1607 but I can't see an option to download this older version.

    Any suggestions on how to get the RSAT installed?
     
    MJCurtis63, Nov 13, 2017
    #3
  4. Can't Uninstall RSAT (KB2693643)

    If you have system image or system restore checkpoint before installing, revert back using one of them. Otherwise, you may try this: install the wrong version again, reboot, uninstall. If it fails, check event logs for uninstall errors, Get-WindowsUpdateLog powershell command, or text-based update log of RSAT if they have one. The last resort is to try to use some universal uninstaller utility like Revo but be sure you made system image before, these uninstallers can be dangerous.
     
    muchomurka, Nov 13, 2017
    #4
  5. ncage Win User
    Unfortunately i went to do a system restore and found out somehow it was turned off. When i try to reinstall the bad version i get "Update for Windows (KB2693643) is already installed on this computer. I checked the event log after the uninstalled failed and this is all i get:

    "Package KB2693643 failed to change the absent state. Status: 0x8000005." (Type informational)

    I tried to download a trial of revo uninstaller pro but it doesn't work with KB updates. These are the days that i HATE windows. I guess the only other option is to repave..?
     
    ncage, Nov 14, 2017
    #5
  6. School Win User
    This is what worked for me. I couldn't view the "manage user" tab options in AD and RSAT was alltogether fubard.

    I tried to:
    Delete the registry keys and then remove the windows feature and rsat
    Remove via wusa
    Remove via DISM
    Remove via Programs and Features > Add/Remove Windows Features
    The only way I could remove KB2693643 and the RSAT windows features are as follows:
    1. Open command prompt as administrator
    2. run DISM /Online /Get-Packages
    2a. Copy and paste the output into a txt document such as notepad
    3. Run DISM /Online /Remove-Package /PackageName:<INSERTDATAHERE>

    In step 3 above, the <INSERTDATAHERE> should be the package name you copied from the Get-Packages list. You will need to run this each time, for each package that starts with "Microsoft-Windows-RemoteServerAdministrationTools...."

    So my step 3 looked like this:
    DISM /Online /Remove-Package /PackageName:Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~31bf3856ad364e35~amd64~~10.0.10585.0
    (selected "no" to restart)

    DISM /Online /Remove-Package /PackageName:Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~31bf3856ad364e35~amd64~~*AnotherVersion*
    (selected "yes" to restart after this 2nd command)
     
    School, Jan 25, 2018
    #6
  7. EdTittel Win User
    Nice job, School. When all else fails, there's always DISM!
    --Ed--
     
    EdTittel, Jan 25, 2018
    #7
  8. iTry Win User

    Can't Uninstall RSAT (KB2693643)

    Hi, I tried this. My step 3 looked like this
    C:\WINDOWS\system32>DISM /Online /Remove-Packages /PackageName:Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~31bf3856ad364e35~amd64~~10.0.16299.2

    But then I get this:
    Error: 87The remove-packages option is unknown.For more information, refer to the help by running DISM.exe /?.

    Any suggestions, or what am I doing wrong? I am new at this....
     
    iTry, Feb 6, 2018
    #8
  9. essenbe Win User
    Try Remove-Package not Remove-Packages and see if it helps.
     
    essenbe, Apr 5, 2018
    #9
Thema:

Can't Uninstall RSAT (KB2693643)

Loading...
  1. Can't Uninstall RSAT (KB2693643) - Similar Threads - Can't Uninstall RSAT

  2. Can't Uninstall An App

    in Windows 10 BSOD Crashes and Debugging
    Can't Uninstall An App: Amazon has a downloadable app called Kindle Create. No matter how many times I uninstall it, it won't install. I know this because I test it. I enter "Kindle Create" in the search bar and it shows up. How do I get rid of it?...
  3. RSAT-Linux problem

    in Windows 10 Customization
    RSAT-Linux problem: HI! At the firm Windows we work with clients and Linux on waiters. Till now the admin machine Windows operated with 7 Pro on what it is RSAT perfectly worked. I replaced the machine and Windows I installed 10 Pro concerned it that way truth RSAT-ot this does not fill the...
  4. Can't uninstall a program

    in Windows 10 Network and Sharing
    Can't uninstall a program: I had downloaded and installed DAZ 3D 4.10 64 bit, and Hexigon 2.52, but they don't work well on my PC and I wanted to uninstall, I can't find them in my program files. I was able to uninstall their installer, but the apps are still on my PC and I can't find the files to...
  5. RSAT

    in Windows 10 Installation and Upgrade
    RSAT: Upgraded OS from Windows 10 1803 to 1903. Lost utility RSAT, can't find it in "Windows features" neither. How do I get the utility back? Thanks, Jen https://answers.microsoft.com/en-us/windows/forum/all/rsat/3d46b8f2-7372-4618-bb46-444fc9df7001
  6. AudibleRT.WindowsPhone.exe can't uninstall it...

    in Windows 10 Software and Apps
    AudibleRT.WindowsPhone.exe can't uninstall it...: Had a windows phone at one point about 3 years ago. The app. kept my phone and computer app in sync. Then got rid of the phone and computer - but kept the harddrive. So about a month ago I was using an external link to format old hard-drives after pulling any info off I...
  7. Can't Uninstall An Application

    in Windows 10 Network and Sharing
    Can't Uninstall An Application: Hello, Recently, I installed an application called "Epic Games Launcher". I didn't wanted to install it but had to because I wanted to play a game. Now I have completed all the levels in this game I want to uninstall Epic Games Launcher. Unfortunately whenever I try to...
  8. Can't uninstall a program

    in Windows 10 Software and Apps
    Can't uninstall a program: I'm trying to upgrade to Windows 10, but it told me I need to uninstall Buffalo TurboPC EX Series. I looked in the uninstall a program screen, and couldn't find it. Is there a way to uninstall it? 19575
  9. I can't find DNS in the RSAT

    in Windows 10 Network and Sharing
    I can't find DNS in the RSAT: Hi. I installed the Remote Server Administration Tools for Windows 10. I went to appwiz.cpl and to Windows features, scrolled down to the RSAT section and everything is checkmarked. However, when I open the administrative tools control panel I do not see any DNS management...
  10. RSAT missing from "Windows Features" even though KB2693643 installed

    in Windows 10 Support
    RSAT missing from "Windows Features" even though KB2693643 installed: I'm an idiot. For those who follow, it doesn't get its own category in Windows Features. Hyper-V management stuff is under "Hyper-V" in Windows Features, and the Server Manager just shows up in the Start menu. 100102

Users found this page by searching for:

  1. cant uninstall Windows update KB2693643

    ,
  2. KB2693643 causing bluescreen

    ,
  3. how to uninstall rsat windows 10 1903

    ,
  4. dism uninstall KB2693643,
  5. how to clean romove Windows update KB2693643,
  6. why cant i uninstall KB2693643,
  7. kb2693643 uninstall