Windows 10: Default AutoPlay behaviour for a particular USB device

Discus and support Default AutoPlay behaviour for a particular USB device in Windows 10 Network and Sharing to solve the problem; Howdy, I have a piece of scientific equipment that appears as a mass storage device when I plug it in. Is there any way to suppress AutoPlay opening... Discussion in 'Windows 10 Network and Sharing' started by PookAllpike, Apr 7, 2021.

  1. Default AutoPlay behaviour for a particular USB device


    Howdy,

    I have a piece of scientific equipment that appears as a mass storage device when I plug it in.


    Is there any way to suppress AutoPlay opening an explorer window behaviour for only this device, for any system I plug it in to?

    e.g. is there something I can put in an Autorun.inf file to stop explorer from opening on USB connection.


    I detect the USB connection event and download the data from it using my own software, the explorer window just gets in the way, and is confusing for users.


    -Pook

    :)
     
    PookAllpike, Apr 7, 2021
    #1

  2. Program doesn't exist for Autoplay

    Hi,

    Welcome to Microsoft Community.

    I suggest you to set the Autoplay settings and check if it helps.

    Follow the steps below.

    • Press Windows key +X, select Control Panel.
    • Go to Control Panel and locate AutoPlay.
    • In AutoPlay settings make sure that you check Use AutoPlay for all media and devices.
    • Next click the Reset all defaults button. Your Autoplay settings should be reset to default.

    Default AutoPlay behaviour for a particular USB device autoplay-problems-windows-10.png

    • Insert USB or DVD to see if Autoplay is working.

    You can also try downloading Windows Media Player 10

    https://www.microsoft.com/en-in/download/details.aspx?id=20426

    Hope this helps.

    Regards,

    Guru Kiran
     
    Guru Kiran G, Apr 7, 2021
    #2
  3. Pavan_N Win User
    Problems with autoplay and my JVC camcorder

    Hi Marchony,

    Thank you for posting in Microsoft community.

    I suggest you to follow the Methods below.

    Method 1: Hardware Troubleshoot

    Windows 10 has a built-in troubleshooter to check and fix issues with hardware and devices. I would suggest you to run this troubleshooter to check if the issue is with your touch pad.

    Refer these steps:

    • Press Windows key +X, select
      Control panel

    • Change the view by option on the top right to
      Large icons
    • Click on troubleshooting and click on the
      view all option on the left panel
    • Run the Windows Store apps troubleshooter

    Method 2:
    Update USB Controllers.

    To update the USB Controllers from Device Manager follow these steps.

    • Go to Device manager in control panel.
    • Select Device manager and a Device Manager window will pop-up.
    • Double Click on USB Controllers to expand.
    • Right click on the USB Controllers that is listed and select Update.

    Method 3 : Follow these steps to specify what should happen when you insert different types of digital media into your computer.

    1. Open AutoPlay by clicking the Start button, in the search box, type autoplay, and then click AutoPlay.

    2. Under MEDIA, find the type of media that you want to change the AutoPlay setting for.

    3. Click the action that you want AutoPlay to take when you insert CD/DVD into your computer.

    4. Click Save.

    Hope this information is helpful. Please feel free to reply in case you face any other issues with Windows in future.

    Thanks.
     
    Pavan_N, Apr 7, 2021
    #3
  4. Default AutoPlay behaviour for a particular USB device

    autoplay doesn't work after loading windows 10

    Hi,

    Thank you for posting in Microsoft Community, we appreciate your interest in Windows 10.

    Please do let us know if you have installed all the pending updates on your device.

    Also, check with the sound drivers as well.

    I suggest you to check with the setting for AutoPlay and check if it helps.

    Even if you have turned on the AutoPlay option, there might be some option chosen Choose AutoPlay defaults. I suggest you to check with those options.

    Steps:

    • Press Windows key, type AutoPlay and click on AutoPlay settings.
    • To enable AutoPlay, move the Use AutoPlay for all media and devices button to On.
    • Next you can choose and set your AutoPlay defaults.
    For Removable drives, the following options are available from the drop-down menu:

    • Take no action
    • Open folder to view files
    • Ask me every time
    • Configure this drive for backup (File History)
    • Configure storage settings (Settings).

    For Memory Cards, the options available are:

    • Play video files using alternate
      software
    • Play using Windows Media Player
    • Take no action
    • Open folder to view files
    • Ask me every time.
    Set your options and exit.

    Hope it helps. Kindly update the status of the issue, we will be happy to help you.
     
    Deepika Gowda, Apr 7, 2021
    #4
Thema:

Default AutoPlay behaviour for a particular USB device

Loading...
  1. Default AutoPlay behaviour for a particular USB device - Similar Threads - Default AutoPlay behaviour

  2. Weird USB port behaviour

    in Windows 10 Ask Insider
    Weird USB port behaviour: A little earlier today, i was using my computer normally with no real issues whatsoever, and all of a sudden, both my front USB ports (marked as USB 2.0) stop working at the same time, meaning i couldn't use my mouse or keyboard in thoses ports. However, after i changed my...
  3. default behaviour for Windows Defender

    in Windows 10 Customization
    default behaviour for Windows Defender: Does Windows 10 scan archives by default, or must you enable it from PowerShell ? If it doesn't, why doesn't it ? It would've seemed like he single most useful thing aware could take advantage off hiding inside containers....
  4. Autoplay -Open Device Stage

    in Windows 10 Software and Apps
    Autoplay -Open Device Stage: I have a camera. For this camera Windows 10 "Auto play" is set to "Open Device Stage" which is run when this camera is connected via USB cable and then turned On. With Windows 10 version 1809 the camera app is listed on the Task bar then runs and saves pictures from the...
  5. usb autoplay

    in Windows 10 Customization
    usb autoplay: When I plug in a USB or external drive the autoplay does not open an explorer the way it used to. The auto run/auto play settings have not changed-what's wrong? https://answers.microsoft.com/en-us/windows/forum/all/usb-autoplay/46e56627-36cf-4c2f-b32c-cb58df49e7bf
  6. AutoPlay defaults

    in Windows 10 Drivers and Hardware
    AutoPlay defaults: Do you know how to set the AutoPlay defaults with the registry editor? For example, I would prefer the default to be set to "Open a folder to view files (File Explorer) for "Removable Drive" and "Memory Card," but I don't exactly know how to set this in the registry editor...
  7. set AutoPlay defaults with registry editor

    in Windows 10 Support
    set AutoPlay defaults with registry editor: Do you know how to set the AutoPlay defaults with the registry editor? For example, I would prefer the default to be set to "Open a folder to view files (File Explorer) for "Removable Drive" and "Memory Card," but I don't exactly know how to set this in the registry editor...
  8. BSOD - No particular behaviour - IRQL-NOT_EQUAL_OR_LESS

    in Windows 10 BSOD Crashes and Debugging
    BSOD - No particular behaviour - IRQL-NOT_EQUAL_OR_LESS: Log Name: System Source: Microsoft-Windows-WER-SystemErrorReporting Date: 8/3/2015 12:59:19 AM Event ID: 1001 Task Category: None Level: Error Keywords: Classic User: N/A Computer: DESKTOP-NGT1MNV Description: The computer has rebooted from a bugcheck. The bugcheck...
  9. Usb driver odd behaviour?

    in Windows 10 Drivers and Hardware
    Usb driver odd behaviour?: Hi! This is long term issue for me, i was not able to find a clear answer for why this happens, since to me it's not working as intended. So what happens when i use FTDI 230x as Comport and attach or detach USB device to my system, for reason or another RTS signal...
  10. Default autoplay program

    in Windows 10 Support
    Default autoplay program: When I insert a DVD into the dvd drive it no longer plays automaticaly.Is there a programme in Windows 10 that can be set as default to play automaticaly.The options for doing this in control panel are now disabled. 101143