Windows 10: DLL file in System32 and Excel problem

Discus and support DLL file in System32 and Excel problem in Windows 10 BSOD Crashes and Debugging to solve the problem; Good afternoon - I don't know if this is a Windows or Office question, so I'm asking it in both sections. I'm experiencing a difficult problem with... Discussion in 'Windows 10 BSOD Crashes and Debugging' started by PNSAPNSA, Sep 3, 2019.

  1. PNSAPNSA Win User

    DLL file in System32 and Excel problem


    Good afternoon -


    I don't know if this is a Windows or Office question, so I'm asking it in both sections.


    I'm experiencing a difficult problem with Excel, in Office Pro 2019, on a desktop computer running Windows 10 Pro, version 1809. This started last Tuesday morning (Aug27), and not after a software update. Aug 29 a large update was installed by Windows, but this did not remedy the problem. In researching others who have experienced difficulties like this, I have not loaded any apps from Google or Dropbox (for some folks, those apps interfered/caused conflict with Office). No add-ins have been loaded to any component of Office 2019 Pro. Only Excel is impacted - all other Office components are working fine. Also, this problem showed up out of the blue - Excel had been working fine on Aug 26.


    I can launch and use Excel in the Administrative account. But, if I log-in to my user account (non-admin privileges), when I launch Excel (either by clicking on the icon in the Start menu, or by double-clicking an Excel file in Explorer), the Excel icon appears on the Taskbar, but it is orange, and I cannot open/display the file (or even the Excel start screen where you can choose a recently opened file, or create a new blank document, etc.). I can right-click on the Taskbar icon to close Excel, or I can open Task Manager and choose to close it via End Task.


    I have run the on-line Office Repair Tool, but that did not fix the problem. I can start Excel in Safe mode, and it works as it should.


    I've looked at the Events Viewer log of errors, and all previous errors (from Aug. 28 and earlier) appear to have been removed by the Office Repair Tool today. The only errors reported are timestamped from after the Windows Update and the use of the Office Repair Tool. I have since logged in to the non-admin account and 'launched' Excel, and that generated these Error reports in Event Viewer:


    1 - "Windows cannot load the extensible counter DLL "C:\WINDOWS\system32\sysmain.dll" (Win32 error code The specified module could not be found.)."

    2 - "Unable to open the Server service performance object. The first four bytes (DWORD) of the Data section contains the status code."


    When I look in the directory: C:\Windows\System32\

    I find these 2 files next to each other:

    sysmain.dll.mui ~7kb, created/modified back in May 2019

    sysmain.dll ~980kb, created/modified Aug. 29 (when I ran the Office Repair Tool)


    So the sysmain.dll file appears to exist, but for some reason it is not loadable from the non-admin account.


    Another note, when I check these same file locations on my laptop, running Windows 10, but only the basic version of Office 2019, the sysmain.dll.mui file is not in the System32 folder, but here:

    C:\Windows\System32\en-US\sysmain.dll.mui


    Could this be part of the problem?


    Any suggestions on how to fix this/these errors? And if a DLL is unloadable/not found, why does Excel work in one user account, but not another? Thank you for helping me!


    Claudia

    :)
     
    PNSAPNSA, Sep 3, 2019
    #1
  2. Kem Mon Win User

    dll file not found after Creator's Update, Code Execution Cannot Proceed

    Hi Aberfoyle,

    It is possible that the
    .dll file was corrupted during the update causing the error to occur.
    To better assist you, kindly find the
    .dll file
    in
    c:\Windows\System32. If you can find the
    .dll file, it means that we need to
    register
    your
    .dll file
    to your
    Operating System
    for it to
    work. To do this, we need to
    unregister
    the
    .dll file
    first and
    re-register
    it. Here are the steps on how to do so:

    To unregister the .dll file:


    • Press
      Windows key + R, type
      Regsvr32 /u c:\Windows\System32\VCRUNTIME140.dll
      and hit
      Enter/OK.

    To re-register the .dll file:


    • Press
      Windows key + R, type
      Regsvr32 c:\Windows\System32\VCRUNTIME140.dll
      and hit
      Enter/OK.

    If you cannot find the
    .dll
    file in
    c:\Windows\System32,
    kindly run these methods of troubleshooting
    so that we will know if the issue is within/not within the
    Operating System:

    Method 1:
    Run SFC Scan.  

    SFC
    will
    scan
    and
    run
    an
    automatic repair
    to any
    corrupted system files
    that it will detect. We suggest that you perform it twice. To run an
    SFC scan, follow these steps:  


    • Run
      Command Prompt as Administrator.  

    • Type
      sfc /scannow
      and hit
      Enter.   

    Note:
    Kindly run
    SFC twice or thrice
    and check for results before you proceed to the next method.

    Method 2: Clean Boot.

    Clean Boot
    will
    stop or disable
    the
    applications
    that are running in your
    computer's background.
    To perform a
    Clean Boot, click
    here.

    Note:
    Reset the computer back to
    Normal Mode
    once you are done with the troubleshooting by following the section
    "How to reset the computer to start normally after clean boot troubleshooting"
    from the same article.

    After performing these
    methods of troubleshooting
    and still the issue persists, we suggest that you contact your
    computer/laptop manufacturer
    for further assistance.

    Update us on how it goes.

    Regards.
     
    Kem Mon, Sep 3, 2019
    #2
  3. 95Viper Win User
    Rundll32.dll?

    Make sure to use an adminstrative command prompt.

    Try this: ICACLS "c:\windows\system32\rundll32.dll" /T /grant Everyone:F or ICACLS c:\windows\system32\rundll32.dll /T /grant Everyone:F
    Can't remember if it is with, or without, quotes.

    But, why do all this... try FileAssassin by Malwarebytes, if you are trying to delete the files, but be careful, if you delete the Rundll32.dll files your OS may take a cr*p on you.
     
    95Viper, Sep 3, 2019
    #3
  4. pabloc74 Win User

    DLL file in System32 and Excel problem

    nv4.dll problem

    ok, after 3 hs on google i think i found a solution, i hope, i download a nv4.dll file and put on c..windows..system32

    that i was found in another forum and the guy who have the problem can fixed that way, i hope me too
    i recently play 10 minutes aprox without crash. tonight y play hours to check it and i hope this works fine.
     
    pabloc74, Sep 3, 2019
    #4
Thema:

DLL file in System32 and Excel problem

Loading...
  1. DLL file in System32 and Excel problem - Similar Threads - DLL file System32

  2. Missing .dll files and audio problems

    in Windows 10 Customization
    Missing .dll files and audio problems: Recently after I re-installed windows, everytime i would try to open roblox or steam or an app etc. a missing .dll file error message appeared. I have many other issues including not being able to turn my volume up, etc.. It all happened after I reinstalled windows on my...
  3. Word and Excel Not Opening and D2d1.dll File Issues

    in Windows 10 BSOD Crashes and Debugging
    Word and Excel Not Opening and D2d1.dll File Issues: I've been having two issues with my laptop for a few days. The first being every time I start up my laptop, I get an error message saying "The code execution cannot proceed because d2d1.dll was not found. Reinstalling the program may help." I'm not entirely sure what that...
  4. ''Entry point not found'' ''System32/KERNEL32.DLL.''

    in Windows 10 Network and Sharing
    ''Entry point not found'' ''System32/KERNEL32.DLL.'': I recently bought a fresh version of Windows 10 because of frequent crashes, and everything was working great compared to before until now. I was playing a game (Overwatch) and after 2 hours it crashed. This time the blue screen did actually manage to fix the problem and...
  5. Problem with a DLL

    in AntiVirus, Firewalls and System Security
    Problem with a DLL: I did it "https://support.microsoft.com/en-us/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system" and after a day it is came back (the problem) and now i am to do it again and it wont work help!...
  6. Excel file saving problem. File disappeared.

    in Windows 10 Network and Sharing
    Excel file saving problem. File disappeared.: Excel file had problem saving. Window asked if report to Microsoft. Now, excel file disappeared. There is a .tmp file. Where is my excel file? https://answers.microsoft.com/en-us/windows/forum/all/excel-file-saving-problem-file-disappeared/c1450290-5248-4c9f-aeb2-47702d4bdc54"
  7. .DLL error [C:\Windows\SYSTEM32\MSIMG32.dll]

    in Windows 10 BSOD Crashes and Debugging
    .DLL error [C:\Windows\SYSTEM32\MSIMG32.dll]: 'C:\Windows\SYSTEM32\MSIMG32.dll is either not designated to run on windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc0000020.' I...
  8. Run DLL error {C:\\WINDOWS\System32\nvspcap64.dll}

    in AntiVirus, Firewalls and System Security
    Run DLL error {C:\\WINDOWS\System32\nvspcap64.dll}: Hey, Every time I boot my WIN 10 I keep getting this error message: [ATTACH] What can I do to fix this error message? Thank you...
  9. Have 4 .dll files with problems

    in Windows 10 Support
    Have 4 .dll files with problems: Tried registering these dll files in hopes to get my store app working cause I don't have use of Edge either and these 3 came up with could not be loaded, specific module could not be found: msxml.dll, initpki.dll, and qmgrprxy.dll. This one qmgr.dll came up with dll register...
  10. C:\windows\system32\nvscap64.dll

    in Windows 10 Updates and Activation
    C:\windows\system32\nvscap64.dll: running windows 10pro vers1511 on my pc os build 10586.589, prod id 00330-80000-00000, each startup this message appears, could not find C:\windows\system32\nvspcap64.dll, what's wrong?*Sick 71699