Windows 10: Help with NVME boot issues

Discus and support Help with NVME boot issues in Windows 10 Support to solve the problem; Installed WIn 10 Pro 64 EUFI successfully onto a 1TB NVMe drive and all was working fine and reliably. Without going into much detail, was trying to... Discussion in 'Windows 10 Support' started by vkinetic, Apr 17, 2020.

  1. vkinetic Win User

    Help with NVME boot issues


    Installed WIn 10 Pro 64 EUFI successfully onto a 1TB NVMe drive and all was working fine and reliably. Without going into much detail, was trying to get a UAD accelerator PCe2 card working on the system (these are used in pro audio and there are known issues with Ryzen systems). Silly me started to mess with PCe by changing to earlier protocols in BIOS, trying to get the UAD card recognised. I actually had it working in the graphics slot but problems began when I installed a graphics card so that I could upgrade the CPU (to a non graphic capable Ryzen 5 3600). Obviously these attempts (which all failed by the way) also upset the NVMe settings and now the system will not boot. I took an Acronis disk image of the NVMe drive and found that all the data is still there - it's just that for some reason the Windows Boot Manager won't work and even if I set just the drive (without the Windows Boot Manager) as the boot drive I get the message to insert proper boot media.

    Funnily enough (actually it wasn't funny) at the same time I built another system for someone using EUFI and a NVMe drive. That system worked fine until Windows Build 1909 got installed and when that system rebooted it too could not see the NVMe boot drive. Again, an Acronis disk image was taken and I found that all the data of the original Windows installation was still there. I restored to a SATA SSD but alas I could not get the system to boot from that new SSD either. I began to wonder whether there was an issue with EUFI and NVMe drives. At any rate I did a normal (non EUFI ) install on that system using the SATA SSD as the boot drive and just used the NVME drive as a data drive.

    Both NVMe drives in these two systems were Crucial P1 1TB drives.

    If anyone has hung in there so far and read all this - is there anyway I can recover my system so that it boots from the NVMe drive again? I can install the drive in another system so I will be able to edit or otherwise manipulate it outside of the problematic system if necessary.

    Thanks

    :)
     
    vkinetic, Apr 17, 2020
    #1

  2. Windows 10 installer don't detect NVMe drive

    I have 2 drives:

    • disk1 (SATA SSD, with Ubuntu 16.04)
      • partition1 (sda1: flag /boot)
      • partition2 (sda2: flag /home, encrypted by LUKS)
    • disk2 (NVMe SSD)

    So, the goal is to install Windows 10 on disk2 and boot it from GRUB (which is on sda1).

    What is the problem ?

    In disk-choose step, disk2 is missing. However Ubuntu 14.04 installer "see" this disk, so I assume that is software issue, rather than my hardware.

    What I tried to solve this problem ?

    • loaded Samsung NVMe drivers from this thread
    • patched Windows image using DISM tool by adding 2 updates. I followed this guide
    • tried to run Windows 10 installed on USB stick to install it

    All of them failed.

    Please help me to solve this issue.
     
    WojciechCe, Apr 17, 2020
    #2
  3. cnenzel Win User
    AMD X370 Chipset - NVMe boot device - Driver issue

    Mostly posting this in case others run into this issue.

    I have an AMD Ryzen system with an Asus X370 motherboard and two SATA drives in a RAID 1 array booting from a Western Digital NVMe stick

    Last night at some point the system - Newly upgraded to Windows 1903 with all available post upgrade patches - that the
    Standard NVM Express Controller driver wasn't sufficient for the NVMe stick not running RAID mode (disabled in BIOS) and installed the
    AMD-RAID Bottom Device and AMD-RAID Controller [Storport] drivers for it.

    It did this silently. I rebooted to cure a different issue and Windows 10 ended up in a boot loop.

    I only realized what actually happened after I restored a Macrium Reflect (HIGHLY RECOMMENDED) image of the C: drive (NVMe) from the night before the reboot, opened device manager and saw what it had done.

    I don't know of an easy way to figure out which AMD-RAID Bottom Device
    and AMD-RAID-Controller [Storport] are assigned to which device so I temporarily put the NMVe stick into RAID mode so it would boot and disabled RAID for the remainder of the SATA devices. This let me boot, change the driver back to the
    Standard NVM Express Controller Driver (because now there is only one AMD-RAID Bottom Device and AMD-RAID-Controller [Storport]
    listed in device manager) , disable NVMe RAID, enable SATA RAID and resolve the issue.

    Whew. Now, if it boot loops again, my first troubleshooting step will be to turn on RAID mode for the NVMe stick and see if that fixes the boot issue... Instead of spending an hour trying to get the system to see the F8 key being spammed so I could select
    the Reflect recovery USB stick and reimage the NMVe stick...
     
    cnenzel, Apr 17, 2020
    #3
  4. Help with NVME boot issues

    Use bootloader from a SATA disk to boot Windows installation on a NVME disk

    I've managed to get the system booting from the NVME some other way:

    1. Converted the NVME to GPT using MBR2GPT.EXE
    2. Hacked NVME support into the bios
     
    a1__Bart__1, Apr 17, 2020
    #4
Thema:

Help with NVME boot issues

Loading...
  1. Help with NVME boot issues - Similar Threads - Help NVME boot

  2. Is there an Issue with NVMe drives ?

    in Windows 10 Virtualization
    Is there an Issue with NVMe drives ?: Hi I ran a hyper-v vm this morning and I tried to add a physical drive which I do regularly as I need to access the data on it. Up until today, that data has always been on an SSD but I recently moved all that data onto a new NVMe drive. The first time I tried, I added it...
  3. Help with nvme m.2

    in Windows 10 Ask Insider
    Help with nvme m.2: Need help m.2 nvme card I bought a digifast nvme m.2 and it won’t show up in Windows. I try doing the Disk Management, Initialize Disk but it’s doesn’t show up. When I go into the bios is there I see the m.2 and my ssd card. Help please. X570 gigabyte mobo. Thank you....
  4. Win 10 boot issue...help!

    in Windows 10 Support
    Win 10 boot issue...help!: Hi everyone, My Acer laptop crashed from a BSOD and I'm no longer able to boot into Win 10, I suspect it was a recent Win 10 update but cannot be 100% sure. These are the things I've attempted to troubleshoot my laptop. - Attempted to use Win 10 self fix service, system...
  5. NVME issues for booting win 10

    in Windows 10 Drivers and Hardware
    NVME issues for booting win 10: Hi, I was recently rebuilding my PC and decided to upgrade to a 2TB PCIE 4 NVME. I also Previously had a Samsung 960 PRO. I did a clean install from a USBC SSD. For some reason, I have to have my BIOS set to legacy in order to recognize and boot from the new NVME. How can I...
  6. Help with NVME boot issues

    in Windows 10 Drivers and Hardware
    Help with NVME boot issues: Installed WIn 10 Pro 64 EUFI successfully onto a 1TB NVMe drive and all was working fine and reliably. Without going into much detail, was trying to get a UAD accelerator PCe2 card working on the system (these are used in pro audio and there are known issues with Ryzen...
  7. Issue after running OS on NvME

    in Windows 10 Ask Insider
    Issue after running OS on NvME: [ATTACH] submitted by /u/TheLifePhotographic [link] [comments] https://www.reddit.com/r/Windows10/comments/g0g5ke/issue_after_running_os_on_nvme/
  8. Help! weird boot issues

    in Windows 10 Performance & Maintenance
    Help! weird boot issues: Since my computer was running 7 i upgraded to 10 today. However, I've been having weird boot issues. To simplify things, if I shut down my computer, wait about 5 mins, and turn it back on, everything is fine. However, if I restart the computer I have to do this for driver...
  9. AMD X370 Chipset - NVMe boot device - Driver issue

    in Windows 10 Drivers and Hardware
    AMD X370 Chipset - NVMe boot device - Driver issue: Mostly posting this in case others run into this issue. I have an AMD Ryzen system with an Asus X370 motherboard and two SATA drives in a RAID 1 array booting from a Western Digital NVMe stick Last night at some point the system - Newly upgraded to Windows 1903 with all...
  10. Help with Dual Booting Driver Issues

    in Windows 10 Drivers and Hardware
    Help with Dual Booting Driver Issues: Hello, all! New to this forum just signed up because I have a problem. SO. I have an HP laptop that came preinstalled with windows 10. I have made it so that I can also dual boot my system into windows 7. You know the drill, making a bootable usb and installing it to a...