Windows 10: Homegroup is working but can't open folders

Discus and support Homegroup is working but can't open folders in Windows 10 Network and Sharing to solve the problem; I have two desktop computers in a Homegroup, connected by a Netgear router. But my problem is that I can only open folders in one direction (from one... Discussion in 'Windows 10 Network and Sharing' started by zzzoom, Mar 18, 2017.

  1. zzzoom Win User

    Homegroup is working but can't open folders


    I have two desktop computers in a Homegroup, connected by a Netgear router. But my problem is that I can only open folders in one direction (from one PC to other is OK, reverse is not).

    PC #1 is Windows 10 Pro 1607 x64, using a Netgear Wi-Fi adapter. Disabled the firewall.

    PC #2 is Windows 7-SP1 Pro x64, plugged directly into the router (Ethernet). For test, Windows firewall disabled, uninstalled the AV.

    I can create a new Homegroup, join both computers, and see and open folders on the Win 10 PC from the Win 7 PC. But from the Win 10 PC I can see the folders on the Win 7 PC, however clicking on them does nothing. No errors.

    I have checked that all necessary clients and protocols are enabled in both network adapters. I have checked that IPv6 is enabled for LAN in the router. All necessary services are started on both PC's.

    I know the network path is working, because the Win 7 PC is used as a HTPC in the living room, and has a web server that I can access OK from a browser on the WIN 10 PC.

    I have rebooted after every change, even deleted the files from the peernetworking folder. I am stumped.

    :)
     
    zzzoom, Mar 18, 2017
    #1
  2. Karnac44 Win User

    Unable to Start Peer Name Resolution Protocol Service

    Though I had some trouble finding the MachineKeys folder (maybe it's hidden?) this solution worked perfectly to fix my homegroup problem. Thanks, CrazyRabbit!

    Why can't the Windows troubleshooter just tell you why you can't get the homegroup to work?
     
    Karnac44, Mar 18, 2017
    #2
  3. MenyEi Win User
    Establishing home network

    Thanks Qui for your reply.

    The build ID is 14393.1066

    Both PCs are connected with wired connection.

    I see the folder that I shared in the Network folder on the Win10 explorer but not on the Win7 (on Win7 Network folder I do not see the Win10 PC ID).

    One another thing regarding the HomeGroup - I have HomeGroup entity in the Win7 but when I open the HomeGroup page in the Win10, I get the message that there is no HomeGroup at the network...

    Both PCs are connected through switch with my VDSL router and both have internet connection (as it seemed to me that there might be connectivity issues as Win10 can't recognize the configured HomeGroup on the other PC).

    Thanks
     
    MenyEi, Mar 18, 2017
    #3
  4. Homegroup is working but can't open folders

    Hi zzzoom.

    When you say you can see files on the Windows 7 machine from your Windows 10 can you see / open files in the Public directory?


    Ken
     
    Caledon Ken, Mar 20, 2017
    #4
  5. Samuria Win User
    Have you tried mapping a drive to it does it have a folder shared with correct permisions? try from a cmd prompt

    net use e: \\pcname or ip\sharename password /user:user pass and username are on the pc your connecting to not the pc your on
     
    Samuria, Mar 20, 2017
    #5
  6. zzzoom Win User
    I can only see the folder icons, but not open them.
     
    zzzoom, Mar 20, 2017
    #6
  7. zzzoom Win User
    I hear ya, but I shouldn't have to map any drives or set file permissions to use Homegroup, correct? It works OK from the Windows 7 PC to access the Windows 10 Homegroup shared files without doing that.
     
    zzzoom, Mar 20, 2017
    #7
  8. Homegroup is working but can't open folders

    Hi zzzoom

    Could I ask you to please right click on your network icon, open network and sharing, the click on "Change Advance Sharing settings.

    If you scroll down there is a section on your 7 machine "Password Protected Sharing" and below it "Homegroup". Confirm how you want it. On the 10 machine there is the same setting screen although it doesn't have "Password Protected Sharing"

    Disable firewalls, which I think you said you did already for testing (unless it immediately works). Just for record, are you current in patching?


    Ken
     
    Caledon Ken, Mar 21, 2017
    #8
  9. zzzoom Win User
    Hi Ken, thanks for your feedback!

    My "Password Protected Sharing" is turned off.
     
    zzzoom, Mar 21, 2017
    #9
  10. and if you right click on say Documents, and then click on "Share with" is home group enabled?

    Within 10 and 7 there are trouble shooters for sharing files / accessing files. Might be worth trying.

    I know this sounds crazy, but did you ever shut off router for a minute and then try. Stranger things have happened.


    Ken
     
    Caledon Ken, Mar 21, 2017
    #10
  11. zzzoom Win User
    I ran the Homegroup troubleshooter, which found no issues. If I try to share folders with the legacy method, I get this error on the Win 10 desktop: Error code: 0x80070035 The network path was not found.

    Out of curiosity, I started up my laptop with Win10 Home 1511 (pre-anniversary update), joined the same Homegroup and it worked! Could access the Win7 PC Homegroup just fine. My Desktop that can't connect with the Win 7 machine has Win 10 version 1607, up to date, except for the Mar 2017 updates.
     
    zzzoom, Mar 21, 2017
    #11
  12. The puzzle grows. There was another member who posted he lost his casting. Removed the most recent updates and it started working again. You on the other hand have not installed the March updates and it does not work. Maybe try installand see if they have fix enclosed. (LOL)

    I can't remember if you reset your Windows 10 network on the machine that doesn't access properly but that may be the next step. Then rejoin Homegroup. You will lose wireless passwords. If you wish to try Start => Settings => Network and Internet

    scroll down right hand side, click reset network.

    There are these four commands that reset a bunch of things, indicated in brackets (do key in bracketed info). You may wish to try before network reset. Entered to command prompt(admin)

    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)

    You will have to reboot. As with any change it is always a good idea to have a restore point and given its recent flakiness an Image created with Macrium Reflect (with required boot disk). Maybe even boot media.

    The plan is not to need any of these, the reality is to have a plan B.

    You may wish to see if others have a better idea.


    Ken
     
    Caledon Ken, Mar 21, 2017
    #12
  13. zzzoom Win User

    Homegroup is working but can't open folders

    Appreciate the helpful suggestions. I believe that the problem can be isolated to my Win 10 desktop PC. I do take a disk image at least once a month, so resetting the network is probably going to be my next step, if I am going to sort this out. This is an odd one for sure. Will try that tomorrow. Thanks again!
     
    zzzoom, Apr 5, 2018
    #13
Thema:

Homegroup is working but can't open folders

Loading...
  1. Homegroup is working but can't open folders - Similar Threads - Homegroup working can't

  2. Can't open new folder on desktop

    in Windows 10 Network and Sharing
    Can't open new folder on desktop: Unable to open a new folder in desk top. Also can't open a folder in the ribbon, not highlighted https://answers.microsoft.com/en-us/windows/forum/all/cant-open-new-folder-on-desktop/a2d14cd4-a4a1-4b1e-80b6-e4e49445ba65"
  3. Homegroup stopped working

    in Windows 10 Network and Sharing
    Homegroup stopped working: When I reinstalled Windows 10 on one desktop computer it no longer has homegroup functionality to enable connection with my other 3 computers and network printers. The updated computer cannot see the Homegroup network. All computers have internet access but not to my local...
  4. Can't Access Homegroup

    in Windows 10 Network and Sharing
    Can't Access Homegroup: Have a new L/T, can access the Internet but can't join an existing Home group to use my printer Believe that the existing HG doesn't exist anymore. Help!...
  5. can't connect to the homegroup

    in Windows 10 Network and Sharing
    can't connect to the homegroup: Hello! At home we have 4 PCs, I used to share file using homegroups without any issues. just three days ago, I had to reinstall the windows on an HP Mini, and after that it couldn't connect to the homegroup, instead it says Create a homegroup. I have tried: -to clean the...
  6. Homegroup stopped working

    in Windows 10 Network and Sharing
    Homegroup stopped working: I'm not sure if it's related to the last update or not, but suddenly my homegroup started saying my other PC was offline. So I went and left it and recreated it, and sometimes it'll connect for maybe 5 minutes then disappear again. Also, it's saying almost everytime I try to...
  7. Homegroup not working correctly

    in Windows 10 Network and Sharing
    Homegroup not working correctly: hi guys, since Build 10041 the only computer with Win 10 TP is in the homegroup but that computer only shows the 3 other pc's. Changing from "Allow WIndows to manage home group connections" to 'Use user accounts and passwords to connect to other computers" does not...
  8. Can't open folders and control panel.

    in Windows 10 Support
    Can't open folders and control panel.: I can't open folders, or right click them... when i try to do it the screen goes blank for a few seconds then all my icons refresh and nothing else happens. I tried to change the size of my "text, apps and other items" to 125% and 100% ( i had 100% when this started to...
  9. Homegroup not working. Frustrating !

    in Windows 10 Support
    Homegroup not working. Frustrating !: I'm trying to allows my TV and Xbox one to access a folder on my external hard drive using the Homegroup. I have turned Homegroup on, Changed the password, Allowed all the devices on the network to share content, Added my folder on the external HD to the Homegroup....
  10. Can't Open Folders HELP

    in Windows 10 Support
    Can't Open Folders HELP: I've had Windows 10 for about a month now. Everything has been going well. Then this AM I tried to open a folder on my desktop but it will not open. I right click on it to only go back to my home screen.I cant even get into my documents. No folders what so ever. I clicked on...