Windows 10: Keyboard language setting changes on its own

Discus and support Keyboard language setting changes on its own in Windows 10 Support to solve the problem; I live in the UK, my language/region option is set correctly and I have a UK-format keyboard. US English keyboard format is not even an option set in... Discussion in 'Windows 10 Support' started by THX1138, Dec 7, 2018.

  1. THX1138 Win User

    Keyboard language setting changes on its own


    I live in the UK, my language/region option is set correctly and I have a UK-format keyboard. US English keyboard format is not even an option set in the region and language settings. Why does Windows 10 keep adding the US English keyboard option and switching me to it? I want it to be set to UK forever and to get the language bar off my taskbar forever.


    Keyboard language setting changes on its own [​IMG]


    :)
     
    THX1138, Dec 7, 2018
    #1
  2. 95Viper Win User

    Windows 8.1 update changed the language, can't change back

    Maybe, these will help... it seems it is a common enough problem.

    Language packs are no longer available after you upgrade to Windows 8.1

    And, sort of the same here --> Add a language or keyboard

    Quote from above MS web page:

    Spoiler Download and install language packs
    You'll need to download the language pack if you want to make a language your Windows display language (that's the language you see most often in Windows and apps).
    • Swipe in from the right edge of the screen, tap Settings, and then tap Change PC settings.
      (If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, click Settings, and then click Change PC settings.)
    • Tap or click Time and language, and then tap or click Region and language.
    • Tap or click a language that says Language pack available underneath, and then tap or click Options.
    • Tap or click Download. The download process might take a while, depending on your PC and the size of the language pack.
      If you want to make this your display language, see the next section "Change your Windows display language".
    Change your Windows display language
    To change your Windows display language (that's the language you see most often in Windows and apps), first add a language, download and install the language pack, and then follow these steps.
    • Swipe in from the right edge of the screen, tap Settings, and then tap Change PC settings.
      (If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, click Settings, and then click Change PC settings.)
    • Tap or click Time and language, and then tap or click Region and language.
    • Tap or click the language that you want to set as your display language.
    • Tap or click Set as primary to move the language to the top of the list. If the language can become your Windows display language, you'll see Will be display language after next sign-in appear under the language.
    • Sign out and then sign back in to finish.
    And here is some more info --> Add Language Packs to Windows
     
    95Viper, Dec 7, 2018
    #2
  3. Keyboard language keeps changing

    Hello Charlie,



    Thank you for writing to Microsoft Community Forums.



    1. Since when are you facing this issue?
    2. Have you installed Spanish Keyboard in your desktop?


    You can follow the steps to fix the issue.



    Method 1:



    Removing other keyboard layouts.



    1. Go to Settings > Time & Language >
      Region & Language.
    2. Click on Spanish
      and Click on Remove.
    3. Now add the Spanish language again from
      Region & Language under
      Settings.


    Also, if you are using an older build of Windows 10, you can refer to the suggestions by

    Monica Cam
    dated 10th October 2016.



    Method 2:



    Changing the language preference to English only.



    1. Go to Settings > Devices >
      Typing.
    2. Under More keyboard settings click on
      Advanced keyboard settings.
    3. Now under Override for default input method select
      English.
    4. Restart the computer.


    Hope it helps.

    Let us know if you got the help you needed by clicking ‘Yes’ or ‘No’.



    Prakhar Khare

    Microsoft Community – Moderator
     
    Prakhar_Khare, Dec 7, 2018
    #3
  4. Keyboard language setting changes on its own

    Touch Pad and Keyboard language change

    Hi Dimitrov,

    We appreciate you for being part of Windows 10.

    Before proceeding, we need more information to help you better.


    • On which app you try to set a particular language?

    • Have you downloaded the different language packs?

    I will assist you to answer your questions.

    Answer 1:

    This issue may occur when scrolling options are configured in a different manner. Please follow the below steps to modify the scrolling options.


    • Open the Start menu, type Settings in the search bar and click on Settings.

    • Click on Devices, select
      Mouse and Touchpad on the left navigation pane under the Devices settings window.

    • Change the configuration settings for touchpad features under
      Touchpad.
    Answer 2:

    Note: Please reply us the particular app which you want to switch the language. The language switching functionality depends on the app whether it is supported or
    not.

    To switch the languages in Windows 10 you should download the language pack to use it. Follow the below steps to add language pack.

    Step 1:


    • Press Windows + I keys on the keyboard to open Settings menu.

    • Click on Time and language in settings window.

    • Click on Region and language from left navigation pane.

    • Click on Add a language (+ symbol)

    • Select Russian language pack.
      (You can download any language packs. As example I suggested to download Russian language pack)

    • Now, click on Russian language pack and click on
      Set a default button under the Region and language from left navigation pane.
    Step 2:


    • Press Windows + X keys on the keyboard, select
      Control panel.

    • Type Language in the search bar located at the top right corner of Control panel and click on language.

    • Click on the Russian language pack on the Language window.

    • Click on Download and install language pack button under
      Russian language pack.

    • Enter the administrator password if prompted.

    • Click on Save button.


    I hope the above information helps. Kindly let us know if you need any further assistance with Windows. We are glad to assist you.

    Thank you.
     
    Kiran Kishore, Dec 7, 2018
    #4
Thema:

Keyboard language setting changes on its own

Loading...
  1. Keyboard language setting changes on its own - Similar Threads - Keyboard language setting

  2. Fix Windows 10 keyboard language changes on its own

    in Windows 10 News
    Fix Windows 10 keyboard language changes on its own: [ATTACH] In case of multiple keyboard scenario, things get tricky. Keyboard language changes on its own because of the keyboard changes while you are typing. The fact is that keyboard changes because we accidentally hit shortcuts like WinKey+Space key (Changes...
  3. Date/Time incorrectly changes on its own.

    in Windows 10 Customization
    Date/Time incorrectly changes on its own.: While in sleep mode, my computer often changes the date/time to several days in the future. No one else has access to the computer. Automatic time and automatic time zone are turned on. I've read several threads about this, but all they do is share the same complaint. There...
  4. Date/Time incorrectly changes on its own.

    in Windows 10 Customization
    Date/Time incorrectly changes on its own.: While in sleep mode, my computer often changes the date/time to several days in the future. No one else has access to the computer. Automatic time and automatic time zone are turned on. I've read several threads about this, but all they do is share the same complaint. There...
  5. Keyboard and language settings

    in Windows 10 Customization
    Keyboard and language settings: Hi, I am using Windows 10 1803 with the locale set to English-Ireland and a German keyboard. The system was set up using the UK keyboard. After selecting the German keyboard as the default input method (which does fortunately no longer change the system language to German)...
  6. keyboard language keeps changing

    in Windows 10 Customization
    keyboard language keeps changing: Since the last windows update my keyboard language keeps changing. That problem did not occur before the update but I can not get rid of it now. system language is English but keyboard is German (for practical reasons). I used override for default input method and German...
  7. Keyboard typing on its own even when not plugged in

    in Windows 10 Software and Apps
    Keyboard typing on its own even when not plugged in: My keyboard has been automatically typing "b" nonstop unless I were to power down and reboot the machine, but it would still continue to repeat the behavior after a few minutes. Unplugging the keyboard and using a different USB doesn't help, or even leaving it unplugged. The...
  8. Edge has its own sets of fonts

    in Browsers and Email
    Edge has its own sets of fonts: Just a curiosity, but Edge has 2 private sets of fonts located in: \Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\Assets\Fonts called BrowserMDL.ttf [img] containing the browsers Asset characters and ReadMDL2.ttf [img] Containing...
  9. SETTINGS pops up on its own

    in Windows 10 Support
    SETTINGS pops up on its own: SETTINGS pops up on its own with 14971 for no apparent reason. Annoying! 70113
  10. Default printer keeps changing on its own.

    in Windows 10 Support
    Default printer keeps changing on its own.: I have a Dymo LabelWriter 400 Turbo directly connected by USB and a HP LaserJet 4100DTN connected by Ethernet. The HP is the default printer but *every time* I print a label to the Dymo, Windows 10 automatically changes it to be the default printer that all other programs...