Windows 10: lack permissions to my documents

Discus and support lack permissions to my documents in Windows 10 Support to solve the problem; I get a message "you don't currently have permission to access this folder", when I try to open my documents folder, which is located in the default... Discussion in 'Windows 10 Support' started by shmu26, Jul 14, 2015.

  1. shmu26 Win User

    lack permissions to my documents


    I get a message "you don't currently have permission to access this folder", when I try to open my documents folder, which is located in the default location in my user account on the C drive.
    hmmm.
    I can click on the error message and gain temporary access, but after the next reboot, I am back to square one.
    I checked who is the owner of the folder, and it says I am the owner, and I have full control.
    but I don't.

    :)
     
    shmu26, Jul 14, 2015
    #1

  2. Losing permissions to Documents folder after reboot

    This behavior started this morning as far as I have been able to determine. It seems to be only affecting the Documents folder for my machine account. I determined this after I was unable to start Outlook (due to lack of permissions)

    • I am using a Microsoft account to log in.
    • I am still shown as the owner of the root user folder, and of the Documents subfolder.
    • I can set myself full access permissions to the Documents folder.
    • After reboot, entire entry for my account disappears from the Documents folder. It still shows in other folders in the user folder.
    My user folder permissions after reboot.

    Some screenshots that show the situation after reboot. Note that the Documents folder has only the group permissions, not the user permissions. Again, this only seems to affect the Documents folder under my account.

    lack permissions to my documents [​IMG]

    Edited to add: I have done malware scans with Defender and Malwarebytes, each came back clean.
     
    SolarWindSurfer, Jul 14, 2015
    #2
  3. figment_ Win User
    figment_, Jul 14, 2015
    #3
  4. lack permissions to my documents

    i had this similar issue once in 8.1 but it was because the FS was Hosed. i think in Win10 we were moved to the new FS from latest builds (ala a clean install) i could be mistaken but if your still using NTFS, i'd run check disk to rule out a bad FS/corrupted permissions.
     
    CaelThunderwing, Jul 14, 2015
    #4
  5. shmu26 Win User
    yes NTFS, but no errors found.
     
    shmu26, Jul 14, 2015
    #5
  6. Are you using a Microsoft account or a Local account?
    Does a User account log-in show at startup where you then enter a password?

    Have you verified the User account name (at command prompt type "echo "%username%" ) to verify you are logged in to the correct account.
     
    CountryBumkin, Jul 14, 2015
    #6
  7. groze Win User
    Try the take ownership registry file. Just don't use it on windows directory. You can use on some directories within the windows directory but you need to be-careful on which. Cursor & Media directory should be ok to use that on.




    I used it also on
    C:\users
    C:\Documents and Settings
    C:\ProgramData

    I used take ownership on the c:\windows and I ended up having to restore from a backup.


    After Merging the take ownership. Right click on the directory and choose take ownership.
     
    groze, Jul 14, 2015
    #7
  8. shmu26 Win User

    lack permissions to my documents

    okay, so I open regedit, right?
    how do I find "C:\Documents and Settings" in there?
    that's what I want to take ownership of.
     
    shmu26, Jul 14, 2015
    #8
  9. groze Win User
    Nope. That not what I was talking about. There is a registry file that is called takeownership, that allows you take ownership of a folder or file so you can access them. After you merge the takeownership registry file (You can get the file on the web) into the registry.

    You right click on the folder (Not in the registry), then you choose take ownership options.

    If you wanted to take ownership of C:\Documents and Settings. You would right click on that folder and choose take ownership. Then a uac prompt will ask you if you want to allow the changes, and you click on yes.
     
    groze, Jul 14, 2015
    #9
  10. shmu26 Win User
    got it, and did it. but I still receive that annoying message that I don't currently have access to my documents, and I need to regain access every time, on a temporary basis.
     
    shmu26, Jul 15, 2015
    #10
  11. groze Win User
    Sorry, I wish I could help further. I have not tested take ownership registry file on the newest build of 10 because I haven't got the new build of windows 10 yet. If the take ownership registry file doesn't work, it will make it a lot harder and more complicated to take ownership of c:\documents and settings folder. It is still possible but it has to be manually done and I am not good at explain how to do that.
     
    groze, Jul 15, 2015
    #11
  12. shmu26 Win User
    I just tried it out to see, but I anyways am the owner of documents, according to what windows tells me, so that's probably not where the problem lies. It seems to be the kind of glitch that goes away only when you do a clean reinstall.
    thanks for telling me about this very useful tool.
     
    shmu26, Jul 15, 2015
    #12
  13. Hydranix Win User

    lack permissions to my documents

    Hey, I know what your problem is.

    On Windwos XP, the "Users" folder was called "Documents and Settings".

    On Vista and 7, Microsoft was worried that by changing the name of a folder which was vital to a lot of programs running correctly, would render a bunch of software broken.

    So they used a new filesystem addition (actually an old Unix idea), called the "Symbolic Link".

    Symbolic Links are kind of like shortcuts, but they don't actually take up space on the hard drive. (Shortcuts do, albeit a very small amount). They point to other files or directories, and are supposed to be mostly transparent to programs and scripts which might use one.

    They can also potentially be a security risk. Since they point to other files or directories on a filesystem (or across filesystems) they can be maliciously employed to give an anonymous user access to system directories (which lack proper ACLs [aka permissions]).

    The other problem that symbolic links can cause is known as "recursive linking" or having a symbol link which points to directory above itself in a directory chain. This might not seem like a big deal, but you can witness it being a problem by using that very registry file that you've installed.

    That script will recurse down through directories until it runs out of files to change the ownership of. If it came across a symbolic link to the directory above itself, the poorly written script would endlessly loop, consuming system resources, potentially doing damage.

    Because of this, Microsoft has made the default security of symbolic links as only being usable by privileged and high-integrity processes. This allows installations made for XP to still work properly on Vista and 7, while preventing wanna-be hackers from "symlinking" a Windows computer, and bad script writers from making Microsoft look bad.


    In short:
    That "folder" you're trying to access isn't actually a folder at all. Its a symbolic link which points to ".C:\Users" on your system. So there's no need to worry about it.


    To give yourself access to following synmbolic links, despite the potential risks I pointed out above:

    Press Winkey + R
    Type "gpedit.msc"
    Follow this path:
    Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options

    Double Click
    "System objects: Strengthen default permissions of internal system objects (e.g., Symbolic Links)"

    Change to "Disabled"

    Be Warned: Changing this setting makes your computer more insecure. Don't do it unless you know what you're doing.

    Careful: The group policy settings are very powerful, so much so you can render yourself locked out of your system.
     
    Hydranix, Jul 15, 2015
    #13
  14. shmu26 Win User
    hey, thanks. I will save this post. but I think I'll let the issue alone for the meantime, in light of your caveats. I can work around the problem pretty painlessly, at least until I come up against another brick wall.
     
    shmu26, Jul 15, 2015
    #14
  15. shmu26 Win User
    I think this problem might be related to an upgrade I did.
     
    shmu26, Jul 17, 2015
    #15
Thema:

lack permissions to my documents

Loading...
  1. lack permissions to my documents - Similar Threads - lack permissions documents

  2. can't modify file due to lack of permissions

    in Windows 10 Support
    can't modify file due to lack of permissions: I am admin on my home PC and since i upgraded to 10 i can't seem to do a lot of things. In some cases i have been able to go into the file's properties and allow myself permission but in others not. Why is this? And how can i just have full control over everything? I can't...
  3. Access denied or lack permission on a private network

    in Windows 10 Network and Sharing
    Access denied or lack permission on a private network: My home network consists of one laptop and one desktop. Same local passwords on both, and are registered with the same MS live account. There are no restrictions, and mutual access is without passwords. The laptop is version 2004 and this works well and the desktop is still...
  4. I can't delete certain folders because of lack of permission.

    in Windows 10 Network and Sharing
    I can't delete certain folders because of lack of permission.: Hi, I bought this computer a few months ago and I installed it with Windows 10 Home Activated. Lately This week, when I download anything from the internet that contains a folder Like a .rar file I can't delete the folder, it says I need permissions from the administrator....
  5. Sound (lack of)

    in Windows 10 Drivers and Hardware
    Sound (lack of): Hello all. I woke up today with no audio on my computer. A little background: After years of making do on Windows XP, in 2019 I found a local PC tech guy who made house calls to repair and/or upgrade. I asked him to install Windows 10. After picking up my comp, he later...
  6. My filing system (or lack thereof)

    in Windows 10 Network and Sharing
    My filing system (or lack thereof): In accepting the challenge that is self-learning today's most highly coveted skills (code, GiT, you get it), I managed to get a bit caught up in the learning and let my file system become a complete disaster. Then after a couple accidental and unknown folder moves in the...
  7. lack sufficient permissions

    in Windows 10 Customization
    lack sufficient permissions: My user account refuses to allow me to be the administrator, tells me I lack sufficient permissions to change files. I am the only user. As a test user I can be administrator. Help. Adobe guys spent hours trying to make their apps let me import or export files. Nothing...
  8. Lack of sound !

    in Windows 10 Drivers and Hardware
    Lack of sound !: I no longer have any sound . I unplugged the speakers once when the computer was on and have tried to plug them back in but there appears to be no response . It even says that a device has been unplugged even when one is there .Please help !...
  9. Origin (or lack of)

    in Windows 10 Gaming
    Origin (or lack of): My son introduced me to Mass Effect, which I was playing via Origin. Then the password would not work, so my son changed it. I got back in and got as far as the financial District in the Citadel, then the password stopped working. I had tried offline several times it did not...
  10. Lack of Highlighting

    in Windows 10 Support
    Lack of Highlighting: The lack of effective highlighting of selections in win 10 is finally driving me mad *Smile. Is there anything anyone knows of that can deal with this? I have attached a screenshot. Believe it or not Adobe Acrobat Update service has been selected. There is now way anyone can...