Windows 10: More about TLS Security Setting

Discus and support More about TLS Security Setting in AntiVirus, Firewalls and System Security to solve the problem; Hi - I just encountered this problem when i tried to get to the MICROSOFT site (www.microsoft.com) using my newly-installed Edge browser. According to... Discussion in 'AntiVirus, Firewalls and System Security' started by Number.6, Apr 30, 2019.

  1. Number.6 Win User

    More about TLS Security Setting


    Hi - I just encountered this problem when i tried to get to the MICROSOFT site (www.microsoft.com) using my newly-installed Edge browser. According to *some* of the instructions in the threads here, it said to contact the site to make sure their certificates were configured correctly. given i cannot get to microsoft's own site, i am thinking it cannot be a site issue. i have read about setting the TLS security settings, but i hope microsoft will be interested in what we found here as we tried to troubleshoot the problem.


    We are still running Win 7 on a couple of machines. we have also converted one machine and bought 2 newer desktops with win 10. our win 7 machines do not have any issues. our 2 desktop win 10s both have the problem. I can simultaneously go to the exact same site on my win 7s and win 10s, and no prob with 7, but get the error with a 10.


    we had been having issues with our xfinity wifi router defaulting to an unused, non-subscribed xfinity hotspot, so when the win 10 that was using wifi had the TLS problem, we thought it was related to that. however, the hard-wired ethernet machine has now had the same issue.


    ONE POSSIBLE CAUSE -- the TLS certificate keys on a TIMED certificate. so, the way we have been getting around it is to re-boot the Browser. that has re-set the times--which we thought may be re-syncing the system and certificate times. whatever the reason, that allows us to get in fine...until we let the machine sit for a bit. then it happens again. so, i am convinced one of the problems has to do with SOMETHING doing a time-out regarding the certificate. however, on my latest configuration after checking all the TLS boxes as instructed, even a browser re-boot does not get me to microsoft--on either of my browsers on the win 10 ethernet machine; i have to totally re-boot the whole machine. Note - as long as i keep using the same page, it seems to keep working, but i cannot be sure because it's hard to keep using multiple browser tabs simultaneously.


    when i read in a prev thread that it could be tied to the virus software, i uninstalled avast. but, the problem persisted. i then installed a different antivirus with firewall. but then... the opsys displayed a notification in the lower right saying that BOTH my windows defender and antivirus firewalls were OFF (that i was unprotected). it gave me the option to turn them on, but when i tried, it would not take/apply. so, i went to the individual apps and looked in each one. strangely, in spite of the notification that both were off, BOTH apps said their firewalls were ON. so, i turned off the antivirus firewall and verified each one again. the antivirus said 'off' and the windows defender said 'on.' ...and, the system info agreed.


    THE APPARENT CAUSE IN MY CASE.... at that point, with only windows defender on, i went to the tabs that were being blocked,. and they all reappeared as i watched, as i clicked on them and got focus. i then tried it with the wifi desktop.... so far, so good. however, we would need to let it sit unused or asleep for even longer to be absolutely sure, but we have too much going on and cannot do a deep test yet on that one. yet, the ethernet has been fine the rest of the day, and so far, the wifi machine is looking good!


    the last status of the TLS settings i made to the ethernet machine (before trying the firewall changes) were for only 1.1 and 1.2 active. that is where i had left them when i got to the firewall, so that is what i am set for on that ethernet machine. for the wifi machine, it has active 1.0, 1.1, 1.2. once i confirm the wifi machine remains stable, i will try to add the 1.0 back onto the ethernet machine, as that version is still being used by some sites. i did see a reference to instability for the 3.0 protocol. does anyone else have an opinion as to how prevalent 3.0 is/will be, and if there will be yet another version in the near future?


    Now that support is going away for Win 7, there are surely going to be a bunch of new people like us migrating to Win 10. the whole 10 experience is new to us (even the known issues--such as this TLS problem), so when existing threads are closed, it may be necessary to start a new one--especially when i do not see where a lot of this info was covered. I apologize for starting it again...but i believe i have new/unique observations regarding this issue.


    hope this helps.

    :)
     
    Number.6, Apr 30, 2019
    #1

  2. TLS security setting

    We appreciate your response and the confirmation. To troubleshoot, we suggest the following steps:

    • In the Windows Search bar, type Internet Options.
    • Open the app and got to the Advanced tab.
    • In the Security section, scroll down and add a checkmark to the following:
      Use SSL 3.0

      Use TLS 1.0

      Use TLS 1.1

      Use TLS 1.2
    • After adding a checkmark, click on Apply then OK
      to save changes.

    Give us an update about how it went so we can provide additional help.

    Kind regards.
     
    Jennifer Cha, Apr 30, 2019
    #2
  3. curatia Win User
    Microsoft Edge TLS Security


    After trying everything (not a lot of steps) listed in the Microsoft Edge support site, I did a wider search and found this very simple youtube video that fixed it immediately:

    For those who prefer not to click links the steps are simple:

    1. Click in the Cortana search bar next to the Win 10 Start button

    2. Type internet options

    3. Select internet options (control panel) from the list

    4. Click on the advanced tab

    5. Scroll down to the security section

    6. Make sure the following are all clicked:
    Use SSL 3.0
    Use TLS 1.0
    Use TLS 1.1
    Use TLS 1.2

    7. Click apply

    8. Refresh the page that was giving the error and it should now connect.

    Hope this helps, it was a 30 second fix after hours of pounding my head against the error with the Support site suggestions.
     
    curatia, Apr 30, 2019
    #3
  4. More about TLS Security Setting

    TLS security setting

    I have been trying to figure this out for days. I seen this info and I fixed it in 20 seconds!!! TY so much!!!! Tammy
     
    tammy333bowers, Apr 30, 2019
    #4
Thema:

More about TLS Security Setting

Loading...
  1. More about TLS Security Setting - Similar Threads - More TLS Security

  2. How to fix the Can't connect securely to this page due to unsafe TLS Security settings.

    in AntiVirus, Firewalls and System Security
    How to fix the Can't connect securely to this page due to unsafe TLS Security settings.: After hours and hours of searching and reading about how to fix this issue I finally was able to resolve the problem. I did the following….. Verify the following are checked: Use SSL 3.0 Use TLS 1.0 Use TLS 1.1 Use TLS 1.2 and it did not solve the problem. After...
  3. TLS security settings error - cannot connect to the Internet

    in Windows 10 Network and Sharing
    TLS security settings error - cannot connect to the Internet: Hi - hope someone out there can help me with this: I have a laptop running Windows 10 Pro (Version 1803, OS build 17134.706). I'm having trouble connecting to the Internet via my web browsers. Regardless of which one I use, they fail when connecting to *almost* all...
  4. TLS security settings

    in Windows 10 Customization
    TLS security settings: how do I reset my TLS security settings back to default https://answers.microsoft.com/en-us/windows/forum/all/tls-security-settings/b29e3acf-d709-4b46-8f2c-3fc1581eb163
  5. TLS security

    in AntiVirus, Firewalls and System Security
    TLS security: just reset my computer completyl wipe clean window loaded new only thing on computer is windows newest versio keep getting TLS security issues on web sights how to fix...
  6. TLS Security Question- Firefox,Edge and IE11

    in Browsers and Email
    TLS Security Question- Firefox,Edge and IE11: O.K. Yesterday I ran a DISM restorehealth. When I went to reboot, I also had updates to install (that I hadn't noticed). Since then I have been unable to go to at least 2 sites due to a TLS security reason. I mean the browser(s) just flat out refuse to go there. No option to...
  7. [Password protection on wakeup] - Is set to 'Required' more secure?

    in AntiVirus, Firewalls and System Security
    [Password protection on wakeup] - Is set to 'Required' more secure?: When I upgraded to Win10 from Win 8.1 this value changed to [Required], which is a pain because I like to just hit the spacebar and have the machine ready without the extra fuss (many times a day.) No one untrusted has physical access to the machine, but it wakes up at 4am...
  8. Microsoft Edge TLS Security

    in Browsers and Email
    Microsoft Edge TLS Security: I run Webmin on my local LAN. Firefox opens and runs this without any problem. When I try Webmin to open with Microsoft Edge I get the fommowing error: Can’t connect securely to this page This might be because the site uses outdated or unsafe TLS security settings. If...
  9. System Properties - Protection Settings - Learning more about it . .

    in Windows 10 Performance & Maintenance
    System Properties - Protection Settings - Learning more about it . .: I am trying to learn more about the subject above, and feel sure there are some gurus out there with lots of knowledge about the System Properties in Windows Ten. I suspect many users only use this section for making a restore file. I have heard that only about 5% of the...
  10. TLS 1.3 Internet security protocol was approved

    in Windows 10 News
    TLS 1.3 Internet security protocol was approved: The long-simmering battle over the future of the internet’s most important security protocol is over: TLS 1.3 was approved by the Internet Engineering Task Force after over four years of work and 28 draft versions of the standard. TLS — short for Transport Layer Security —...