Windows 10: Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE

Discus and support Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE in Windows 10 Installation and Upgrade to solve the problem; I am converting an existing Windows 10 Pro laptop to RAID 0 - and I keep getting to the final boot where it says INACCESSIBLE_BOOT_DEVICE. What am I... Discussion in 'Windows 10 Installation and Upgrade' started by awalt, Oct 7, 2015.

  1. awalt Win User

    Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE


    I am converting an existing Windows 10 Pro laptop to RAID 0 - and I keep getting to the final boot where it says INACCESSIBLE_BOOT_DEVICE. What am I doing wrong? The laptop has two 1 TB Samsung 850 SSDs that are identical. Laptop is a HP Zbook 17.

    Here are my steps:

    1. Made a good System Image of C: drive on separate external SSD drive connected by USB. D: drive didn't have anything on it to be saved.
    2. Used Win 10 Pro DVD to delete all partitions/format drives.
    3. Went into BIOS and changed from AHCI to RAID, and also to turn on ability to do Control-I to get to Intel RST ROM.
    4. Rebooted, did Control-I, created a RAID 0 of the two disks.
    5. Rebooted, installed Windows 10 fresh. Verified it would reboot on its own.
    6. Rebooted, went into Repair on Windows 10 DVD. Selected external SSD image to do image restore from.
    7. Rebooted - verified on Control-I that the RAID 0 array is listed as "bootable"
    8. Rebooted - get INACCESSIBLE_BOOT_DEVICE.

    The place it dies - I see the little Windows 10 blue window, and the spinning circle at the bottom - then I get the blue screen with the message.

    I think I listed everything I did - what am I missing?

    :)
     
    awalt, Oct 7, 2015
    #1

  2. Inaccessible_Boot_Device BSOD after KB3176493 Update on RAID 0 Setup

    Thank you very much for the response! I have been hiding the update whilst in a working edition of Windows, which means I have to revert back before the update first. After I revert back to before the update, I download and run wushowhide immediately. I
    then let it scan my computer and select "Hide." I have tried hiding every item in the list-- including the dreaded update KB3176493. I'm continuing to try to get this update to register as hidden.
     
    Bobby Dobby, Oct 7, 2015
    #2
  3. Inaccessible_Boot_Device BSOD after KB3176493 Update on RAID 0 Setup

    Hi Bobby,

    As per the info, I appreciate the time and effort invested to fix the issue. But just to make sure that you have followed the proper steps to hide the update, I recommend that you revert your PC prior to the installation of the update in question. Once done,
    use the tool that is compatible with your OS and hide/block the update provided that you do not restart until the update has been blocked.

    Refer to the article which outlines the steps in detail on How to temporarily prevent a driver update from reinstalling in Windows 10


    Hope this helps

    Regards
     
    Vanessa Sohtun, Oct 7, 2015
    #3
  4. Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE

    The need to install 10 fresh! When similarly working with a storage array of two drives with each still seeing a separate volume but configured into a SCSI array they were fortunately brand new at the time without much on either of them to see backed up onto a 3rd drive. The change of the change of mode in the bios is presently seeing 10's boot configuration made useless where you may end up needing a repair install if not able to use the Startup repair tool or rebuild the boot sector. For that the bootrec /rebuild command would be used once the drive has been selected at the command prompt option when booted live from the 10 media.

    Potential problem? When nuking the first of two primary partitions on the second desktop once the first 7 upgraded to 10 primary was nuked to move the second with the clean 10 install forward the drive was not able to see a new BCD store and boot sector created where the second clean install was then needed to replace the first! When changing from Native IDE to AHCI it took a few full startups for 10 to smooth out but later had to be reverted back in order to boot from optical media.

    For your situation the change is a bit more involved where you may have to revert back or face the need for a replacement install. When setting up any array the usual expectation is to start fresh not simply expect everything to work in an instant due to the pronounced effect the change has on any existing Windows or other OS installations.

    I found one MS solution but was originally intended for 8 on AHCI/RAID issues where the Windows installaiton goes into a loop cycle of restarts you can try out. Changing the ATA Drive setting in System Bios causes reboot loop on Windows 8

    Mainly during the change of bios settings you can run into this type of BSOD situation usually as a result of not seeing a necessary Plug'n'Play type driver go on.
     
    Night Hawk, Oct 7, 2015
    #4
  5. awalt Win User
    Thanks for the reply but sorry that was very hard to understand what part of what you said applied to my situation! Are you saying this will only work to install fresh and then reinstall apps etc. fresh (and restore of files) - in other words can't be done using a system image?
     
    awalt, Oct 7, 2015
    #5
  6. NavyLCDR New Member
    I would use Macrium Reflect Free to make an image of the System Reserved or EFI partition that the system is using to boot - when the new install Windows 10 is functioning correctly. Also make a Macrium Reflect Free rescue disk. Restore you previous system image, which will result in the inaccessible boot device error. Then boot from the Macrium Reflect Free rescue disk and restore only the boot partition that was working.

    You can also boot from the Macrium Reflect Free rescue disk and just attempt to run the fix startup problems utility to recreate your boot files to match the Raid 0 setup.
     
    NavyLCDR, Oct 7, 2015
    #6
  7. Why does he have to download Macrium to another machine being used at the moment to post here? Since 10 isn't booting up to the desktop where he could download and install MR in order to see the image made he needs a live option he can work with if he is unable to access the F8 Repair options like the Automatic repair or command prompt options.

    Another post regarding this type of problem in 10 refers to the use of the Check Disk tool if the Automatic repair previously Startup repair tool fails to work. This was a post at the MS answers site of a similar problem without the AHCI to RAID change but still regarding the same type of error. http://answers.microsoft.com/en-us/w...f-71d1472847d1

    Now since the F8 option didn't work and the Automatic repair was attempted when booted live from the 10 dvd only once? that often takes two or maybe 3 runs to see results. The other option would be seen to at the command prompt option for a run of the Disk Check tool with the command seen in the reply there. The command you can try out as well as is simpy typed as "chkdsk /f/r" without the quotes with the fix and repair switches added onto the command to start the Disk Check tool up.
     
    Night Hawk, Oct 8, 2015
    #7
  8. awalt Win User

    Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE

    So what is the issue I am having? See if I have it correct:
    1. By changing the BIOS to RAID from ACHI, and doing the Control-I to set up a RAID 0 array, the hardware/firmware is set up
    2. When I installed Windows 10 fresh, it created a master boot record (MBR) that supported a boot from RAID array
    3. When I restored my single disk Windows 10 image using the Windows system image backup, it rewrote the MBR to boot from a single disk. So when I rebooted, the system could not find a boot device.

    Is that a correct assessment of what happened?

    If so, I need an easy way to either restore my Windows image and the restore the MBR to boot from RAID, or to restore some other image I created from a third party that I can selectively restore all but the MBR. Unless there is some way to "fix" the MBR after I get to step 3 above, to get it to boot from th existing RAID array.

    Is that correct? Is this the easiest by Navy LCDR - boot from the Macrium Reflect Free rescue disk and just attempt to run the fix startup problems utility to recreate your boot files to match the Raid 0 setup? Where is "Fix Startup Problems Utility", is that Macrium?

    or is there an easier way to do this?

    Thanks for your patience and help!
     
    awalt, Oct 8, 2015
    #8
  9. NavyLCDR New Member
    Yes, that is what happened.

    Correct.

    Yes, on the Macrium Reflect Rescue Disk will be an option, I think under restore, to fix startup problems. That is just a utility program that will search your hard drive(s) for windows installations and make the proper entries in the BCD to boot from them. Not sure if that will fix your problem or not.

    You can also try booting from Windows 10 install media and select the repair option in the lower left hand corner instead of install now.

    To summarize your problem - the clean install created the proper MBR/Boot Record/BCD to boot from RAID 0. Restoring the system image replaced the RAID 0 boot files with the boot files required to boot from standard AHCI disk setup. Your solution is to now replace those boot files with those required for RAID 0 again.

    If you set your bios back to standard booting and boot into your non-Raid Windows 10, you can use Macrium Reflect to create a system image of your standard install that you have now. Then set bios back to RAID 0, do a clean install of Windows 10, and use Macrium Reflect to restore only the C: drive operating partition. I think that will work. Windows system image only lets you backup up and restore the entire hard drive. Macrium Reflect allows you to back up and restore individual partitions.
     
    NavyLCDR, Oct 8, 2015
    #9
  10. awalt Win User
    Thanks for the help on this, I have spent the last day reading and trying, as Macrium was new to me. Here is what I did, it still does not work; something else is going on.

    I made a Windows image backup on the spare 2nd drive that I intend to use as RAID 0, as "backup" since Macrium was new to me. I then made an image an an external SSD using Macrium. I then deleted my partitions and restored from the Macrium image, knowing I had the Windows image if I messed up the Macrium image backup somehow. Everything worked perfectly.

    So then knowing I had a good Macrium image, and a rescue USB stick, I set the BIOS and firmware to RAID 0/created a RAID 0 array. I then installed a fresh Windows 10 on the RAID array, ensuring it could reboot. I then started a restore of my Macrium image of C: drive.

    I saw there were two partitions the Windows 10 fresh install made, the first a System Reserved partition, the second a C: drive. So I dragged the Macrium image backup to the second partition, so it would not touch the System Reserved partition. On the last screen in Advanced Options it let me select "do not restore MBR from image backup". I thought this would work, but this still gives the INACCESSIBLE_BOOT_DEVICE, and trying both the Macrium boot repair and the Windows 10 boot repair doesn't fix it.

    Note, I also tried in a previous attempt just restoring the whole image backup onto the RAID 0 array, also selecting "Do not replace MBR". But that also did not work - it wiped out the System reserved partition leaving only one partition, which I thought might have been the problem. That's why I thought the first attempt I described above would work - but it didn't.

    So I am out of ideas. Something else is going on that prevents this from booting. Unless someone has an idea, I suppose my choices are stay with single drive, or reinstall everything fresh on a RAID 0 array.
     
    awalt, Oct 9, 2015
    #10
  11. NavyLCDR New Member
    Try this:
    How to: Change SATA Modes After Windows Installation
    If you can't get into safe mode, I think after three failed attempts at booting, Windows 10 automatically goes to Safe Mode.
     
    NavyLCDR, Oct 9, 2015
    #11
  12. When you allowed the 10 installer to create the new primary partition automatically not having selected the Drive tools option that saw the 10 installer automatically create the System Reserved partition which has been seen with Windows since Vista. Most prefer to partition the drive first and then install Windows on the single primary as a rule to avoid seeing that second partition.

    Once you opted not to replace the existing boot sector for the alternate seen with the image being stored you left the drive unbootable by not working the type of set up the image was created from as far as which drive mode. The restoration automatically from a single primary type drive overwrote the entire drive in favor of the image as would any imaging software even the Windows image made if not by another program.

    With all the fuss seen already the quickest and easiest solution was what you had already done with the spare drive instead of the intended SSD drive where you should simply backed up everything you wanted to keep and wipe it clean for a fresh install of 10 only in RAID this time around. Already having download MR you would have simply created the first image of 10 in AHCI with that in the name of the image by the way if MR allows you to name the image your way or not. The Windows option is numbered by Windows only.

    With the AHCI image made up you would then simply proceed to wipe the single primary or replace it fresh with a new single primary and then allowed the 10 installer to proceed from there. Once you have everything back on as far as files backed up and the programs you run you then create a new RAID image not replace the first but to back up the array's install. That would allow you to switch back and forth at any time without the need to see a clean install each time but simply restore the appropiate image giving you options.

    You can try NavyLCDR's suggestion there to see how far you get with it of course but should be prepared to see a fresh copy of 10 go on which generally will insure the best results. Just because something doesn't go immediately wrong is not any guaranty it won't after so many system restarts, power ups, etc.

    Here when previously seeing the two former no longer present storage drives put into a SCSI array I had to do some fast tweaking to avoid losing everything on the drives while most as fortunately backed up between the two OS drives one not in use at the time. And that was with two brand new single partitions on each drive without any OS involved.
     
    Night Hawk, Oct 11, 2015
    #12
  13. awalt Win User

    Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE

    I got it working! Conversion of AHCI -> RAID 0 without a reinstall.

    There were many good tips on this thread but they were largely isolated suggestions and I didn't have a complete step by step, so I spent a few days experimenting, trying things, reading many sites etc. to figure this out. I thought I would post what I found to work here in case someone else needs it, as there is a lot of good AND bad information on the Internet about this.


    My environment - laptop running Windows 10 Pro. I have two Samsung 850 PRO 1 TB SSDs that I wanted to move from AHCI to RAID 0. My system was entirely on the C: drive/first SSD, the D: drive was installed and empty.


    I used Macrium Free as recommended here, it was invaluable to the effort as you will see.


    I also was very careful to be sure I had backups, fallbacks etc. as I was working - I had many trial runs that failed before I found this process that worked, and I need to make sure I didn't lose anything!


    Steps:
    1. Make sure you create and test a Macrium Rescue USB.
    2. Make sure you create and test booting successfully from a Windows 10 Recovery USB.
    3. Use Macrium Free to create an image of C:
    4. Go into Macrium restore only to VERIFY the image - make sure it is good!
    5. Reboot - go into BIOS - change BIOS setting from AHCI to RAID. Be sure (in my BIOS) that ability to enter RAID firmware via Control-I is enabled.
    6. Go into Control-I - create RAID array of the 2 identical SSDs. Select block size of 128KB.
    7. Boot to Macrium Rescue USB - restore backed up image on partition (now just one partition shows, as both SSDs are one RAID 0 array)
    8. Exit Macrium, boot to Windows 10 Recover USB. This is where things didn't work quite right but it worked out ok. The purpose of this step was to boot into Safe Mode - maybe there is a better way?


    I believed that I could boot to Safe Mode through the Recovery USB, because I read that you really can't F8 to Safe Mode with SSD-based systems anymore because they are too fast. So when the Recovery USB booted, first screen I picked US keyboard, then Troubleshoot, then Advanced Options, then Command Prompt. I did a DIR C: and saw my restored image! I typed Exit, and chose Turn off your PC. I assumed that I had been in safe mode, but in retrospect I was not.


    This failed - upon reboot, I got INACCESSIBLE_BOOT_DRIVE. So I rebooted with the Macrium Rescue USB, and did the Fix Boot Repair Problems, and that appeared to go fine as it found the Windows 10 image on C:. But on reboot I got the INACCESSIBLE_BOOT_DRIVE again. I booted to the Windows Recovery USB again, and did Startup Repair, letting that USB take a shot at fixing things - but it said it couldn't fix it. It let me go back in the menu structure, so from that same boot I chose Command Line, and then I was able to run REGEDIT.


    I read this next tip somewhere, that these three regedit locations should have a value of 0 for DWORD Start:


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\storahci
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\pciide
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV



    The problem was, they were already 0. Then I read that each of these had a tree "StartOverride", value of which should be 0. They were all 3, so I changed them to 0.


    When I rebooted, I got a blue screen error saying there was some problem with the disk (I didn't write down the error). Maybe I should have left StartOverride as 3 under iaStorV, since I wanted RAID - it may have been complaining there was no selected disk driver type, but I am guessing here. But!!!! It gave me the option of hitting F8 to enter Safe Boot. PERFECT!


    9. I hit F8, and go into Safe boot.
    10. Once booted up, I run msconfig. I set it to do a Safe boot again from the Boot tab. I reboot. This may not have been necessary, but I wanted a clean automated boot into Safe Mode to be sure, as that is the process that will fix the lack of proper RAID disk drive in Windows.
    11. It boots into Safe Boot, I run msconfig again. I unmark Safe Boot option, and on the General tab I select Normal Startup. I reboot.


    That's it! The original INACCESSIBLE_BOOT_DRIVE problem was that the system booted properly, but the restored Windows image had the wrong disk driver - when backed up it was AHCI, but the hardware/firmware was now RAID. Windows does not load all drives just the ones needed, to speed up the process. When you Safe Boot, ALL drivers are loaded, and it fixes the system/updates the registry to be able to access the RAID drive. Reboot then uses what Safe Boot corrected.


    Once successfully into Windows 10 you may want to run the Intel Rapid Storage Technology program to see if you are happy with the settings.


    Contrary to what you might read you do not have to install a fresh copy of Windows first on the new RAID array. You also do not have to worry about the MBR, it is fine.


    Once into Windows 10 I also uninstalled the Samsung Disk Magician, I don't know if that was good to do or not but I thought it was not needed anymore. Was that correct from a performance persepctive?


    I am running some of my longer running programs now to benchmark. The AS SSD Sequential read went from 525.55 MB/sec to 1037.19 MB/s, and sequential write went from 500.11 MB/sec to 940.84 MB/sec!


    System is running like a champ!
     
    awalt, Oct 12, 2015
    #13
  14. Well that's good news for you then! The idea of seeing a clean install however is not to replace but to plan a clean when you know ahead of time you will be setting up an array or changing from Native IDE to AHCI while a few restarts usually will take care of seeing the correct driver put to use.

    Here I would have first made the system image of the AHCI or Native IDE install and then proceeded with the clean install on a new array to see the second image made for that. This would allow going back and forth over time in case you later decide to break the array up one drive has a problem of some type where you can revert back in necessary. That leaves you options to work with. *Smile
     
    Night Hawk, Oct 12, 2015
    #14
  15. DjDemonD Win User
    @awalt - Can I just say THANK YOU!

    You have saved me a lot of sitting around waiting for windows to fresh install (and download my favourite games etc...)

    This worked perfectly.
    There is one thing I'd correct in your last post.

    I left "StartOverride as 3 under iaStorV" but this results in the inaccessible boot device error so make sure this is set to 0 like the others. Then everything proceeds as in the post. You can go to safe mode and then windows installs the rapid storage driver and my hard drive access speed is now 900Mb/sec. *Smile

    Superb work sir.
     
    DjDemonD, Oct 6, 2016
    #15
Thema:

Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE

Loading...
  1. Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE - Similar Threads - Moving RAID INACCESSIBLE_BOOT_DEVICE

  2. Windows Raid 0, how to save?

    in Windows 10 Network and Sharing
    Windows Raid 0, how to save?: I have a computer I built with a 1TB SSD on the motherboard my windows was loaded on. I have two drives set up as Raid 0 through Windows 10 with important data on them that isn't fully backed up. The SSD appears to have gone bad with my Windows on it, preventing the...
  3. Win 10 raid 0

    in Windows 10 Drivers and Hardware
    Win 10 raid 0: So, I have a server trying to install Windows 10 on. I ran into some issues. It doesn't see my HD during the setup and i am assuming I need a raid0 driver of some kind? Secondly, how do I get Windows 10 to display the full drive since its a 2X2TB setup that I setup as raid0...
  4. 1 SSD or 2 SSD RAID-0

    in Windows 10 Drivers and Hardware
    1 SSD or 2 SSD RAID-0: In preparation for Windows 10 I plan on completely resetting my hard drive configuration since I currently have it spanning four hard drives. Right now my OS sits on a 128GB SSD while all the programs, games, photos, family videos, etc. sit on a mechanical 1TB drive. I...
  5. System Backup before RAID 0

    in Windows 10 Backup and Restore
    System Backup before RAID 0: Hey Guys, I am planning on doing a RAID 0 with my two 1TB HDD's and I was wondering if a system image backup onto an external HDD will work for restoring my OS, programs, and files to the newly raided drives. 87071
  6. Raid 0 ssd drive

    in Windows 10 Drivers and Hardware
    Raid 0 ssd drive: HI all Hope someone can help me. I have a desktop computer in raid 0 samsung ssd drive My problem I have is deleted pictures. I know that raid 0 ssd does not support trim on my p58 atx motherboard so if I delete a file I should be able to recover it? I deleted a...
  7. Raid 0 help required.

    in Windows 10 Drivers and Hardware
    Raid 0 help required.: I have a GT72 6QE Dominator Pro G laptop. Can i delete the recovery partition (120gb -THE W10 OS has 117gb) in the raid array, so i have more SDD storage (2x128 SDD in raid 0)? I was going to use a W 10 home install DVD disc(media creation) to delete the Recovery Partition by...
  8. Question about SSD RAID 0

    in Windows 10 Drivers and Hardware
    Question about SSD RAID 0: I have a 250GB Samsung 850 EVO that I put in my personal laptop back in May. I also have a 250GB Samsung 850 EVO that I just put in my desktop a couple weeks ago. I'm thinking about wiping both, and using both in my desktop for a RAID 0 configuration since I don't use my...
  9. Question on disk space avail RAID 0

    in Windows 10 Drivers and Hardware
    Question on disk space avail RAID 0: I am confused, hope you can help - I have 2 2TB disk drives configured as RAID 0. This is confirmed in Intel RST. RST says 3815 GB total size, roughly 4 TB available, which is what I would expect as RAID 0 supposedly makes available the sum of the drives in the array as its...
  10. Defraggler + SSD raid 0

    in Windows 10 Performance & Maintenance
    Defraggler + SSD raid 0: So i've lived with this for alotta years. Its now on my short list of "things that irk me" to sort out. Ive waited iteration after iteration for piriform to sort it out. I've installed driver after driver for my raid controller. Different versions of windows. The problem...

Users found this page by searching for:

  1. moving raid array windows 10 services currentcontrolset