Windows 10: Opencl.dll on sfc /scannow

Discus and support Opencl.dll on sfc /scannow in Windows 10 Support to solve the problem; hey guys long time lurker here, usually i find solutions on my problem but this time around, i have no idea what to do! Short story: ran sfc... Discussion in 'Windows 10 Support' started by bbnn, Dec 9, 2015.

  1. bbnn Win User

    Opencl.dll on sfc /scannow

    hey guys long time lurker here, usually i find solutions on my problem but this time around, i have no idea what to do!

    Short story: ran sfc /scannow and got the message "found corrupt files but cannot repair," specifically regarding Opencl.dll. Can i fix this w/o doing a reset?

    Long Story (in outline form):
    - got a new SSD
    -with my old HDD still in place(with w7) installed w10 thru usb in the SSD
    -It worked, and thru the desktop i transferred files from my old HDD to the SSD
    -tried to format the HDD thru my computer, did not work, got some error
    -proceeded to format the hdd through w10 installation usb - worked
    -changed the boot order so SSD load first
    -got an error saying no OS is found
    -plugged in w10 usb and did "repair my computer" - worked
    -able to access desktop, play games, etc.
    -decided to run sfc /scannow to be sure, and got that error
    -did a disk cleanup and then ran sfc again, still the same

    also i have attached the log that i got from the sfc

    bbnn, Dec 9, 2015

  2. SFC /SCANNOW report opencl.dll bad

    Just to confirm what PiKohler posted later in this thread, Anniversary Update has cured the inability of sfc /scannow to complete. Whether they fixed the bad opencl.dll thing or it was something else, no idea. But sfc /scannow now works and reports all
    is well with my Windows 10 Pro 64 bit Anniversary Update.
    Mike300ZXna, Dec 9, 2015
  3. PiKohler Win User
    SFC /SCANNOW report opencl.dll bad

    Just executed the Windows 10 Anniversary Update and it works now, finally
    Opencl.dll on sfc /scannow [​IMG]
    PiKohler, Dec 9, 2015
  4. Word Man Win User

    Opencl.dll on sfc /scannow

    Perhaps not, even if you were to do a clean install at this point - see here: SFC some corrupt files can not be fixed

    Normally, folks would advise that the next step is using DISM to repair this problem but, if you check the thread I linked above, you may decide you don't want to reinvent the wheel.

    P.S. - Welcome to TenForums! (now that you no longer lurk)
    Word Man, Dec 9, 2015
  5. bbnn Win User
    I thoroughly enjoyed that thread. haha! Well as of right now, I'm not getting any Errors and can play my games fine. So from what I understand the error may eb caused by conflicts b/w the Microsoft Opencl.dll and the nvidia Opencl.dll.
    bbnn, Dec 9, 2015
  6. Word Man Win User
    That was my take from the thread - looks like everyone's stuck with tolerating the situation (doesn't impact me, however) until MS fixes it. I would suggest monitoring for any update on it.
    Word Man, Dec 9, 2015
  7. rhondalea Win User
    ...and we're all tearing our hair out trying to find a solution to a problem-in-name-only that is not within our control.

    You saved me a lot of work, although I wish I'd found this thread sooner (because that would have saved even more).

    I bought this laptop right before Christmas, and so far, I've refreshed it and reset it, not to mention all the tinkering to clean up errors cluttering my Event Viewer. I was on the verge of a clean install, but I'm not going to waste my time.

    I'm not in love with Microsoft at the moment, but at least the flippin' thing works even if looking at the Event Viewer drives me right out of my mind.

    Thank you again.
    rhondalea, Dec 29, 2015
  8. Word Man Win User

    Opencl.dll on sfc /scannow

    That's the great thing about TenForums - you may have to dig around a bit but can nearly always find someone who's worn your shoes and either shined them up or else stuck them in the closet.*chuckle
    Word Man, Apr 4, 2018

Opencl.dll on sfc /scannow

  1. Opencl.dll on sfc /scannow - Similar Threads - Opencl dll sfc

  2. sfc /scannow

    in Windows 10 Software and Apps
    sfc /scannow: Whenever i try to do sfc /scannow in cmd i get this message : Windows Resource Protection could not start the repair service.
  3. Sfc /scannow

    in Windows 10 Installation and Upgrade
    Sfc /scannow: Hi.I run sfc /scannow as administrator and after finished I got :Windows resource protection found corrupt files and successfully repaired them .Then I restart pc .My question should I do dism or not because I search about it and didn't find an answer. Thanx for help...
  4. sfc /scannow

    in Windows 10 Software and Apps
    sfc /scannow: Hello! When I try to enter the command, it gives me an error:sfc : The term 'sfc' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.At...
  5. SFC /Scannow

    in Windows 10 Gaming
    SFC /Scannow: When I do the SFC /Scannow from the CMD and within the admin area I am seeing after the scan the Verify Only is showing as No repair operation is performed.Is this informing me that I have to do the repair or no repair is needed from my end?Kenneth...
  6. sfc /scannow

    in Windows 10 Gaming
    sfc /scannow: Hey.I've exhuasted all recommendations regarding how to fix the sfc/ scannow command and make it work, namely did the trustedinstaller thing from cmd, i changed the windows modules installer to auto and then back to manual, but I keep receiving the same messages. When I type...
  7. SFC / scannow

    in Windows 10 Customization
    SFC / scannow: I ran SFC / scannow and I'm not sure there was a message. What can I do? I check the application event log for events 1001 and “SFC” I check the DISM.log file I use findstr in CMD to find "[SR]" entries in CBS.log Or Run SFC / showlog...
  8. sfc /scannow

    in Windows 10 Ask Insider
    sfc /scannow: Hi all, does anyone know anything about the logs in sfc /scannow? When I scan my Windows I get no integrity violations however in my logs I see a few things such as: 0000018b Warning: Overlap: Directory \??\C:\Program Files (x86)\ is owned twice or has its security set...
  9. sfc /scannow

    in Windows 10 BSOD Crashes and Debugging
    sfc /scannow: i ran sfc /scannow and got when it reched around 54% i got the followingmessage "Windows Resources Protection could not perform the requested operation"
  10. sfc /scannow

    in Windows 10 BSOD Crashes and Debugging
    sfc /scannow: when I run sfc /scannow in command prompt it will only run to 71% and than it stop, how can i fix that problem?