Windows 10: question about robocopy behavior...

Discus and support question about robocopy behavior... in Windows 10 Backup and Restore to solve the problem; I was trying to do a quick backup of my documents folder, so decided to use robocopy with the /MIR switch: robocopy C:\Users\Brian\Documents... Discussion in 'Windows 10 Backup and Restore' started by couver, May 5, 2021 at 2:12 AM.

  1. couver Win User

    question about robocopy behavior...


    I was trying to do a quick backup of my documents folder, so decided to use robocopy with the /MIR switch: robocopy C:\Users\Brian\Documents D:\Backups\X390\Current\Documents /MIR It was taking a really long time, and what I discovered is that robocopy also backed up my pictures and video folders, as "My Pictures" and "My Videos" as subfolders of "Documents." Since the pictures folder (and all others) are separate folders at C:\Users\Brian\Pictures, etc., why is robocopy seeing them as subfolders of "Documents?" I played around with it a little bit, but didn't come up with a way to only get "Documents"--is there a way to do this?

    :)
     
  2. Bree Win User

    question about robocopy behavior...

    @RolandJS is absolutely correct. 'My Music', 'My Pictures' and 'My Videos' are junctions, and RoboCopy will copy them as if they are folders.

    The way to tell RoboCopy to ignore junctions is to add the /XJD switch to your command line. Type RoboCopy /? for more details.



    question about robocopy behavior... [​IMG]
     
  3. couver Win User
    question about robocopy behavior...

    Well, bingo! I've been using Windows basically since it began, and never heard of "Junctions." I Googled it, and still don't really get it, or why it is there, but I was able to reproduce your screen shot of the command prompt showing those folders as Junctions. I added the /XJD switch after /MIR, and sure enough, just a very quick update of my Documents folder backup.

    Thank you!
     
  4. question about robocopy behavior...

    Robocopy speed question

    I have 2 large files (total 210 GB) being copied by Robocopy between 2 external drives. Task Manager under "Disk" indicates a transfer speed of 30 MB/s.

    A straightforward calculation indicates that it should take 117 minutes to complete the transfer. In practice, however, I am noticing a time to completion of about 250 minutes, or more than double the theoretical calculation.

    Can anyone please explain this large discrepancy or, alternatively, suggest some way to improve on this performance? With Robocopy I use switches /mir /xo /mt:80.

    All suggestions appreciated.
     
    IvanDenisovich, May 5, 2021 at 2:28 AM
    #4
Thema:

question about robocopy behavior...

Loading...
  1. question about robocopy behavior... - Similar Threads - question robocopy behavior

  2. is this Robocopy behavior a sign from Robocopy of fault or Errors ?

    in Windows 10 Backup and Restore
    is this Robocopy behavior a sign from Robocopy of fault or Errors ?: the Indicator you see in the Image below highlighted in Red is Supposed to stay at the bottom and next to the file that is being copied but today while i was copying 300 gb of data like for example files from 1 to 100 it stayed next to file number 30 and followed this file...
  3. Robocopy speed question

    in Windows 10 Installation and Upgrade
    Robocopy speed question: I have 2 large files total 210 GB being copied by Robocopy between 2 external drives. Task Manager under "Disk" indicates a transfer speed of 30 MB/s. A straightforward calculation indicates that it should take 117 minutes to complete the transfer. In practice, however,...
  4. Question about Shift & Windows key behavior

    in Windows 10 Support
    Question about Shift & Windows key behavior: Hello, I'm having a problem with Shift & Windows key. Whenever I press them both, a Windows Start menu appears, which wouldn't matter, but I use an AHK-based program, where a lot of my key combinations are pretty saturated, to assigned macros. Where for example a macro...
  5. ROBOCOPY Log File Question

    in Windows 10 Backup and Restore
    ROBOCOPY Log File Question: Hi Folks, I have been tinkering on and off with the Robocopy command to copy essential documents and files to an SD Card automatically, several times a day (this after my wife's laptop with SSD went belly-up and she lost her most recent work). At the moment, there is a...
  6. Question about robocopy

    in Windows 10 Ask Insider
    Question about robocopy: Hi everyone, I have a problem with robocopy command: i want to make a script for a backup but i only want the most recent files to be copied, i used to do it with the xcopy command with /d parameter but i have some memory issues. Here is an exemple: xcopy "D:\Exemple"...
  7. Robocopy WIndows 10 strange behavior. It will add the root to the path

    in Windows 10 Installation and Upgrade
    Robocopy WIndows 10 strange behavior. It will add the root to the path: Hi Every, I tried to run robocopy on cmd with run as administrator. robocopy '\\server\M Drive\SQL Data\" "E:\SQL Data\" I got an error. The path c:\windows\system32\\\server\M Drive\SQL Data\" does not find on source and c:\windows\system32\E:\SQL Data\ does not find...
  8. Robocopy

    in Windows 10 Customization
    Robocopy: I like Robocopy and used it for a long time but after upgrading from Windows 7 to Windows 10, it got in a loop when I tried to back up via the Documents and Settings Junction. I know that I didn’t change permissions on this folder. But If I try to open it, I get "Access...
  9. ?Question about virus behavior.

    in AntiVirus, Firewalls and System Security
    ?Question about virus behavior.: Hi all, story; I got a virus about 6 months ago[?],,around then,, I had a pro-virus program, and it found virus after virus,after virus,,,,uhh infected files,,, my question is; why didnt the virus program kill the "source of the virus"? was i helping to spread it by...
  10. Question about a System.exe

    in Windows 10 Support
    Question about a System.exe: I noticed today listed in "Startup" (in Task Manager) a System.exe that to be honest i am not sure if it was there before. I checked it and is located in C:\Users\username\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup I let me disable it, but no rename it...