Windows 10: RDP under Build 1607 killing running program on client, upon exit

Discus and support RDP under Build 1607 killing running program on client, upon exit in Windows 10 Network and Sharing to solve the problem; I've been using Remote Desktop (RDP, mstsc.exe) for over 11 years to access my internet radio station server (Windows 10 64 Bld 1607). Before the 1607... Discussion in 'Windows 10 Network and Sharing' started by wmangold, Oct 25, 2016.

  1. wmangold Win User

    RDP under Build 1607 killing running program on client, upon exit


    I've been using Remote Desktop (RDP, mstsc.exe) for over 11 years to access my internet radio station server (Windows 10 64 Bld 1607). Before the 1607 upgrade, RDP always worked the way I need it to (and I PREFER to keep it working vs other options). There are no other programs running on the sever other than Windows Defender and Malwarebytes Premium. I use RDP to run/manage my radio software on the server (SpacialNet's SAM Pro) and for maintaining the server OS and applications, etc.

    The server was upgraded first to 1607 (without my acceptance) but I allowed it to remain since the radio stream worked fine. I noticed each time I did a RDP session from my work PC (Win 10 64, Bld 1607), I would get connected just fine and able to do what I did before. HOWEVER -- as soon as I closed the session -- crap happens:
    1. Closed the RDP session, the radio stream stopped airing. I RDP'd back in, had to exit the SAM program, restart it and voila, the stream began airing again. As soon as I closed the session, the stream stopped. For now, I have to leave the session connected via RDP if I want to keep it going (that's my current unacceptable option)
    2. If the RDP session is in play and I then log into the server from its own console/keyboard, I kill the RDP session on my work PC and again (which kills the stream), I have to exit the radio software, restart it and get it airing again.
    3. I tested an RDP session from a Windows 7 PC and the same issue occurs which gives me the conclusion RDP in the 1607 is dorked up. I tested if from my new MacBook Pro retina and same issue -- kills the stream of the program
    4. I have triple checked the RDP (mstsc) settings to ensure to "play on remote computer" for sound and even tried the other options only to have the stream die upon exiting.
    5. I opened a ticket with SpacialNet (vendor for SAM broadcasting software) and this is the first they have heard of the problem. SAM software has NOT changed in two years so it's not SAM here.
    6. I posted the issue (a while back now) on the MS Community and cannot get anyone to give me feedback, direction etc.

    Anyone have a decent insight for me on this one?

    Will Mangold
    Will's Computer Support, LLC

    :)
     
    wmangold, Oct 25, 2016
    #1

  2. OviStore keeps W-LAN connected

    Keeps the lan connected or doesn't kill the lan connection upon exiting? I experience the second one. I have to kill the wi-fi manulally after exiting ovi store
     
    puasho---01, Oct 25, 2016
    #2
  3. Remote Desktop Issue - Remote computer reboots !

    Strange problem with Remote Desktop:

    Server and Client are both Win-10 Pro Fully Updated (Version 1607 Build 14393.222)

    At the client, I open the Network folder, I can "see" the remote PC

    I can right-click the remote PC and select "Connect with Remote Desktop Connection"

    I can authenticate and use Remote Desktop normally with no issue.

    However, if I try to use a RDP file:

    Double click the RDP file

    Connects, I log in OK at the authentication screen.

    After a couple of seconds the remote computer reboots !

    I have checked the event log on the remote PC

    Nothing to indicate a problem, just an entry for not shutdown cleanly

    I have tried re-creating the RDP file

    Using different client computer also same issue

    No recent changes to any computer

    Security software is Norton 360 Premier fully updated on all computers

    The RDP file has worked correctly until recently ( about mid September )

    So I suspect a recent Microsoft update is the culprit
     
    Steve.Cook4680, Oct 25, 2016
    #3
  4. NavyLCDR New Member

    RDP under Build 1607 killing running program on client, upon exit

    NavyLCDR, Oct 25, 2016
    #4
  5. wmangold Win User
    Thanks for the quick feedback!!! Yes, Win 10 Pro has group policy editor which I'm not an expert on but familiar with and also, I had to go with "pro" in order to use RDP. That is, you have to have RDP on the "client" in order to remote to. Win 10 home edition will not allow "in". You cannot remote 'out" on 10 Home.

    And yes, I do see entries for "Remote Desktop Session host", etc., in the edit. I think you've gotten me in the right area which is very much appreciated! Trying to get this all resolved before I have to leave town for a week and will need this working right.

    I 'believe' I need to "Enable" the options I see and ensure it is set to "Never" --- make sense? Fortunately Win 10 Pro has the group policy editor.

    PS: you still active? I'm a retired O-3E (Air Force - 1994)
     
    wmangold, Oct 25, 2016
    #5
  6. wmangold Win User
    Still no-go based on settings I've been fumbling with. Need more specific direction on what settings need to be set. Would these settings only be set on the host (client) PC? I am looking for ANY setting that simply does NOT affect any running program on the client when exiting (OR) connecting via RDP.

    THANKS ANYONE for your help here!
     
    wmangold, Oct 27, 2016
    #6
  7. NavyLCDR New Member
    On the host computer, In Group Policy Editor, expand Computer Configuration, Administrative Templates, Windows Components, Remote Desktop Services, Remote Desktop Session Host, Session Time Limits. Double click Set time limit for disconnected sessions. Set Enabled, then under options, select Never and apply.

    A program that I like to use on my RDP hosts is RDP Wrapper:
    Releases · stascorp/rdpwrap · GitHub

    It allows you to log in via a remote session without affecting the local console login on the host computer. Don't know if it would help your situation or not. After extracting the zip file I run install.bat as administrator then run update.bat as administrator.
     
    NavyLCDR, Oct 28, 2016
    #7
  8. wmangold Win User

    RDP under Build 1607 killing running program on client, upon exit

    Hmmm -- OK. Will try it.

    Udpate: I don't see any directions on setting it up. I've installed it (bat file run) on both PCs but not sure how I make a connection to the host from the client. Tried a few things out of the blue but not getting anywhere on connecting. Can't find any manual that tells how to make it happen. Is the bat file supposed to be edited first?

    Does RDP wrapper create a service? Is it always running?

    Trying TeamViewer now - really didn't want to get to this and sure wish Microsoft would ANSWER THIS!
     
    wmangold, Oct 29, 2016
    #8
  9. NavyLCDR New Member
    RDP Wrapper requires no setup. After installation you just connect like you normally would. It only needs to be installed on the host. You can tell if it is running by running the RDPConf.exe file included. You'll get a window like this:


    RDP under Build 1607 killing running program on client, upon exit [​IMG]


    If you see the green Listening and Fully Supported indicators, then it is installed and running.
     
    NavyLCDR, Oct 29, 2016
    #9
  10. Samuria Win User
    Are you running the app when you login in which case it will die if you logout unless you runas system
     
    Samuria, Oct 30, 2016
    #10
  11. wmangold Win User
    Again, thanks for the feedback.

    Still somewhat confused here on the "connecting" part. Yes, I did see the window as you showed.

    So, it's on the host. What am I using to connect to the host? My native mstsc.exe program?

    Thanks guys!


    Will
     
    wmangold, Oct 30, 2016
    #11
  12. NavyLCDR New Member
    I don't know if it is mstsc.exe or not. I just type Remote in the search bar and click on the Remote Desktop app that appears at the top of the list. You do log in remotely from just plain old Windows 10 Remote Desktop client. The only thing the RDP wrapper does on the server is intercept the connection request and instead of forcing the logged in local session to terminate first (if there is one) it creates a new session for the remote connection which can run concurrently with any other sessions already running on the host.

    This weekend I logged into my desktop remotely from my laptop and ran disk cleanup. As disk cleanup started, I clicked the X at the top of the remote desktop screen and got a message that the remote session would not terminate and any running programs would continue to run on the remote computer. I clicked OK and my remote session closed. I logged back in remotely and disk cleanup was still running.
     
    NavyLCDR, Oct 30, 2016
    #12
  13. wmangold Win User

    RDP under Build 1607 killing running program on client, upon exit

    Yes, it is RDP when you type in remote (i.e., mstsc.exe in System32 directory).

    I'll give it some testing today and will post back on results. Worse case is I do have TeamViewer working but no where as good as RDP works.

    I will not call this issue Solved until Microsoft fixes the native RDP program without the help of RDP Wrapper. I'm not a fan of band-aide, third party fixes when it comes to the operating system; Microsoft needs to resolve this one and I am holding my breath *Smile.

    Again -- THANKS for the feedback and your time!
     
    wmangold, Oct 31, 2016
    #13
  14. bro67 Win User
    Stop using RDP because it is ancient and has not kept up with the times. Use Teamviewer or VNC.
     
    bro67, Oct 31, 2016
    #14
  15. wmangold Win User
    Sorry, but I have to disagree on using TeamViewer or VNC as better solutions for what "I" need -- RDP is (WAS) a solid, remote desktop tool when the user is strictly the only one needing "full" control of remote (host) systems. I've been using it well over 20 years now and it works on all other hosts I have to access/maintain for my business, except the one I need here in this discussion.

    A little status feedback: I reinstalled RDP Wrapper and tried RDP again -- got to the login screen, entered the password and it crashed the upload stream. Still got access to the host just fine and can do whatever i need except it crashed the stream. Exit the radio software, restart it, and stream stays on (while I'm in the RDP session). As soon as I close the RDP session, stream crashes. Again -- never did this after 11+ years or running my hobby radio.

    SO -- will stick with TeamViewer for now. Don't have time to check out VNC but will consider it. What I'm reading is TV is the best one of the options out there.
     
    wmangold, Oct 31, 2016
    #15
Thema:

RDP under Build 1607 killing running program on client, upon exit

Loading...
  1. RDP under Build 1607 killing running program on client, upon exit - Similar Threads - RDP under Build

  2. Error upon exiting sleep mode

    in Windows 10 Performance & Maintenance
    Error upon exiting sleep mode: I have a Lenovo IdeaPad Yoga running Windows 10 Every time I re-awake my laptop from sleep mode, I get the following error message: “:( Your PC ran into a problem and needs to restart. We’re just collecting some info, and then we’ll restart for you. If you would like to...
  3. RDP hanging and crashing on client machine

    in Windows 10 BSOD Crashes and Debugging
    RDP hanging and crashing on client machine: Hey guys, I hope you are well! I am running into a hang and crash with RDP in between Windows 10 and Windows Server 2008 R2. I have an application running as a remote app on the Windows Server 2008 R2 and in certain cases it seems to be hanging when viewing from Windows...
  4. Delete Browsing History not deleting upon exiting

    in AntiVirus, Firewalls and System Security
    Delete Browsing History not deleting upon exiting: I have tried every suggestion in Google and still does not delete upon exiting (Windows 10) Is there a sure-fire way? I was in 7, switched to 10, back to 7 no problem. New laptop, using 10, won't delete....
  5. RDP client crashes

    in Windows 10 BSOD Crashes and Debugging
    RDP client crashes: Hello Community, Recenty I upgraded to Widows 1803 (OS BUILD 17134.228) Ever since this upgrade, I am unable to RDP to my machine from any other device, running different versions of Windows. The only thing that happens is the Login prompt comes up, I logon, I see a black...
  6. How to bypass a program that knows it's running under a VM?

    in Windows 10 Virtualization
    How to bypass a program that knows it's running under a VM?: Currently using VMware Workstation Pro 12 and I was wondering what are some way/s that I can configure so that the program I'm trying to run doesn't think I'm running it under a VM? 91829
  7. eM Client under Build 9926

    in Windows 10 Software and Apps
    eM Client under Build 9926: I've been unable to get eM Client running under 9926. It apparently installs but doesn't run correctly. I don't want to spend a whole lot of effort at this point getting it to run and will put it aside for now. But if someone here has been able to get it to run then I will...
  8. Office programs won't run under 10

    in Microsoft Office and 365
    Office programs won't run under 10: I am running a dual boot with Windows 7 Ultimate x64 being default and Windows 10 Pro x64 as secondary. I have been running 7 for a couple of years and recently added 10. Maybe I'm not doing something I was supposed to but when I'm in 10 and try to run MS Office 2010, I get...
  9. Build 1607 kills ethernet with wrong driver, fixed but how to keep?

    in Windows 10 Drivers and Hardware
    Build 1607 kills ethernet with wrong driver, fixed but how to keep?: Windows Update to Build 1607 (Pro) installs a newer ethernet driver (but with an older version number??) which doesn't work. Driver roll back option in Device Manager is then greyed out. If I unwind the 1607 update the driver roll back option is then available, and the...
  10. New Desktop Build - Windows Crashes Upon Exiting Sleep Mode

    in Windows 10 Support
    New Desktop Build - Windows Crashes Upon Exiting Sleep Mode: So I just finished this build Friday and everything seems to be working great while running. My only issue is that I can't get it to wake from sleep mode correctly. Pressing a key on the keyboard/mouse seems to initiate wake but the screen never comes on (backlight on the...