Windows 10: Regedit can't finish searching

Discus and support Regedit can't finish searching in Windows 10 Support to solve the problem; Was trying to scan my registry using "find" in regedit. I click on Edit\Find and to look at Keys and Match whole string only for "Run". It will a few... Discussion in 'Windows 10 Support' started by LathropDave, Apr 30, 2016.

  1. Regedit can't finish searching


    Was trying to scan my registry using "find" in regedit. I click on Edit\Find and to look at Keys and Match whole string only for "Run".
    It will a few entries but when it gets to Local Machine\software\wow6432Node\Microsoft\windows\CurrentVersion\Run and I do a F3 to continue, it hangs "Searching the registry". The only option is to "Cancel" and then I get "Registry Editor has stopped working".
    I've run SFC, chkdsk, and done both in safe mode with no problems found. This pc (Dell XPS 8900) is only 2 weeks old. So then I did a Reset and after it was done tried again with the same result.
    Any ideas out there without doing a full rebuild? I did contact Microsoft Help desk. Not much help.

    :)
     
    LathropDave, Apr 30, 2016
    #1

  2. Windows 10 Registry Editor has stopped working

    Got exactly same problem. After latest Windows Update, regedit is working strangely, including:

    • Never-ending search (search dialog won't finish when it can't find next occurence of searched text)
    • After clicking cancel in search dialog (the "Searching the registry..." one), regedit crashes
     
    Martin Zůbek, Apr 30, 2016
    #2
  3. Allen305 Win User
    After Windows 10 1511 Update, Regedit hangs on the Find command

    Removing HKEY_LOCAL_MACHINE\SYSTEM\Setup\Upgrade
    key did not fix the Regedit hang and abort.

    As a favor, try a Regedit Search on your PC name. Let me know if your Regedit Search finishes. Best wishes!
     
    Allen305, Apr 30, 2016
    #3
  4. dalchina New Member

    Regedit can't finish searching

    dalchina, May 1, 2016
    #4
  5. Thanks for replying. I am using OORegEdt in the meantime which works fine. On your link those posts are dated to july of last year and refer to the builds of win 10. I searched all over the internet for current postings on this issue.
    Looking for a way to reinstall/refresh regedit or is it the registry that is problem itself?
     
    LathropDave, May 1, 2016
    #5
  6. OldMike65 Win User
    If you can wait a while, MS will be releasing more updates soon, one of them should fix this issue.
    I have been using a 3rd party reg edit program for years myself. Its a Paid Registered version. Never has given me any
    problems. *Smile
     
    OldMike65, May 1, 2016
    #6
  7. dalchina New Member
    If I recall correctly the problem is to do with the total length of certain entries which is greater than regedit's capability. Hmm.

    However, until someone picks up some definite news, as with MS (apparently) fixing Powershell commands repairing universal apps in the last couple of months, we probably won't know when it happens, lacking detailed info about updates.
     
    dalchina, May 1, 2016
    #7
  8. Regedit can't finish searching

    Thanks for the info. Will give it some time for MS to roll out the updates. I'm in no hurry to rebuild it. Heck just bought it! ha ha
     
    LathropDave, Apr 4, 2018
    #8
Thema:

Regedit can't finish searching

Loading...
  1. Regedit can't finish searching - Similar Threads - Regedit can't finish

  2. File Explorer never finishes searches

    in Windows 10 Ask Insider
    File Explorer never finishes searches: Yet another issue to add to the list of everything that's been reported with 1909's search function. No matter what I've searched for, I get about 99% through a search and results are displayed, but the green bar never reaches the end AND my HDD light is contantly active...
  3. regedit

    in Windows 10 Customization
    regedit: Hi When try to run regedit I now get the following message please could someone give me a solution as I've been unable to resolve this problem https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/regedit/2051bdd6-6232-49fa-b2d1-1ee8b5f1ef18
  4. Regedit crashes during registry searches

    in Windows 10 BSOD Crashes and Debugging
    Regedit crashes during registry searches: When I run a regedit search I am guaranteed that regedit will get stuck every single time while displaying the "Searching the registry" message box. When I eventually click the cancel button, I get the message that regedit has stopped working. I can repeat ad-nauseum, even...
  5. Can't finish logging in

    in Windows 10 Support
    Can't finish logging in: I know this is odd. I am running Windows 10 Pro Insider Preview, Evaluation copy, Build 14316.rs1_release.160402-2217. When I try to repair or restore the computer it won't finish either of these tasks; I can get to the command prompt in the advanced tab. When I type exit and...
  6. regedit crashes when searching

    in Windows 10 Performance & Maintenance
    regedit crashes when searching: On one of my Win10 systems regedit crashes on any search I try. Sometimes it will find a match but then continuing the search for another instance will eventually lead to a regedit crash. The symptom is that regedit looks active and the task manager shows that it is using 25%...
  7. Regedit

    in Windows 10 Performance & Maintenance
    Regedit: Looking for help with how to clean up My regedit. 47927
  8. regedit search broken again 14393.105

    in Windows 10 Support
    regedit search broken again 14393.105: Just noticed regedit search is broken again like it was before. If you search for something that is not found it hangs. I tried regseeker to search and it also hung at 97%. 62514
  9. Cortana search bar not finding things such as regedit

    in Windows 10 Support
    Cortana search bar not finding things such as regedit: My cortana bar seems to be missing some important stuff when I search. Regedit is completely absent when doing search for one. Any ideas why? 23563
  10. [10586.29] Regedit crashes while searching.

    in Windows 10 Support
    [10586.29] Regedit crashes while searching.: Hello. A few days ago I have found out the Regedit crashes on me while performing a search. Running w10 x64. I have run sfc /scannow and it said there were no integrity violations. Any ideas? PS - It even crashes if I hit the CANCEL button while searching. 33212