Windows 10: sound blaster x-fi card blue screen on windows 1809/LTSC

Discus and support sound blaster x-fi card blue screen on windows 1809/LTSC in Windows 10 Drivers and Hardware to solve the problem; first, sorry my english, my x-fi card work on win7-win8.0-win8.1-win10 16xx-1803 it's work fine .not blue screen. but up to win10 1809 pro.. bule... Discussion in 'Windows 10 Drivers and Hardware' started by TaoEx, Dec 7, 2018.

  1. TaoEx Win User

    sound blaster x-fi card blue screen on windows 1809/LTSC


    first, sorry my english,



    my x-fi card work on win7-win8.0-win8.1-win10 16xx-1803 it's work fine .not blue screen.

    but up to win10 1809 pro.. bule screen happen when cold boot pc,loading windows. and reboot sometime can be in to desktop

    i try to use win10 LTSC ,blue screen same with 1809 pro!!! loading windows blue screen, thhe is dump file

    https://pan.baidu.com/s/1smFZKipcXIscmGmOtApI2w

    :)
     
    TaoEx, Dec 7, 2018
    #1

  2. Sound blaster x-fi mb3

    Hi Duncan,

    Welcome to Microsoft Community.

    I understand your concern. Let me help you to fix the issue.

    Let’s try simple troubleshooting steps and check if this helps in resolving the issue. Follow the below methods.

    Method 1.

    I suggest you to run the Hardware and devices troubleshooter to diagnose the exact issue.


    • Press Windows + X keys on the keyboard and select Control Panel.

    • Type Troubleshooting in the search bar on the Control Panel.

    • Click on Hardware and sound under Troubleshoot computer problems.

    • Click on Hardware and devices under Devices.

    • Click on Advanced on the Hardware and devices dialog box and click on Run as administrator (Enter the credentials if required).
    • Click on Next and follow onscreen instruction complete the Hardware and devices troubleshooter.
    If the issue still persist, try the below method.

    Method 2.

    Step 1.

    I suggest you to go to the device manager and uninstall/reinstall the sound adapter driver and check.


    • Press Windows key + X and select
      Device manager
      .

    • Now click on Sound, video and game controllers
      to expand, right click on the device and click on uninstall.

    • Once you are done installing the driver, restart the computer. It will automatically install the sound adapter driver.
    If the issue still persist, try the below steps.

    Step 2.

    I suggest you to update the audio driver and check.


    • Press Windows key + X and select
      Device manager
      .
    • Now click on Sound, video and game controllers and right click on it and
      update the software.
    If the above methods did not help to fix the issue, try the below method.

    Method 3.

    I recommend you to go to the computer manufacturer website and download the latest updated sound adapter driver for Windows 10 and install the same. Visit the below link:

    http://software.store.creative.com/p/software/sound-blaster-x-fi-mb3


    Hope it helps. Keep posting us with the status we will be glad to help you.
     
    Billion Debbarma, Dec 7, 2018
    #2
  3. Sound Blaster X-FI Xtreme Gamer Card

    When I installed Windows 10 my Sound Blaster Sound Card would work only if I uninstalled it in Device Manager and then restarted my computer and let the driver reinstall and then the sound works.

    However here is my research. If you have a Sound Blaster Sound Card go to

    Creative Weltweite Unterstützung

    and look up your Sound Blaster Driver for Windows 10.

    For instance I have a Sound Blaster X-FI Xtreme Gamer Card Model SB073A and my driver won't be ready for installation on my Desktop Computer until this October. So that is why my sound card does not work correctly and as I stated above the only way to get
    it to work now is to uninstall it and then restart the computer and let it reinstall. I can then get sound.

    So will be glad when Creative gets the drivers ready to work on Windows 10 OS.
     
    mmseptember, Dec 7, 2018
    #3
  4. sound blaster x-fi card blue screen on windows 1809/LTSC

    Sound Blaster X-Fi card Inop after Recent Windows 10 update (1803)

    The recent Windows update (1803) obsoleted my Sound Blaster X-Fi card. using Windows drivers or Sound Blaster driver does not fix the problem. Has anyone found a workaround? This upgrade broke the HP Laserjet installation programs and obsoleted my Sound
    Blaster card.
     
    edspyhill01_844, Dec 7, 2018
    #4
Thema:

sound blaster x-fi card blue screen on windows 1809/LTSC

Loading...
  1. sound blaster x-fi card blue screen on windows 1809/LTSC - Similar Threads - sound blaster card

  2. Sound Blaster Recon3Di Problems

    in Windows 10 Drivers and Hardware
    Sound Blaster Recon3Di Problems: So I upgraded my MOBO the other day to a GIGABYTE Z97X-Gaming G1 WIFI-BK Black Edition and I believe there is something wrong with the built-in Sound Blaster Recon3Di or it's drivers. Randomly the audio jumps to it's maximum potential and muffled/distorted (whith headphones...
  3. Sound Blaster X-Fi Titanium HD not working properly in Windows 10 Insi

    in Windows 10 Drivers and Hardware
    Sound Blaster X-Fi Titanium HD not working properly in Windows 10 Insi: I was able to use this card with creative Daniel's K SB X-Fi Series Support Pack 4.0 drivers and the card and the associated creative software and drivers all worked flawlessly on the previous versions of insiders build. After upgrading to the latest build 18282 I had no...
  4. No sound from sound blaster

    in Windows 10 Drivers and Hardware
    No sound from sound blaster: I just installed the most recent windows 10 tech preview last night; but my sound blaster pci express sound card did not get installed correctly or something because i am getting no sound at all. Please help me fix this before I roll everything back to the old setup. 3759
  5. Sound Blaster Z - No Sound

    in Windows 10 Drivers and Hardware
    Sound Blaster Z - No Sound: Hi guys! Some days ago I made a fresh install of Windows 1709 and things appears to be working. Today I`m having some sound problem with my SBZ and I tried to reinstall driver but since then, I have no sound. Thanks for any help 97834
  6. sound blaster on build 10240

    in Windows 10 Drivers and Hardware
    sound blaster on build 10240: I cannot get my surround 5.1 audio to work with this most recent build of 10240; and i cannot get into the enhancements that are supposed to be available for my card which is the x-fi titanium pci express sound card from creative. Is there any way to resolve this or do I just...
  7. No audio: Sound Blaster PCI Express X-Fi Titanium Build 14393.447?

    in Windows 10 Drivers and Hardware
    No audio: Sound Blaster PCI Express X-Fi Titanium Build 14393.447?: My Creative Sound Blaster PCI Express X-Fi Titanium worked just fine with Win 10 (64-bit) prior to the so-called "Anniversary Update" Any solutions would be appreciated. 69708
  8. Sound Blaster X-Fi Surround 5.1 Pro - default Win sound indicator?

    in Windows 10 Drivers and Hardware
    Sound Blaster X-Fi Surround 5.1 Pro - default Win sound indicator?: Hi, I just bought this sound card and installed drivers for Windows 10. (and a crapton of bloatware with UI of Win XP media player...) Everything works well except one thing: when I change the sound (or mute) I don't see Windows 10 volume bar. I mean these: [img] The...
  9. Creative Sound Blaster x Fi Extreme Music failure after clean install

    in Windows 10 Drivers and Hardware
    Creative Sound Blaster x Fi Extreme Music failure after clean install: Mine Dimension 9200 was with no problem in sound after the Win 10 upgrade from Win 7. After two days this afternoon I did a clean install of the Win 10 from a USB (created from Windows media). Following this my Creative Sound Blaster X Fi Extreme Music -failed no sound on...
  10. Sound Issue in Windows 10 with Sound Blaster X-Fi Titanium

    in Windows 10 Drivers and Hardware
    Sound Issue in Windows 10 with Sound Blaster X-Fi Titanium: Hello -- After I upgraded to Windows 10 from 7 Pro, there was no sound. Obviously, Creative Labs has yet to release compatible drivers for many of their sound cards. Nevertheless, I found out that I'd make it work by changing its modes back and forth via its Audio Control...