Windows 10: SSD USB 3.0 is not accessible

Discus and support SSD USB 3.0 is not accessible in Windows 10 Drivers and Hardware to solve the problem; I have been using this SSD for almost 2 years now and I couldn't be happier until a couple of days ago, when my computer did not read it when I... Discussion in 'Windows 10 Drivers and Hardware' started by kevinbaykr, Oct 6, 2015.

  1. SSD USB 3.0 is not accessible


    I have been using this SSD for almost 2 years now and I couldn't be happier until a couple of days ago, when my computer did not read it when I connected. (I use a Qosmio X70, win 10)
    Here's what's happening. When I connect it shows up on the task bar as it's manufacturer's name rather than the name i assigned to it, does not show up in My computer, shows up at "USB mass storage device" in device manager, but does not show up in disk manager and finally it shows up (in it's manufacturer's name again) in "printers and hardware".
    If I try to eject it from the task bar, nothing happens, when I remove the cable a message pop's up saying the device was in use by a program.
    Furthermore when I try to uninstall it from "device manager" the app freezes and is not responsive.

    Is there a way to fix it, I'd rather not lose the files in the SSD, but if it's a must it would be fine; I;d settle for just formatting it and getting it back as it was.

    PS I tried to access the SSD on my windows 7, doesn't show up in any way there. Also changed the cable, nothind happened.

    :)
     
    kevinbaykr, Oct 6, 2015
    #1
  2. BBVR Win User

    USB SSD keeps unmounting when putting laptop to sleep

    I have a Samsung SSD T3 connected via USB (3.0) to my Win10 Dell XPS 15.

    Whenever the laptop goes to sleep the SSD unmounts and is not available when I wake the laptop up again.

    What is required to keep the USB SSD Drive always mounted?
     
    BBVR, Oct 6, 2015
    #2
  3. Gogosb Win User
    Copying files VERY slow, speed drops to zero, even on USB 3 -- no solutions have worked

    I use Samsung SSD and no problems with it, no high utilization when I copy files. The problem is with the USB 3.0 speed.
     
    Gogosb, Oct 6, 2015
    #3
  4. CountMike New Member

    SSD USB 3.0 is not accessible

    Sounds like USB adapter problem otherwise it would show up in disk manager, at least as "Raw".
    You can try another adapter or to take it out of enclosure and try connect using SATA cables on a desktop computer to make sure it's not due to drive itself.
     
    CountMike, Oct 7, 2015
    #4
  5. spapakons Win User
    Right suggestion! I've seen that in a number of cases. Due to some power surge while connecting or disconnecting the cable, the adapter is damaged. Try the disk on another computer or with another SATA-to-USB adapter. If the disk is OK (99% chance) then you can buy a new USB enclosure and put it there. The USB 3.0 version used to be a bit expensive, but prices have dropped.
     
    spapakons, Oct 7, 2015
    #5
  6. An update, I opened up the external and connected it it directly to my mother board.
    The computer froze at the Toshiba logo, had to force shut down. Then connected it to the motherboard with the laptop on, and nothing. As if it's not there, didn't show up in device manager, disk manager or anywhere else...
    What do I do now?

    PS I tried connecting via USB with another wire, same thing happened as described in the original post
     
    kevinbaykr, Oct 7, 2015
    #6
  7. spapakons Win User
    Sorry to bring you the bad news, but in this case the disk is faulty. If it contains valuable data, you can try finding the same model (see part number on label) and preferably manufactured around the same date. Then the two disks will match and an experienced technician can take the working circuit board from the new disk (this will void warranty!) and place it on your original disk. It will bring disk to life where you can either continue using it as it is, or if it has further damage you can at least backup it. In the second case you can backup all your data to a third disk. When ready, the technician puts the working circuit board back on the new disk and you can restore your backup on the new disk. The third disk necessary can be the technician's temporary storage. You don't need to buy two disks!
     
    spapakons, Oct 7, 2015
    #7
  8. SSD USB 3.0 is not accessible

    Well, I'm taking it to a professional tomorrow. Let's see what he will say.
    Good thing the files in it are not THAT important.
     
    kevinbaykr, Apr 5, 2018
    #8
Thema:

SSD USB 3.0 is not accessible

Loading...
  1. SSD USB 3.0 is not accessible - Similar Threads - SSD USB accessible

  2. usb 3 board

    in Windows 10 Gaming
    usb 3 board: just installed a new usb 3 board, but PC cannot find or recognize it. Any thoughts? https://answers.microsoft.com/en-us/windows/forum/all/usb-3-board/e0a97612-4258-4aa9-97e2-7240772ca3eb
  3. 1 SSD or 2 SSD RAID-0

    in Windows 10 Drivers and Hardware
    1 SSD or 2 SSD RAID-0: In preparation for Windows 10 I plan on completely resetting my hard drive configuration since I currently have it spanning four hard drives. Right now my OS sits on a 128GB SSD while all the programs, games, photos, family videos, etc. sit on a mechanical 1TB drive. I...
  4. Raid 0 ssd drive

    in Windows 10 Drivers and Hardware
    Raid 0 ssd drive: HI all Hope someone can help me. I have a desktop computer in raid 0 samsung ssd drive My problem I have is deleted pictures. I know that raid 0 ssd does not support trim on my p58 atx motherboard so if I delete a file I should be able to recover it? I deleted a...
  5. Can't access drives in external USB 3 enclosures

    in Windows 10 Drivers and Hardware
    Can't access drives in external USB 3 enclosures: Ever since I switched over to my new Windows 10 PC, I haven't been able to access my external USB 3.0 enclosures. They are all 4-disk enclosures by IcyDock (Black Vortex). On my old Windows 7 PC, all I had to do was turn it on and all 4 drives were detected via USB 3. Now on...
  6. USB 3 information

    in Windows 10 Drivers and Hardware
    USB 3 information: Having just acquired a USB 3 Hub and a couple of devices for my 2-in-1 hybrid PC, I would welcome some information about their operation. If the Hub or device, such as a card reader / writer or DVD burner, is plugged into the PC's native USB sockets will they run at USB 3...
  7. USB 3 Hub

    in Windows 10 Drivers and Hardware
    USB 3 Hub: I have a new computer and noticed that when using a powered USB 3 hub connected to the ports on the back my USB drive are not connecting. This happens with my HDD's and my SSD's. If I plug the drives in directly to the ports they work. I can use the ports on the front. Is...
  8. Question about SSD RAID 0

    in Windows 10 Drivers and Hardware
    Question about SSD RAID 0: I have a 250GB Samsung 850 EVO that I put in my personal laptop back in May. I also have a 250GB Samsung 850 EVO that I just put in my desktop a couple weeks ago. I'm thinking about wiping both, and using both in my desktop for a RAID 0 configuration since I don't use my...
  9. USB 3 is not runing usb 3 speeds on my board

    in Windows 10 Drivers and Hardware
    USB 3 is not runing usb 3 speeds on my board: So i had to get intel chipset drivers for my board from intel my board is a msi z77a-g45 all drivers show working and functioning here is a picture of the drivers installed, i can't figure out why all my usb 3 devices are not running at usb 3 speed they are running at usb 2.0...
  10. Defraggler + SSD raid 0

    in Windows 10 Performance & Maintenance
    Defraggler + SSD raid 0: So i've lived with this for alotta years. Its now on my short list of "things that irk me" to sort out. Ive waited iteration after iteration for piriform to sort it out. I've installed driver after driver for my raid controller. Different versions of windows. The problem...