Windows 10: SSL_ERROR_RX_RECORD_TOO_LONG when accessing Google

Discus and support SSL_ERROR_RX_RECORD_TOO_LONG when accessing Google in Windows 10 Support to solve the problem; All of a sudden, I get this message when trying to access Google: Error code: SSL_ERROR_RX_RECORD_TOO_LONG This happens when I try to access the... Discussion in 'Windows 10 Support' started by rivre, Jun 28, 2018.

  1. rivre Win User

    SSL_ERROR_RX_RECORD_TOO_LONG when accessing Google

    All of a sudden, I get this message when trying to access Google:


    This happens when I try to access the advanced search page directly. It never used to happen until yesterday. I took the big spring Windows update 2 days ago, and Firefox also updated to v61.0 yesterday, so maybe that broke something?

    If I go to Gmail (not log in), then try Google again, it usually works. Sometimes I have to go back and forth to Gmail a couple times before it works.

    rivre, Jun 28, 2018

  2. Edge Search Does Not Permit Change of Region

    I got these suggestions from the Microsoft Community forum.No. 1 worked for me:

    Thank you for posting the query on Microsoft Community. I am glad to assist you on this.
    We have reproduce the issue here and we are able to access non-regional search for google using Microsoft Edge.
    I would suggest you to try the below steps and check if it helps.
    Step 1:
    Clear browsing data option of Microsoft Edge and check if you face the issue. To do so perform the steps below.

    • Click on the More actions icon next to the feedback icon present on top right corner of the Project Spartan homepage.
    • Select Settings and click on Choose what to clear.
    • Check the boxes Browsing history, Cookies and saved website data and Cached data and files and click on Clear.
    Step 2:
    I suggest you to create a new user account and check if the issue occurs.

    • Go to Settings.
    • Choose Accounts and then select Family and other users.
    • Select add someone else on this PC.
    • Enter a user name and hit next.
    • Click on Finish.
    • Sign out from the current Account and Log into the new account.
    Step 3:
    It could also happen because of network issue. I suggest you to try with different network connection and check if it helps.
    hurricane51, Jun 28, 2018
  3. Unable to connect to Google servers

    There are cases that web content are blocked due to proxy server settings. We suggest that you remove the check mark on the the proxy server box, follow the steps below:

    • Type Internet Options in the Ask me anything bar.
    • Click on Connections tab.
    • Click on LAN settings.
    • Remove check in Proxy server box.
    Once done, access your Google apps and check if issue persist.

    Send your post to keep us updated on how the steps goes.
    Darwin Dim, Jun 28, 2018
  4. fussybob Win User

    SSL_ERROR_RX_RECORD_TOO_LONG when accessing Google

    IE11 Google Toolbar no auto search suggestions, no search history?

    Since the last Win 10 update my Google Toolbar won't list any search suggestions as I type and there is no search history listed. The Google tool bar will allow a search, but after a few searches no search history shows and no "clear search" button is listed either.

    I have turnd on "Suggest searches as you type", and "store search histroy on my computer" in the Google Toolbar options.

    Any suggestions to fix this?
    fussybob, Jun 28, 2018

SSL_ERROR_RX_RECORD_TOO_LONG when accessing Google

  1. SSL_ERROR_RX_RECORD_TOO_LONG when accessing Google - Similar Threads - SSL_ERROR_RX_RECORD_TOO_LONG accessing Google

  2. Cannot access anything google

    in Windows 10 Network and Sharing
    Cannot access anything google: This problem started only this morning, I am using a surface pro 4 with windows 10. I've attempted to reach youtube, google, and gmail and none seem to work. But everything else does work, like IGN, Facebook, and I've done a dns flush, I've reset the modem...
  3. Google classroom is not working/accessible

    in Windows 10 Customization
    Google classroom is not working/accessible: I can't access a specific website which is google classroom. I can access it through other laptops and mobile devices. I used google chrome, internet explorer and firefox but still failed. I'm sure the problem is in my laptop. Please help....
  4. No internet access using Google

    in Windows 10 Network and Sharing
    No internet access using Google: I usually use Yahoo to surf the net and it is OK. But if I try to use Google, I receive a message that I don’t have internet access. How can I change this?
  5. Lost access to everything but google chrome

    in Windows 10 Customization
    Lost access to everything but google chrome: I'm using a SuperSonic tablet running windows 10 that my college gave me but now I cant run anything but Google Chrome. I try to open settings but nothing happens, I try to open Control Panel but it tells me I lack the permissions to access, file manager does the same thing...
  6. Windows 10 access to Google Mail

    in Windows 10 Software and Apps
    Windows 10 access to Google Mail: Windows 10 wants access to my Google mail account. It says it can read, send, delete and manage my email. It states it may be sharing sensitive info. I don't want this but my email does not work if I deny this. HELP??...
  7. Can't access Google services.

    in Windows 10 Network and Sharing
    Can't access Google services.: Greetings, Before this latest update I could access google services using any browser. After this latest update I can't access google services at all using any browser. I have tried Chrome, Firefox, Edge, and Opera. They all give me an error message. Any suggestions?...
  8. accessing google

    in AntiVirus, Firewalls and System Security
    accessing google: How come I get a TLS Security Setting error message when I attemp to log on to Google?
  9. Can't access to Google sites any more

    in Windows 10 Network and Sharing
    Can't access to Google sites any more: I think my PC (Lenovo T450) has been updated with the latest Window version couple days ago. Then it could not access Google web site any more. I tried different Google web sites, none was linked. It just showed a statement as below. Please help how it can't solve the...
  10. Using Google Chrome cannot access

    in Browsers and Email
    Using Google Chrome cannot access Hi all, I do not know what the problem is, but due to hardware limitations, the only browser that runs smoothly on my laptop is Google Chrome. I do have Firefox installed but it runs choppy at best, but google will load on it. I cannot figure this out, but Google will...