Windows 10: Telnet having problems

Discus and support Telnet having problems in Windows 10 Software and Apps to solve the problem; I recently started development on a chat app using Java, I enabled telnet and left it alone while it did its thing. No problems. I start testing my... Discussion in 'Windows 10 Software and Apps' started by Pregrammer, Jan 12, 2021.

  1. Telnet having problems


    I recently started development on a chat app using Java, I enabled telnet and left it alone while it did its thing. No problems. I start testing my chat server using the command "telnet localhost 7171" 7171 is the port I'm using, could be the problem? and start writing some stuff when the client using telnet to simulate client but it does something like this,


    date: xx/xx/xxxx

    date: xx/xx/xxxx

    date: xx/xx/xxxx

    date: xx/xx/xxxx

    date: xx/xx/xxxx

    date: xx/xx/xxxx

    date: xx/xx/xxxx

    date: xx/xx/xxxx

    date: xx/xx/xxxx

    date: xx/xx/xxxx


    Connection terminated


    I don't think too much of it, and I continue on making my program, I change it because I know that it's working, and allow the user to type in some commands, but none of them work, something about telnet feels broken, but it could just be my program. If there's another program I could use to test this again to see if it really is telnet, I would appreciate it. If it's my program then I can hop on over to stack exchange.


    Thanks to all those who help.

    Sincerely, Pregrammer

    :)
     
    Pregrammer, Jan 12, 2021
    #1

  2. Telnet Not in Default Apps

    Telnet works fine from the commandline. It's enabled in Windows options, and I can run it without issue.

    The problem is I can't associate it with the TELNET protocol under default apps. That's because TELNET isn't even an option that I can assign a program to. It's been removed from the list of protocols that can be assigned. Protocols like SCP, FTP, SSH
    are still there, with apps assigned to each. But TELNET, which has always been there, is no longer in the list.
     
    BrianPelletier, Jan 12, 2021
    #2
  3. Nikhar_K Win User
    Unable to assign XShell application to URL: Telnet protocol

    Hi,



    Thank you for writing to Microsoft Community Forums.



    We understand that you are unable to associate XShell application to URL: Telnet. You may go ahead and try adding the program using Registry Editor and see if that helps.



    Note: Important this section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow
    these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.




    Follow the steps to take backup of registry.




    Please follow the steps mentioned below:



    1. Press Windows key + R, to open Run dialog box.
    2. Type regedit and click on OK.
    3. Now, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\telnet\shell\open\command
    4. On the right pane, double click on the (Default) value and change the file location with the location of the program that you want to associate.
    5. Close Registry editor and restart the computer.


    If the issue persists, I suggest you to post your query in
    TechNet forums
    , where we have support professionals who are well equipped with the knowledge on Telnet to assist you with the appropriate details.



    Regards,

    Nikhar Khare

    Microsoft Community - Moderator
     
    Nikhar_K, Jan 12, 2021
    #3
  4. Telnet having problems

    Telnet Not in Default Apps

    Telnet is an app and a protocol.

    I upgraded my Windows 10 from home to pro. Now telnet is not listed in the default apps by protocol; it always has been previously. FTP, SSH, and other similar protocols are all there, just not TELNET.

    My work uses a web-based application to connect to remote sites via telnet, and it depends on the browser being able to fire up a telnet app when a 'telnet://' URL is encountered. This worked great until just recently, I'm assuming my home->pro update caused
    this (though it could be coincidence).

    Any help would be appreciated.
     
    BrianPelletier, Jan 12, 2021
    #4
Thema:

Telnet having problems

Loading...
  1. Telnet having problems - Similar Threads - Telnet having problems

  2. Telnet on windows 10 sends single character

    in Windows 10 Network and Sharing
    Telnet on windows 10 sends single character: Hi, I'm testing a web server manually with telnet, and telnet on windows is sending a single character without waiting for the whole line to be entered. I've tried setting crlf and mode to stream, but it has had no effect. This doesn't seem to happen on other OS's just...
  3. Telnet Not in Default Apps

    in Windows 10 Customization
    Telnet Not in Default Apps: Hello, I am trying to be able to telnet to the nodes on my eve-ng vm running on my windows 10 laptop but telnet does not appear in the default apps. I have enabled telnet client and restarted my laptop but telnet still does not appear in the default apps. What am I doing...
  4. Enable Telnet on Windows

    in Windows 10 Customization
    Enable Telnet on Windows: Hello I am having trouble starting telnet from a command prompt on Windows 7 and Windows 10. I have ensured that Telnet is installed using Programs and Features. I have used services.msc to automatically start the telnet service. On Windows 7 I have added the local user...
  5. Telnet Client issue with posrt 23 error

    in Windows 10 Network and Sharing
    Telnet Client issue with posrt 23 error: telnet cleint says the port 23 error doesn't connect to the server ***Original title: services error*** https://answers.microsoft.com/en-us/windows/forum/all/telnet-client-issue-with-posrt-23-error/625dad3d-2ef8-4874-9f02-bdac3dfb93d9
  6. telnet problem

    in Windows 10 Network and Sharing
    telnet problem: I want to use teraterm to connect Linux which is in private network. But I get a message "Connection timed out". The following is Linux(Ubuntu16.04)'s command result. xxx.xxx.xxx.246 is Windows 10's IP. root@xxxxxx:/usr/share/iptables# telnet xxx.xxx.0.246 22 Trying...
  7. telnet on windows 10

    in Windows 10 Customization
    telnet on windows 10: When I try to turn on the telnet feature, as soon as I click on Turn Windows features on/off....I get a blank screen and the list of features never comes up. This is a brand new right out of the box W10 PC. I have tried using command line and it fails. sfc /scannow was...
  8. Fail to telnet after open port 5501

    in AntiVirus, Firewalls and System Security
    Fail to telnet after open port 5501: Hi, I open port 5501 in firewall (Inbound Rules) and try to telnet locally to the port. It show connect failed. Anything else should I consider in order to allowed port to enable? Meanwhile I use netstat -na to check port open (listening) in my Laptop, the result not show...
  9. Telnet

    in Windows 10 Network and Sharing
    Telnet: Hi All, I just signed up and this is my first post. My question is: since there is no telnet server in Windows 10 that would be the reason I can not Telnet in from my Centos VM Correct? I can Telnet into my CentosVM from my Windows VM but not vice versa, Thank You in...
  10. telnet carriage return (with no line feed)

    in Windows 10 Support
    telnet carriage return (with no line feed): I'm using a windows 10 machine and running putty on it to telnet into a video switcher. The video switcher accepts SIS commands and one of the commands is ECI with a carriage return needed at the end of it - with no line feed. I don't really understand how a carriage return...