Windows 10: The schedule in Optimize drives never works

Discus and support The schedule in Optimize drives never works in Windows 10 Performance & Maintenance to solve the problem; Hello! I've set it to optimize or trim my SSD everyday and increase priority if three consecutive scheduled runs are missed but it never optimizes it.... Discussion in 'Windows 10 Performance & Maintenance' started by klappa, Apr 30, 2020.

  1. klappa Win User

    The schedule in Optimize drives never works


    Hello!

    I've set it to optimize or trim my SSD everyday and increase priority if three consecutive scheduled runs are missed but it never optimizes it. It just plain doesn't work.

    It's been like this for years and I never can get it working how come? Running version 1909.

    :)
     
    klappa, Apr 30, 2020
    #1

  2. Disk optimization scheduling in Windows 10

    Hi,

    Welcome to Microsoft Community.

    I suggest you to follow the below steps and check if it helps.


    • In search select Defragment and optimize drives

    • Click on change settings

    • In optimization schedule

    • In frequency select the options accordingly.
    Please let us know if you need further assistance.

    Thank you.

    `
     
    Divya Murugan, Apr 30, 2020
    #2
  3. Disk optimization scheduling in Windows 10

    NO I do not leave my computer on FULL TIME. I am UP TO 30 OPTIMIZE and then it reads 15 Defragment. Can I run my computer at all while it OPTIMIZES if it ever does. ASKING FOR HELP IN WINDOWS 10 is TERRIBLE. MY COMPUTER ALWAYS TELLS ME IT DID NOT CLOSE
    DOWN CORRECTLY THOUGH I FOLLOW YOUR RECCOMENDATIONS. I SO MISS WINDOWS 7. WINDOWS 10 has been NOTHING BUT A HEAD ACHE !!!!
     
    Penelope JPatrick, Apr 30, 2020
    #3
  4. Sptz Win User

    The schedule in Optimize drives never works

    Drive Optimize Scheduler not working


    As you can see from my printscreen scheduler isn't working. Sometimes it goes up to 40 days last run, I have to do it manually every single time I remember doing it. Windows 10 has NEVER done automatic trimming/defragging on any drive.

    Anyone have a similar issue?


    The schedule in Optimize drives never works [​IMG]
     
Thema:

The schedule in Optimize drives never works

Loading...
  1. The schedule in Optimize drives never works - Similar Threads - schedule Optimize drives

  2. Optimize Drives Not Occurring on Set Schedule

    in Windows 10 BSOD Crashes and Debugging
    Optimize Drives Not Occurring on Set Schedule: I have Optimize Drives set to a monthly schedule. However, I noticed this morning that it has been 32 days since the last optimization and it reads "Needs Optimization." I performed a manual optimization. This utility was broke for a long time until Microsoft fixed it with...
  3. Optimize Drives Tool shows Never Run or Optimization not available in Windows 10

    in Windows 10 News
    Optimize Drives Tool shows Never Run or Optimization not available in Windows 10: [ATTACH]Windows offers disk optimization tools that can help you speed up system performance. In fact, a lot of this is automated and can be scheduled […] This article Optimize Drives Tool shows Never Run or Optimization not available in Windows 10 first appeared on...
  4. Windows 10 & Optimize Drives schedule

    in Windows 10 Customization
    Windows 10 & Optimize Drives schedule: Hello, I'm using Windows 10 version 1909, OS build 18363.900 - latest available for my PC, which is installed on a Kingston A400 SSD. As well known, the SSD needs to be trimmed optimized weekly. Windows have that Optimize Drives tool the old Defragmenter which can do this....
  5. Optimize Drives>Never Run

    in Windows 10 Performance & Maintenance
    Optimize Drives>Never Run: I ran ''optimize'' several times and every time when I close and reopen the window I see this ''never run'' (see screenshot) . Drive C is SSD. [ATTACH] When run ''optimize'' for drive D (HDD) I see this in event viewer: ''The storage optimizer couldn't complete retrim on...
  6. Defragment & Optimize Drives Reports "Never run"

    in Windows 10 Performance & Maintenance
    Defragment & Optimize Drives Reports "Never run": Since upgrading to Windows 10 2004, I have encountered an issue with the tool Defragment & Optimize Drives. First of all, let me state that I have a SSD and realize that defragmentation is not needed. However, I find it odd that the tool reports "Never run" and "Needs...
  7. Defragment & Optimize Drives Reports "Never run"

    in Windows 10 BSOD Crashes and Debugging
    Defragment & Optimize Drives Reports "Never run": Since upgrading to Windows 10 2004, I have encountered an issue with the tool Defragment & Optimize Drives. First of all, let me state that I have a SSD and realize that defragmentation is not needed. However, I find it odd that the tool reports "Never run" and "Needs...
  8. Scheduled drive optimization is OFF but running anyway

    in Windows 10 Ask Insider
    Scheduled drive optimization is OFF but running anyway: Under "Optimize Drives" scheduled optimization is turned off (and has been) but "Current status" column shows it is running anyway, e.g., one drive shows '2 days since last run' and another shows '5 days since last run.' I noticed this after my Macrium Reflect image-based...
  9. Defragment and Optimize Drives & Task scheduler not working.

    in Windows 10 BSOD Crashes and Debugging
    Defragment and Optimize Drives & Task scheduler not working.: I want to defrag my drives but I get an error every time I start up the defragment service. The error I am getting is "Storage optimization cannot start because the task scheduler service is not running. Start the task scheduler service and try again.". And when I start the...
  10. Drive Optimize Scheduler not working

    in Windows 10 Performance & Maintenance
    Drive Optimize Scheduler not working: As you can see from my printscreen scheduler isn't working. Sometimes it goes up to 40 days last run, I have to do it manually every single time I remember doing it. Windows 10 has NEVER done automatic trimming/defragging on any drive. Anyone have a similar issue?...