Windows 10: There is no way to select legacy Korean IME from settings

Discus and support There is no way to select legacy Korean IME from settings in Windows 10 Customization to solve the problem; Hello,This is a problem/question regarding You might have issues on Windows 10, version 20H2 and Windows 10, version 2004 when using some Microsoft... Discussion in 'Windows 10 Customization' started by JeeHoWon, Jun 14, 2021.

  1. JeeHoWon Win User

    There is no way to select legacy Korean IME from settings


    Hello,This is a problem/question regarding You might have issues on Windows 10, version 20H2 and Windows 10, version 2004 when using some Microsoft IMEsIn this article, it says that you can change into legacy IME if you confront any problem with the IME that followed after 20H2or 2004 update. This became a problem for languages such as Japanese, Chinese, and Korean. Luckly, legacy IME support became available for some updates, but the main problem is that the updates are only for Japanese and Chinese. There is no way to select legacy IME on Korean, where the settings page does not follow th

    :)
     
    JeeHoWon, Jun 14, 2021
    #1
  2. 한곤김 Win User

    Some problems in IME for Chinese and Korean

    Microsoft IME for Chinese and Korean has some problem.

    1. Touchscreen interface.

    I use ChangJIe IME in touchscreen. ChangJie IME input is based on Chinese calligraphy and is not phonetic based. In most time, we can easily get only one candidate character. (For example, 倉=人戈日口, no other candidates). So, most time we don't need to select
    character from candidate list. In real keyboard, we press "Space" instead of press number to select character. But somehow, touchscreen keyboard "DOESN'T" allow me to use space key to select character so I need to touch character in the list (even there only
    one) and is very inconvenient. In Android or iOS uses "Space" to hit and select candidate key. If you understand some Chinese, try to see HK Microsoft community and many Hong Kong people complain this problem but seems they just say "We will improve"?

    2. Also touchscreen keyboard, why keystroke appears in the input box? Example, assume we input 倉= 人戈日口(OIAR) so we need press 人戈日口(OIAR) but this will appear in the input box not above touchscreen IME so I need to move my eyes from top to bottom(Example
    we use edge to try search something on the web so we need to type Chinese in the address bar) to see if there is any typo. In Android or iOS system keystrokes will appear at the top of the IME. This should be improved.

    3. Why Chinese and Korean IME include English keyboard??

    I understand most Korean and Chinese people can only speak one or two languages and their display language is also in either Korean or Chinese so therefore they don't need to frequently switch IME and they usually use "Shift" and "Left Alt" to switch English
    input instead of use "Windows + Space" to switch different IME. But why don't you make an option allows Chinese and Korean IME doesn't allow to input English? It is VERY INCONVENIENT when I switch to different language and start to type, it shows English instead
    of Korean or Chinese. in Mac OS, you know they use "Command + Shift" and each IME only has one language and doesn't have problem I just explained. I added "English" in language list to use English as displayed language so English IME also appears in the IME
    list. This makes me to feel I have "Three" English keyboard plus Korean and Chinese keyboard. I'm so sad when I switch to different language and use "Backspace" to remove wrong characters and use "Shift" or "Left Alt" to change language again but I already
    changed to different IME.

    4. Character set for Changjie IME.

    I was studying in Macau so I don't understand simplified characters at all but why those ugly simplified characters appear on the list of candidate keys? I found Microsoft Pingyin only shows Simplified Chinese characters so Changjie IME can eliminates simplified
    Chinese characters. Pleased don't include all characters in Unicode Set of Changjie input but try to eliminate simplified characters in the database or make option to remove simplified characters which are useless for me.
     
    한곤김, Jun 14, 2021
    #2
  3. LeoSeabra Win User
    Cannot type Korean

    Hi Soo,

    Welcome to our community.

    This is Leocadia, an independent advisorr, and I am glad to assist you today.

    We are sorry to hear about this inconvenience. Now, we would like to help you promptly. In fact, this is a very known issue.

    We suggest you to follow the below method and check if it helps:

    This will assume that:

    You speak English

    You want to use Windows in English

    Sometimes you want to type in Korean.

    If that describes you then this guide is for you. Just follow the easy steps. This works whether you actually have a physical Korean keyboard or not (if you don't, the right-alt key will be your 한/영 toggle).

    Typing in Korean on Windows 10 (post-2017)

    Note that my Windows is using the dark theme in these screenshots so yours will probably be white. Everything's the same though. Click these screenshot thumbnails for full-size views.

    Step 1 Right-click on the keyboard icon in the taskbar. Ignore the fact that mine already has Korean in it.

    If you don't see this, just tap the Start menu (or press the Windows key) and type "Region" to open the Region & Language settings.

    Step 2 Inside the Region & Language settings, tap the large "+" to Add a language.

    Step 3 Find "Korean" and tap "next"

    Step 4 Do NOT check the "Set as my Windows display language" unless you want everything in Korean. Just tap Install.

    Step 5 Wait while it downloads the Korean language pack.

    Step 6 When it's done downloading, you'll see this. "Language pack installed"

    Step 7 Scroll down to the link that reads "Advanced keyboard settings"

    Step 8 In the "Override for default input method" section choose "Korean - Microsoft IME"

    That's it! You're done. This setting will ensure that your computer uses the Korean MS IME keyboard, which includes both English and Korean. You don't ever need to use "English US Keyboard" again.

    You can now switch between typing Korean and English either by pressing the right "Alt" key (next to your spacebar), or clicking the new keyboard language icon in the bottom-right of your Windows taskbar, or of course the 한/영 key if you have a physical Korean
    keyboard.

    I assume you know where the Korean letters are on the keyboard. If not you might want to play with the Windows 10 soft keyboard until you get comfortable

    To summarize: After adding the language pack (which obviously the person asking this, go to Additional date, time, & regional settings, click Change Input Methods, click Advanced Settings, set the first two menus to English and Korean, respectively.

    Please let us know if you need further assistance.

    Thank you.
     
    LeoSeabra, Jun 14, 2021
    #3
  4. 한곤김 Win User

    There is no way to select legacy Korean IME from settings

    Some problems in IME for Chinese and Korean

    1. I'm not sure how it was on Windows 8.1 or Windows 7.

    2. All of my Korean and Macau friends have this problem (and suggestions) but we couldn't find any troubleshooting method. Not only troubleshooting, but we have many suggestions which can make IME better for multi-language speakers.
     
    한곤김, Jun 14, 2021
    #4
Thema:

There is no way to select legacy Korean IME from settings

Loading...
  1. There is no way to select legacy Korean IME from settings - Similar Threads - select legacy Korean

  2. Set Japanese IME to hiragana by default

    in Windows 10 Customization
    Set Japanese IME to hiragana by default: Is there any way to make hiragana input the default in Japanese IME? I know that there are keyboard shortcuts but that is not the answer. This issue has been described in more detail at:...
  3. Korean & Japanese IME

    in Windows 10 Customization
    Korean & Japanese IME: why do i need Korean & Japanese IME ? I dont speak either one.. https://answers.microsoft.com/en-us/windows/forum/all/korean-japanese-ime/127122fd-5d4f-4661-bf79-509407fdbd0b
  4. Japanese IME, characters selection not available

    in Windows 10 Customization
    Japanese IME, characters selection not available: Hello, Using Windows 10 Pro, version 1909, IME for Japanese doesn't show the "characters selection" for Hiragana, Katakana, Romaji... [ATTACH] The result of that is that I can't use Japanese on that computer. Why is that? I have already desinstalled, reinstalled... no...
  5. Korean IME Keyboard issues with Hanja conversion

    in Windows 10 Customization
    Korean IME Keyboard issues with Hanja conversion: Hello, since there were few people with enough expertise on this subject in the German community I shall try my luck over here. I have downloaded the Korean IME Keyboard on my Windows 10 laptop and left it at the default settings including ‘Keyboard type 1 with 101...
  6. Korean keyboard / IME not working correct. typing wrong characters

    in Windows 10 Customization
    Korean keyboard / IME not working correct. typing wrong characters: I just got a new PC couple weeks ago. OS Name: Microsoft Windows 10 Education. Version: 110.0.18363 Build 18363 I installed Korean in language setting and yet when I type in Korean keyboard setting it keeps typing wrong characters the whole time. It's really weird. It...
  7. How do i get my Korean IME to use azerty instead of qwerty

    in Windows 10 Customization
    How do i get my Korean IME to use azerty instead of qwerty: So i have a Korean IME so u can select between qwerty and Korean, but is there a way i can make it be azerty instead of qwerty because it's confusing since the keyboard of my laptop is azerty....
  8. Cannot create local users if you are using Chinese, Japanese, or Korean IME on Windows 10

    in Windows 10 News
    Cannot create local users if you are using Chinese, Japanese, or Korean IME on Windows 10: [ATTACH] [ATTACH]Some users are encountering the issue preventing them from creating local users when setting up a new Windows 10 device using Input Method Editor (IME). In this post, we will provide a workaround to mitigate this issue. An Input Method [...] This post Cannot...
  9. Korean IME Input Lost Between Apps / Active Window

    in Windows 10 Customization
    Korean IME Input Lost Between Apps / Active Window: I have several users that want to type in Korean without having to toggle their desired input method each time they click a hyperlink to go to a new web page or change browser tabs. So far this has been an issue in Chrome, IE, and Firefox. The process is open a browser,...
  10. How to change default input language for Korean IME

    in Windows 10 Customization
    How to change default input language for Korean IME: Hello, I'm using WIndows 10 Japanese edition, and I also use Korean IME. When I change IME Japanese to Korean, Korean IME is in English input mode. I have to change Korean IME state English to Korean(Hangul). How can I make Korean input mode(Hangul) is default in...