Windows 10: "To run this application, you must first install one of the following versions of the .NET...

Discus and support "To run this application, you must first install one of the following versions of the .NET... in Windows 10 Installation and Upgrade to solve the problem; I recently decided to perform a system recovery on my desktop because I was unable to uninstall apps and the system was overall slower than usual.... Discussion in 'Windows 10 Installation and Upgrade' started by Bryan Javid, Apr 21, 2021.

  1. "To run this application, you must first install one of the following versions of the .NET...


    I recently decided to perform a system recovery on my desktop because I was unable to uninstall apps and the system was overall slower than usual.


    After the system recovery was successful, Whenever I tried to open or install applications or programs, I would receive the following error :


    "Please set the registry key

    HKLM[COLOR=rgba17, 17, 17, 1]\Software\Microsoft\.NETFramework\InstallRoot to[/COLOR]

    [COLOR=rgba17, 17, 17, 1]point[/COLOR]

    [COLOR=rgba17, 17, 17, 1]to the .NET Framework install location"[/COLOR]


    [COLOR=rgba17, 17, 17, 1]After correcting this I started getting another error:[/COLOR]

    "To run this application, you must first install one of the following versions of the .NET Framework:

    v4.0.30319

    Contact your application publisher for instructions about obtaining the appropriate version of the .NET Framework."


    When I try to install the latest version of the .NET Framework, it says ".NET Framework 4.8 or a later update is already installed on the computer."


    I've tried using Microsoft .NET Framework repair tool with no luck and spent hours searching up if there's a way to uninstall the .NET Framework and reinstall it and found nothing so I'm turning to the community for help.


    Also I'm running on Windows 10.

    :)
     
    Bryan Javid, Apr 21, 2021
    #1
  2. Eric Ber Win User

    getting error message' This application requires one of the following versions of the .NET framework: .NETFramework, Version = v4.5.2

    Hi clareburns,

    The .NET Framework is an integral part of many applications running on Windows and provides common functionality for those applications to run. The .NET Framework 4.5.2 is already pre-installed on your computer. For us to assist you better, kindly answer
    the questions below:

    • Have you made any changes to your computer prior to this issue?
    • What troubleshooting steps have you done so far?
    • Which version and OS build number of Windows 10 is currently installed? To check, press the Windows key, type winver, and press the Enter key.
    • Do you have a third-party security software installed?

    Meanwhile, I would suggest that you download and run the Microsoft .NET Framework Repair tool from this

    link
    . The tool tries to resolve those issues by applying known fixes or by repairing the corrupted installations of the supported .NET Framework versions.

    We're looking forward to your reply.
     
    Eric Ber, Apr 21, 2021
    #2
  3. error 0x800F081F while installing .net 3.5 issue Win 10 x64

    Hello Steebo,

    Thank you for posting your concern in Microsoft Community and we regret for the inconvenience. Let me assist you.

    Please follow the below suggested methods and check if it helps to resolve the issue.

    Sometimes, during an app installation, it needs a specific version of .NET Framework. In those cases, it might automatically install and activate that version. Is it the same in your case?

    Also, are you trying to download and install .net framework because it is a pre-requisite for another application/program to run?

    Now, 0x800F081F is one of the Windows update error codes users usually face. I suggest you to follow these steps to run the Windows inbuilt troubleshooter and check if it helps to identify any potential issue.

    • Write Troubleshooting in the search box and hit enter.
    • Click on Troubleshooting tab.
    • Click on view all option on the upper left corner.
    • Select the Windows Update option from the list.
    • Click Next to run theTroubleshooter.

    Write to us with the updated status and the required information for us to be able to assist you further.

    Thank you.
     
    Sayan_Ghosh, Apr 21, 2021
    #3
  4. niko084 Win User

    "To run this application, you must first install one of the following versions of the .NET...

    Insurgency wont install and run for me....

    I have played and have fully updated CS and Half life 2....
    I am using the newest client and installed the SDK.

    I am completely blown away, if i click the desktop icon it starts the sdk and then closes, and it doesn't show up in my game list...

    First mod attempt install here, followed the directions step by step on the mods website...

    Any ideas?
     
    niko084, Apr 21, 2021
    #4
Thema:

"To run this application, you must first install one of the following versions of the .NET...

Loading...
  1. "To run this application, you must first install one of the following versions of the .NET... - Similar Threads - run application must

  2. There must be an application . . .

    in Windows 10 Network and Sharing
    There must be an application . . .: My computer is a, Dell laptop. Running Windows 10 pro. There are times, I need to "Delete". Very, BIG folders. So big, that it takes hours. Is there an app, I could get. That would just, chew 'em up fast? Hopefully, free? So, give me, good news. Thanks for reading . . ....
  3. To run this application, U must download one of the following .net versions: 4.0.30319

    in Windows 10 Installation and Upgrade
    To run this application, U must download one of the following .net versions: 4.0.30319: HELP PLS https://answers.microsoft.com/en-us/windows/forum/all/to-run-this-application-u-must-download-one-of-the/40a90ef3-dcea-4dd2-a3fb-a1197cec6b7e
  4. You must install .NET 3.5 ?!

    in Windows 10 Installation and Upgrade
    You must install .NET 3.5 ?!: Hello Guys, I had recently come across a strange problem: When ever I tried to Install 'Virtual-Tablet-Server' on my PC, it doesn't even install, it quits with a message saying "You must install .NET 3.5", even though I have had install .NET twice in my PC Uninstalled and...
  5. Version v4.0.30319 of the .NET Framework is not installed and it is required to run version...

    in Windows 10 BSOD Crashes and Debugging
    Version v4.0.30319 of the .NET Framework is not installed and it is required to run version...: My powershell closes immediately the moment i open it. I tried opening it via cmd by typing "powershell /" and it says "Version v4.0.30319 of the .NET Framework is not installed and it is required to run version 3 of Windows PowerShell." Send help guys :<...
  6. you first must install the following versions of the .NET framework: v4.0.3019

    in Windows 10 Installation and Upgrade
    you first must install the following versions of the .NET framework: v4.0.3019: I did install net 4.8. But it still reminded me that need .Net Framework V4.0. https://answers.microsoft.com/en-us/windows/forum/all/you-first-must-install-the-following-versions-of/07da383e-b41e-461e-892e-828cf4d38918
  7. Log in errors - You must log out first...

    in Windows Hello & Lockscreen
    Log in errors - You must log out first...: I've a new computer (all in one desktop) and every single time I log in it comes up with this error... so it logs me out and when I log in again it's with a NEW temporary account.... I'm so frustrated... I personally have two Microsoft accounts (home and work) and my...
  8. getting error message' This application requires one of the following versions of the .NET...

    in Windows 10 BSOD Crashes and Debugging
    getting error message' This application requires one of the following versions of the .NET...: trying to download garminexpress for new satnav - has allowed me to download but wont launch content above message received. Moved from: Windows / Windows 10 / Devices & drivers...
  9. getting error message' This application requires one of the following versions of the .NET...

    in Windows 10 Drivers and Hardware
    getting error message' This application requires one of the following versions of the .NET...: trying to download garminexpress for new satnav - has allowed me to download but wont launch content above message received....
  10. Microsoft: You Must Install This Patch No Matter Your Windows Version

    in Windows 10 News
    Microsoft: You Must Install This Patch No Matter Your Windows Version: Redmond releases security update for all Windows versions One of the updates that Microsoft rolled out as part of this month’s Patch Tuesday cycle comes to address a critical security flaw in absolutely all Windows versions that are still being supported, starting with...