Windows 10: Typing numbers and signs in Japanese IME

Discus and support Typing numbers and signs in Japanese IME in Windows 10 Customization to solve the problem; I have recently learned to use Kana Input where each key is a kana syllable. Before that I used Romaji Input with usual Latin letters. I was typing... Discussion in 'Windows 10 Customization' started by supernova_, Jan 14, 2020.

  1. Typing numbers and signs in Japanese IME


    I have recently learned to use Kana Input where each key is a kana syllable. Before that I used Romaji Input with usual Latin letters.

    I was typing numbers normally as in US layout, but on Kana Input there are syllables on number keys 1 - , 2 - . I found no way to type numbers other than switching to US layout or Romaji Input.

    There are also other signs that I can't type now - ! ? @ %

    I could be doing it by switching back to US layout, but it is a bad solution because I also have a third layout for my native language and it will take a lot of switching to comfortably type. Also the Japanese signs and numbers have different appearance than usual ones - 1234$%?! - . It looks more natural among hieroglyphs. So is there a way to type signs and numbers with Kana input, or, what would be an OK solution for me, a quick way to switch between Romaji and Kana input?

    This is g****y can't find my way out.

    :)
     
    supernova_, Jan 14, 2020
    #1

  2. Japanese typing mode [A] and Japanese typing mode [あ] of Japanese IME don't show up on the bar menu.

    Hi Seizen,



    Thank you for writing to Microsoft Community Forums.



    We reproduced the issue on our lab machine and we were able to get the Japanese IME with both Japanese typing mode.



    As per your screenshot, we see that the English (United States) US keyboard is highlighted in blue. What happen when you select and highlight Japanese Microsoft IME?



    What is the KB number of the Windows update installed, prior to this issue? (Settings>Updates & Security>Windows Updates>View update history)



    Meanwhile, we would suggest you to perform these methods and let us the status of the issue after every method.

    Method 1: Change the Typing settings.

    1. Press Windows + I key to launch
      Windows Settings
      .
    2. Select Device and click on
      Typing
      on the left pane
    3. Scroll down and click on Advanced keyboard settings
    4. Click on Language bar option and select the
      Language bar tab.
    5. Select the radio icon beside Docked in the taskbar and check the box beside
      Show text labels on the Language bar.


    Method 2: Remove Japanese language.

    1. Press Windows + I key to launch
      Windows Settings
      .
    2. Click on Time & Language and select
      Region and Language from the left pane.
    3. Click on Japanese IME under Languages and select
      Remove.
    4. Restart the PC and then repeat step 1 and
      2.
    5. Click on the + sign beside
      Add a language
      and then select Japanese to install it back.
    6. Check if the issue persist


    Hope it helps.



    Aditya Roy

    Microsoft Community – Moderator.
     
    Aditya_Roy, Jan 14, 2020
    #2
  3. Dr. Musou Win User
    i8042prt Japanese IME Windows 10

    Hello,

    Could you please inform me how to correct the Japanese keyboard layout with kbdus.dll step by step? I have no idea what "kbdus.dll" is.

    I am using the US Windows 10 and US keyboard.

    My question is listed below:

    "Microsoft IME Japanese keyboard layout Windows 10"

    Microsoft IME Japanese keyboard layout Windows 10
     
    Dr. Musou, Jan 14, 2020
    #3
  4. Dr. Musou Win User

    Typing numbers and signs in Japanese IME

    i8042prt Japanese IME Windows 10

    Hello,

    Could you please inform me how to correct the Japanese keyboard layout step by step?

    I have no idea what [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters] is.

    I am using the US Windows 10 and US keyboard.

    My question is listed below:

    "Microsoft IME Japanese keyboard layout Windows 10"

    Microsoft IME Japanese keyboard layout Windows 10
     
    Dr. Musou, Jan 14, 2020
    #4
Thema:

Typing numbers and signs in Japanese IME

Loading...
  1. Typing numbers and signs in Japanese IME - Similar Threads - Typing numbers signs

  2. Japanese IME

    in Windows 10 Customization
    Japanese IME: In the language bar, I cannot select 'Hiragana' or 'Katakana' in "Input Mode". Only 'Half-width alphanumeric' is available. What can I do? https://answers.microsoft.com/en-us/windows/forum/all/japanese-ime/d654e92e-7b1b-404b-83b9-77d9e6124c06
  3. Japanese typing mode [A] and Japanese typing mode [あ] of Japanese IME don't show up on the...

    in Windows 10 Customization
    Japanese typing mode [A] and Japanese typing mode [あ] of Japanese IME don't show up on the...: When you choose Japanese IME, Japanese typing mode [A] or Japanese typing mode [あ] is supposed to show up on the bar menu like pictures below. But (after some Windows update?) on my PC, when I choose Japanese IME, neither of them show on the bar menu even though the "J" icon...
  4. Japanese IME Not Working

    in Windows 10 Support
    Japanese IME Not Working: I use Japanese on and off and have been working in the past. At some point it stopped working. When switch to Japanese, the 'A' isn't there like it used to be and there is not option to switch to hiragana, kana as it is not there anymore. I have tried all the shortcuts,...
  5. Japanese IME

    in Windows 10 Customization
    Japanese IME: When I install Japanese Keyboard I have "Japanese IME is not ready yet". It is more than an hour now. Just in term of comparaison: Mac OS 1mn, Android 1mn, Windows forever... https://answers.microsoft.com/en-us/windows/forum/all/japanese-ime/26d989e7-6127-49ff-907a-5b8233c2a84a
  6. Japanese IME Keyboard not typing in kana but just English

    in Windows 10 BSOD Crashes and Debugging
    Japanese IME Keyboard not typing in kana but just English: Hello, I installed the Japanese IME keyboard a year ago, and it was working fine. I would type in the romanji and then the corresponding kana character would appear on screen. I could switch from English to kana at any time via the little keyboard icon at the on the taskbar...
  7. Change IME japanese font

    in Windows 10 Customization
    Change IME japanese font: Hi, I'm using Word (Office 365) and, after studing chinese for several years, I've started to study japanese. My problem is that the default japanese font (Yu Mincho font) doesn't convince me (the writing is quite different in some "characters" that are the same in both...
  8. IME Japanese input

    in Windows 10 Customization
    IME Japanese input: So, set up Japanese as my second input. Each time I hit alt + shift, it will switch to Japanese. However the annoying issue I am dealing with is when it switches to Japanese mode, it is in alphanumeric not hirigana mode, which is extremely annoying because if someone switches...
  9. Japanese IME

    in Windows 10 Customization
    Japanese IME: Yesterday, it was working but when I tried typing today, i can't get the kanjis after typing romaji. Tried changing A to hiragana but it won't change. Please help. https://answers.microsoft.com/en-us/windows/forum/all/japanese-ime/38b6ca97-39c9-46c7-84a7-8074215f13cb
  10. Japanese IME kanji guessing

    in Windows 10 Customization
    Japanese IME kanji guessing: Whenever I use the Microsoft Japanese IME keyboard, it has a little text window where it offers suggestions for what kanji to use. I'd like to turn it off, because I need to study the words in hiragana. Any advice would be great....