Windows 10: USB Storage Devices

Discus and support USB Storage Devices in Windows 10 Drivers and Hardware to solve the problem; I've been using Win10 since the general release. This was an update install on a Win7 laptop. Apart from a few issues (waking from sleep on scheduled... Discussion in 'Windows 10 Drivers and Hardware' started by Anotherusername, Sep 3, 2015.

  1. USB Storage Devices


    I've been using Win10 since the general release. This was an update install on a Win7 laptop.
    Apart from a few issues (waking from sleep on scheduled tasks, lack of control on updates) I have a problem with external devices.
    If I use several USB flash drives/harddrive I'm able to eject one or two but then I can't eject any others. When this happens I don't get the menu option to eject/safely remove the device through "explorer" and the drive doesn't appear in the "safely remove" icon on the task bar. I can still access the drive without issue just don't have any way to eject except to shutdown the laptop. If I reboot the laptop but leave the device attached the eject option reappears.
    The laptop is fully patched and I can't work out what is happening and google hasn't revealed any similar problems except the normal "device is in use" message.
    Any ideas?

    :)
     
    Anotherusername, Sep 3, 2015
    #1
  2. Bruce Hagen, Sep 3, 2015
    #2
  3. usb storage devices

    I have two pc's, a work pc and a home pc. The work pc has no problem importing from any file storage device. The home pc always gives me the "You'll need to provide administrator permission to copy this file". I click continue and get the 'You need permission
    to perform this action" and "You require permission from the computer's administrator to make changes to this file" with the "Try Again" button. I cannot get past this. Each PC has Windows 10 Home. Each was upgraded using the free Win 10 upgrade. I am administrator
    on each computer, and can see the files in file explorer. I have tried the give permission's route and have full permissions on every user account on the home machine to no avail. Anyone have any ideas? Currently I am importing the files to the work PC and
    then copying the file to the home pc over the network.
     
    GeorgeMcMahan, Sep 3, 2015
    #3
  4. Snakeyes Win User

    USB Storage Devices

    Do the flash drives show up on "This PC". Since you can access them I suspect they do. Have you tried right clicking on their icon and using the eject option?
     
    Snakeyes, Sep 3, 2015
    #4
  5. The problem is that when this occurs the drives appear in "This PC" and I can still read/write to them BUT there is no "eject" option until I reboot.
     
    Anotherusername, Sep 3, 2015
    #5
  6. Snakeyes Win User
    If you right click on the icons of the flash drives, and open properties, what do they show up as under the hardware tab.
     
    Snakeyes, Sep 3, 2015
    #6
  7. OK - just been using an external drive, via powered usb hub, without issue - eject option showing. Plugged in a second drive - again eject option showing and accessed without issue. Plugged in a third drive and able to access it with eject option still showing. Ejected this third drive - no errors reported. Went to eject the other two and eject option doesn't show via "My PC" - safely remove hardware on task bar also isn't responding. Clicking on any of the drives that are showing (internal, CD and two external) and then hardware shows all four with the three hard drives showing correctly. Clicking on each of these drives shows them as USB and working correctly.
     
    Anotherusername, Sep 4, 2015
    #7
  8. USB Storage Devices

    Quick update - just checked and 45 minutes after I posted the reply above the Eject function has returned for both of the two external drives that were attached. Safely ejected one and then the eject function disappeared for the other drive. This time after a couple of minutes the eject function returned for the final external drive. Can't see anything specific in event viewer to indicate what is happening. I have a feeling it is going to be difficult to identify/sort - didn't have this problem in Win7
     
    Anotherusername, Sep 4, 2015
    #8
  9. Snakeyes Win User
    This is a longshot, but try hitting the refresh button when you open This PC.
     
    Snakeyes, Sep 4, 2015
    #9
  10. WhyMe Win User
    @Anotherusername

    Since you are using a large number of usb ports at the same time, it is possible they do not all use the same chip. Manufacturers often add their own second chip (in addition to the standard chipset) to increase the number of available ports for improved connectivity.

    • How many USB chips does your motherboard have?
    • Is it always the same ports that do not offer the 'eject' option?
    • Are those ports running off a second chip?
    • If so, have you tried installing the applicable driver?
    • What exact laptop model are using?
     
    WhyMe, Sep 4, 2015
    #10
  11. I'm using a Belkin powered 7 port USB hub to connect the drives to my eMachines E525 laptop via one of its two USB ports. The drives are main brand only, i.e. western digital, maxtor. The issue occurs irrespective of which ports I use on the hub or which drives are connected - so no obvious pattern.
     
    Anotherusername, Sep 5, 2015
    #11
  12. WhyMe Win User
    oh okay then...I was going to suggest checking the driver for secondary usb controller and chipset. But if there is not a discernible pattern then it may be a moot point. Your laptop probably only has the single controller. Sorry
     
    WhyMe, Sep 5, 2015
    #12
  13. USB Storage Devices

    This might help:
    Insert your USB drive
    Type in "Device Manager" in the "search the web and windows" box, and open it.
    Click on "Disk Drives" and then right click on the drive you've inserted and select "Properties"
    Click on the "Policies" tab at the top
    You should have this box where you can select either "Quick Removal" or "Better Performance"

    USB Storage Devices [​IMG]
     
    Cornishman, Apr 5, 2018
    #13
Thema:

USB Storage Devices

Loading...
  1. USB Storage Devices - Similar Threads - USB Storage Devices

  2. Installed a Cruzer Glide USB storage device

    in Windows 10 Drivers and Hardware
    Installed a Cruzer Glide USB storage device: I installed a Cruzer Glide USB storage device. When completed, it told me this device is working properly. I go to the explorer and find there is no mention of the drive installed. In the devises it said it is present; however there is no drive available. Please explain...
  3. USB Mass Storage Device (Code38)

    in Windows 10 Drivers and Hardware
    USB Mass Storage Device (Code38): Hi All I've been working on this issue for a few weeks months now and still no joy. My issue is as follows and I hope someone can point me in the right direction; If I boot the workstation fresh my external USB drive is present and works. That night I am able to run...
  4. Problem Ejecting USB Mass Storage Device

    in Windows 10 Network and Sharing
    Problem Ejecting USB Mass Storage Device: It is getting to the point where every time I leave a USB device plugged into my computer for more than 5 minutes, when I try to eject it, I get the INCREDIBLY annoying message: “Problem Ejecting USB Mass Storage Device. This device is currently in use. Close any programs or...
  5. USB STORAGE DEVICE

    in Windows 10 Drivers and Hardware
    USB STORAGE DEVICE: I've saved all my documents and pictures on my old computer onto a USB memory stick so I could transfer to my new computer, but the memory device isn't showing up when I plug into the new computer....
  6. USB mass storage device problem

    in Windows 10 Drivers and Hardware
    USB mass storage device problem: I am running a windows 10. AMD FX 8320 Eight-Core Processor 3.5Ghz 8GB Ram 64 Bit Windows Version 1803 I am trying to do some work where I need to write data (3D print files) to an SD card for printing. It is part of a product testing cycle. When I first turn the...
  7. Problem with the USB mass storage device driver

    in Windows 10 Drivers and Hardware
    Problem with the USB mass storage device driver: Hi, its my first post. My problem is that my 128gb flash drive wont appear in windows 10 or any programs. It showed up in the Devices section of the control panel, but said there was a problem with the USB mass storage device driver. I reinstalled the mass storage, and it...
  8. VMware-usb storage device not recognized

    in Windows 10 Virtualization
    VMware-usb storage device not recognized: Hello, I'm running Windows XP in Workstation Player on a Windows 10 laptop. My USB CD/DVD drive is able to mount in the Player. So is a flash drive. My Western Digital ssd (My Passport Ultra) is listed in "Removable devices", but fails to mount, giving this error:...
  9. Problems with USB SCSI Mass Storage Device

    in Windows 10 Drivers and Hardware
    Problems with USB SCSI Mass Storage Device: Everytime my Seagate Expansion Portable Drive is plugged into my PC (Windows 10 64bit), Window's Event Viewer repeatedly reports warning messages: Event 129, UASPStor Reset to device,\Device\Raidport1, was issued Also, USB 3 write speed was extremely...
  10. Weird "Generic STORAGE DEVICE USB Device"

    in Windows 10 Support
    Weird "Generic STORAGE DEVICE USB Device": So I finally decided to do something about this. There is always a Safely Remove icon on my taskbar, so I click it and there is nothing to remove. In Device manager, it is also present under Disk Drives. Even under my computer there is a disk drive with the letter "D" that...