Windows 10: usb thumb drive ejection problem.

Discus and support usb thumb drive ejection problem. in Windows 10 Network and Sharing to solve the problem; Just two or three days ago I started having a problem when I try to eject a Sandisk 32GB usb thumb and get the nasty li'l "device is currently in use"... Discussion in 'Windows 10 Network and Sharing' started by Pan Demic, May 29, 2020.

  1. Pan Demic Win User

    usb thumb drive ejection problem.


    Just two or three days ago I started having a problem when I try to eject a Sandisk 32GB usb thumb and get the nasty li'l "device is currently in use" window. I've been using this thumb for over a year now with no problems. I haven't made any changes to the computer or to the usb drive to coincide with the onset of this issue. I typically have ejected it by clicking on it in the notification tray, when this problem arose I tried ejecting it through Windows Explorer by right-clicking on the drive in the explorer window, but now the context menu that pops up doesn't even have the eject option - which it did previously. Right now I'm turning the computer off to remove the thumb drive. Any info or assistance is appreciated.

    :)
     
    Pan Demic, May 29, 2020
    #1

  2. ejecting a usb drive in 10

    Hi Walden,



    I realize the inconvenience you are experiencing with accessing Safely Remove and Eject Media USB icon on the taskbar.



    To assist you better, please provide us the below information:

    • When you say that "not I can not get it to show up in bottom right lower", are you referring that you are not able to see the Eject USB icon under the show hidden icons?


    I suggest you to follow the steps below to understand the system

    1. Click on Search bar.

    2. Then type "Select which icons appear on the taskbar" without the quotes in the search bar and click on it.

    3. Turn on Safely Remove Hardware and Eject Media icon.

    Reply to us with the information, so that we can assist you better.



    Please get back to us with an update on issue, we will be happy to help.



    Thank you.
     
    Nyima Yonten, May 29, 2020
    #2
  3. Windows 10 won't eject USB thumb drive

    Here is a curious behaviour. I have Kaspersky anti-virus installed on this machine. When I plug in a thumb drive, Kaspersky offers to scan it but then hangs up when I give it the go-ahead. Right clicking on the thumb drive in explorer (is that what they call it these days?) and requesting a Kaspersky virus scan runs fine. This is super suspicious. I did try uninstall the greyed out hidden devices as suggested by Ztrucker but I am still getting the weird "eject" thing happening. Right click context menu, and eject does not eject the drive, it still appears in the "safely remove hardwire" icon on the toolbar...

    Reinstall windows or do we think this is fixable?
     
    selwynpolit, May 29, 2020
    #3
  4. billcz Win User

    usb thumb drive ejection problem.

    Have to safely eject thumb drive exactly twice every time


    This amounts to an annoyance only, but I thought I'd ask in case someone has a solution.
    I find I always have to eject my thumb drive exactly twice.

    • This happens on at least two laptops:
      • A Toshiba Satellite with Windows 10 Home 10586.545
      • An Asus X555LA also on the same build of Windows
    • Most often I'm using a Cruzer SanDisk drive.
    • This is when I use “Safely Remove Hardware and Eject Media” from the task bar.
    • It always takes exactly two tries. First time get a pop up window “Problem Ejecting USB Mass Storage Device” “Windows is unable to stop the device…” Second time works fine. Even when I do it immediately after the first.
    • This happens when all docs involving the thumb drive and the apps that used them are all closed.
    • It happens if I plug in the drive, don't do anything, then try to eject.
    • Waiting before ejecting doesn’t seem to matter.
    • In Task Manager I verified no associated apps running then tried it. Don’t know if there are pertinent background apps.
    • If I right click on the drive in the File Explorer tree and select eject it works the first time.
    • Another thumb drive, Attache 1GB, behaves the same way.
    • Another thumb drive, Kingston 2 GB, behaves the same way.
    • I think this happened on at least one of my computers before the Windows 10 upgrade, but I don’t remember the details.
    • For the SanDisk at least, select in File Explorer, right click, Properties, Hardware tab, Properties, Change Settings, Policies: Quick Removal is selected.

    Does anyone have a fix? Thanks.
     
    billcz, May 29, 2020
    #4
Thema:

usb thumb drive ejection problem.

Loading...
  1. usb thumb drive ejection problem. - Similar Threads - usb thumb drive

  2. Ejecting usb drive

    in Windows 10 BSOD Crashes and Debugging
    Ejecting usb drive: After updating to Windows 10 version 2004, when trying to eject an external usb drive, I continuously receive the error message that the drive is in use and to wait and try again later. No matter how long I wait, this message recurs when nothing I can see is using the drive....
  3. USB thumb drives

    in Windows 10 Drivers and Hardware
    USB thumb drives: Sorry not really a w10 issue but how much actual data should I expect to get from a 32g drive? I just bought one and it is only 28.6 should I return it? I contacted Sandisk and this is what they said; Thank you for contacting SanDisk® Global Customer Support. I understand...
  4. backup to usb thumb drives?

    in Windows 10 Backup and Restore
    backup to usb thumb drives?: Is it possible to do backups to thumbdrives? If so, is it possible to do those backups with common backup apps such as macrim and/or AOMEI? If so what are the pros and cons? Windows 10 Pro 64 bit CPU: i7-4770k @350GHz Ram: 16GB Graphics: Radeon 580 8GB vram Winver 1903...
  5. Is this USB Thumb drive toasted or is it the USB Port?

    in Windows 10 Drivers and Hardware
    Is this USB Thumb drive toasted or is it the USB Port?: Hello; I found that a 32GB LEXAR USB 3.0 thrumb drive was not being fully recognized by my PC. When using File Manager and clicking on Removable disk (I:) under This PC, I am getting a prompt: Please insert a disk into Removeable Disk (I:). [The volume name used to be shown...
  6. BSOD while trying to Eject a USB Thumb Drive

    in Windows 10 BSOD Crashes and Debugging
    BSOD while trying to Eject a USB Thumb Drive: I was trying to remove a USB Thumb Drive, and that's when it crashed. Also, when it booted back up after the crash, it said there was a problem with my antivirus. My antivirus is working though. If this crash pertains to a driver, please note that I installed the latest...
  7. Windows 10 won't eject USB thumb drive

    in Windows 10 Drivers and Hardware
    Windows 10 won't eject USB thumb drive: I'm struggling with a peculiar little problem. My old faithful windows 10 computer will never eject the USB thumb drive. It doesn't ever show any errors. Its quite puzzling. I have several usb devices currently working including a 4TB usb hard drive, usb keyboard and mouse...
  8. Problem with USB eject icon

    in Windows 10 Drivers and Hardware
    Problem with USB eject icon: On windows 10 (10240 build with all updated), lately I have a problem with the "eject usb" icon in taskbar, when I have a External HDD or USB in my PC (any USB 2.0 or 3.0 port) and then I do click in "safely remove hardware" in the eject icon, I don't get notification or...
  9. USB drives that won't eject

    in Windows 10 Drivers and Hardware
    USB drives that won't eject: Like, apparently, many people, I frequently find that USB drives won't eject because they are supposedly in use. I have seen this question posted in many places, but I have yet to see a solution that works. There are two solutions which are supposed to work, but don't....
  10. Thumb drive issue (problem)

    in Windows 10 Drivers and Hardware
    Thumb drive issue (problem): When I insert my 16 GB Kingston flash drive, many windows pop open, perhaps 10 or so. I reformatted the drive again, closed all the windows, removed and reinserted it, and the same thing happens. Can someone please help. Len 88250