Windows 10: WAN miniport driver (Code 45)

Discus and support WAN miniport driver (Code 45) in Windows 10 Network and Sharing to solve the problem; Hello, this is strange: i read you shouldn't uninstall WAN Miniport drivers, because they are part of Windows. However i don't need PPPOE, PPTP, L2TP,... Discussion in 'Windows 10 Network and Sharing' started by empleat, Dec 15, 2020.

  1. empleat Win User

    WAN miniport driver (Code 45)


    Hello,

    this is strange: i read you shouldn't uninstall WAN Miniport drivers, because they are part of Windows. However i don't need PPPOE, PPTP, L2TP, SSTP, IPV6. So i didn't uninstall them, i only disabled these in device manager. However now all WAN Miniports are hidden and i get (code 45) under "Driver" tab - when i right-click on some driver!

    Whole message:
    Code:
    But i didn't disable IP, Network Monitor, IKEv2. Why are these hidden and report (Code 45). Should i care? However IP, or IKEv2 could be important.

    I uninstalled them and after restart they all showed in Device Manager as normal. I tried again to disable former, yet they all are hidden again... Doesn't make sense! I want to disable only former! I didn't disable IP, Network Monitor, IKEv2! So why are these hidden?!

    Thanks for help!

    :)
     
    empleat, Dec 15, 2020
    #1

  2. wan miniport are not connected code 45 in windows 10

    how to reconnect all wan miniport ,in device manager show ode 45 ,Ido not knowwhen this is happen,what need to do to fix it?

    also my question is if ireinstall windows can fix itthis problem?
     
    HectorEdenburg, Dec 15, 2020
    #2
  3. Windows 10 WAN Miniport Code 38

    I do not have a new installation of Windows 10, this problem just suddenly happened. All was working well. As far as I can tell no updates have been installed immediately prior to this problem.

    When windows first starts the WAN Miniport (IP), WAN Miniport (IPv6), and WAN Miniport (Network Monitor) all start with the error code 45, device not connected.

    When you attempt to connect a VPN each of the three have the yellow triangle with the exclamation mark. Looking at the device status is shows: "Windows cannot load the device driver for this hardware because a previous instance of the device driver is still
    in memory. (Code 38). The driver could not be loaded because a previous version of the driver is still in memory".

    When I try to connect, the VPN Connection reports:

    "A connection to the remote computer could not be established. You might need to change the network settings for this connection."

    The problem is clearly not connection specific, as the WAN Miniports show errors as described above.

    I have tried uninstalling the three WAN Miniport items, and updating the driver. No change to the error. Having said that these three items still show a driver dated 21/06/2006 version 10.0.10586.0, and are the Microsoft ones, and not manufacturer specific.
    So this would seem to be a Microsoft issue and not the manufacturer.

    I have also added and additional network card, and installed it from scratch, with the up to date drivers. No change to the error.

    The troubleshooter did not find any errors!!!

    In the error log I get the following error, but the only thing I could find online did not work.

    Device SWD\MSRRAS\MS_NDISWANIP had a problem starting.

     

    Driver Name: netrasa.inf

    Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}

    Service: NdisWan

    Lower Filters: NdisTapi

    Upper Filters:

    Problem: 0x26

    Problem Status: 0xC000038E

    Microsoft-Windows-Kernel-PnP/Device Configuration

    Source: Kernel-PnP

    Event ID: 411

    I do not want to reinstall Windows 10, which was suggestion I found online. That seem overkill, and not even guaranteed to resolve the problem.

    Surely you must be able to change the WAN Miniport drivers to something more up to date than 2006, if indeed that is the issue, as they have been working fine.

    In both cases the Network card works fine and I can browse the Internet okay.

    Can anybody please help?
     
    JohnBoyIOW, Dec 15, 2020
    #3
  4. Ralf_G Win User

    WAN miniport driver (Code 45)

    WAN miniports missing

    "WHERE I CAN FIND THE DRIVERS."

    The WAN miniport drivers are integral to Windows. They should install/load automatically when called for by a software device that requires them.

    In Device Manager click the "View" menu and select "Show hidden devices" and then look under Network adapters to see if disabled miniport drivers are shown.
     
    Ralf_G, Dec 15, 2020
    #4
Thema:

WAN miniport driver (Code 45)

Loading...
  1. WAN miniport driver (Code 45) - Similar Threads - WAN miniport driver

  2. Can't re-enable WAN miniports

    in Windows 10 Customization
    Can't re-enable WAN miniports: I recently disabled all my WAN miniports while troubleshooting an issue, but now I cant re-enable them. When i look on their properties it displays Code 45 Currently, this hardware device is not connected to the computer. Code 45 To fix this problem, reconnect this hardware...
  3. BSOD caused by RASPPPOE.sys and WAN MINIPORT PPPOE

    in Windows 10 BSOD Crashes and Debugging
    BSOD caused by RASPPPOE.sys and WAN MINIPORT PPPOE: Hi All, We have a series of Dell Latitude 3410's that is getting BSOD on reboot or Shutdown. There may be more users with devices that is not reported this issue. However the few that has are on Dell Latitudes 3410 According to the minidump files it comes down to the...
  4. wan miniport network adapters missing

    in Windows 10 Drivers and Hardware
    wan miniport network adapters missing: I need the following wan miniport network adapters in order to run Norton 360 VPN. they are IKEV2, IP, IPV6. I will also need their drivers. How to I find and install these network adapters? Dell Inspiron All-In-One 0 Windows 10, 1909...
  5. WAN miniport IKEv2

    in Windows 10 Drivers and Hardware
    WAN miniport IKEv2: While trying to troubleshoot/repair windows not able to automatically detect this networks proxy settings after waking from sleep mode, I have accidentally deleted WAN miniport (IKEv2). How do I get it back on windows 10? Thanks....
  6. WAN Miniport L2TP / IKEv2 Drivers Locking up

    in Windows 10 Network and Sharing
    WAN Miniport L2TP / IKEv2 Drivers Locking up: Hi all, We have a number of sites which have L2TP / IKEv2 VPNs configured (various server/router hardware and configurations). In all cases though we use the Windows 10 in-built vpn client to connect and all are configured with pre-shared keys and typically RADIUS...
  7. Missing WAN Miniports after upgrade

    in Windows 10 Network and Sharing
    Missing WAN Miniports after upgrade: I upgraded a perfectly running Windows 7 pro to Windows 10 pro. Everything looked great after the upgrade but I did have to tweak a few things here and there. The problem came when I tried to Windows VPN to connect to my office and it just sites there at "Connecting to...
  8. wan miniport on pc

    in Windows 10 Network and Sharing
    wan miniport on pc: Does not connect to modem anymore. I worked yesterday. https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/wan-miniport-on-pc/4f5b7f89-aa0f-43a7-81c1-b86ef4c4196a
  9. Is WAN Miniport (PPOE) needed on desktop?

    in Windows 10 Network and Sharing
    Is WAN Miniport (PPOE) needed on desktop?: Just installed new modem, Linksys CM3016 and modem WRT3200ACM., had to call Linksys to set up but here's my question, in Network Connections it states "Broadband Connection, Disconnected, WAN Miniport (PPOE)" and the statement has a green check mark next to it, When I go to...
  10. Wan Miniport Device Manager

    in Windows 10 Network and Sharing
    Wan Miniport Device Manager: hey guys installed the latest build today, everything seems fine.. i found 8 devices under networking in device manager.. all wan miniport and this wasn't there earlier ( before the update ). everything is green and working but i don't even know what is it and do i...