Windows 10: WindowsApps not able to be deleted...

Discus and support WindowsApps not able to be deleted... in Microsoft Windows 10 Store to solve the problem; I'm trying to delete a WindowsApps folder in my D drive. I'm unable to delete them despite giving myself permission to do so. I get the following... Discussion in 'Microsoft Windows 10 Store' started by ChaunFarmer, May 5, 2019.

  1. WindowsApps not able to be deleted...


    I'm trying to delete a WindowsApps folder in my D drive. I'm unable to delete them despite giving myself permission to do so.


    I get the following error:


    "You need permission to perform this action

    You require permission from (My name) to make changes to this folder"


    To help trouble shoot why I can't do this, these are the following steps I've taken:


    I've gone into Properties > Security > Advanced. I've changed everything I needed to and gave everything full control, yet I'm still unable to do so.


    I've tried to go into cmd and powershell and delete them. YES I've ran them both as admin. Yet I still have insufficient permissions.


    YES I'm on the main admin account on the computer. There is only one account on the computer, and that's the one I'm on.


    NO I'm not on some other account that isn't an admin.


    I've used

    • takeown /f "c:\foldername" /r
    • icacls "c:\foldername" /reset /t

    in PowerShell, and it says it's not owned by me.


    No permission/Access is denied if I use anything CMD related such as trying

    • rmdir /Q /S D:/foldername
    • del /f filename
    • DEL /F/Q/S *.* > NUL


    I've tried to download third party software to format my harddrive and I can't due to limited space now. I have less than a few kb on my C drive.


    I've spent the last two days going through the internet trying anything and everything I can to delete this file, but I cannot seem to be able to do so.


    I'm aware this is a file I shouldn't delete, however it only has two things on it. Halo 5 Forge (Which is already uninstalled), and Halo 5 Forge Picture. That is it, so I don't want to hear a "You shouldn't delete this" It's keeping me from being able to extend my C drive, and I need this issue fixed ASAP

    :)
     
    ChaunFarmer, May 5, 2019
    #1
  2. S.cloris Win User

    WindowsApps folder says permissions are corrupted and need to be deleted, is this normal or critical?

    According to your description, I suggest you try the following steps:

    1. Navigate to the location C:\Program Files.
    2. Right-click on the WindowsApps folder, and select Properties.
    3. Turn to Security tab and click on Advanced.
    4. Click on Change and then type Users in Enter the object name to select area.
    5. Click on OK, then click Apply > OK. You can also add the TrustedInstaller to the users list and check if it takes effect.

    However, you might be still not able to access the files. The workaround is to go inside the C:\Program Files\WindowsApps\, and repeat the same way with the Microsoft.WindowsStore* folders.
     
    S.cloris, May 5, 2019
    #2
  3. WINDOWSAPPS FILE

    Hi,

    For us to provide you an accurate resolution regarding your WindowsApps folder issue, we would like to know the following:

    • Were there any updates made on your computer prior to this concern?
    • Send us a screenshot of your WindowsApps and WindowsAppsOld folders so that we can double check the issue.
    • When did the issue first begin?
    • What troubleshooting steps have you taken so far to resolve this?

    We look forward to your response.
     
    Michael Gall, May 5, 2019
    #3
  4. jkteddy77 Win User

    WindowsApps not able to be deleted...

    Deleting the WindowsApps folder on secondary drive?


    Hmm, which is faster. I attempted a Live Linux Drive already but it was very slow and would not boot, not to mention I don't know a thing about using linux.

    Would option 2 be easier? I looked at Macrium, but the install steps themselves are confusing me, and I fear not knowing how to navigate it once I boot to it.

    EDIT: I installed Macrium Reflect Free, went through these steps to create the media.
    Don't forget to check the UEFI/MBR box if you are attempting this yourself.
    I then booted to it, "browsed my files for an image", but for real, navigate to the WindowsApps folder on your secondary drive, and delete it. It doesn't disappear instantly, but when you exit the drive, and log back into windows, the folder will be gone.

    Thanks for the suggestion cereberus!
     
    jkteddy77, May 5, 2019
    #4
Thema:

WindowsApps not able to be deleted...

Loading...
  1. WindowsApps not able to be deleted... - Similar Threads - WindowsApps able deleted

  2. How to go about deleting WindowsApps folder?

    in Windows 10 Support
    How to go about deleting WindowsApps folder?: I installed forza on my games drive and after uninstalling it I still have Windowsapps and WpSystem, Wpsystem just doesn't respond when I try to delete it and Windowsapps tell me I don't have permission. Anyway I can go about deleting these? 131125
  3. Not able to delete useless files from windowsapp folder

    in Windows 10 Network and Sharing
    Not able to delete useless files from windowsapp folder: Hey, I was just cleaning up my C: drive when I came across the windowsapps folder (i am using TreeSize) it showed that the windowsapps folder nearly took 12 gb of my C drive and the biggest file is some random game called dungeon hunter (1.86 gb) i have never played this...
  4. Can't Delete Windowsapp folder

    in Windows 10 Network and Sharing
    Can't Delete Windowsapp folder: I install my windowsapp games on a separate hard drive. After reinstalling windows, I am no longer able to access or delete this folder. Most of the drive is being used by files and folders I CANNOT format or delete. So formatting the drive is not an option. I have tried...
  5. How to delete WindowsApps?

    in Microsoft Windows 10 Store
    How to delete WindowsApps?: Hi, I want to remove WindowsApps folder from the root of my secondary hard drive. I safely uninstalled everything related with Xbox or Microsoft Store but the folder remains....
  6. app not able to be deleted

    in Windows 10 Network and Sharing
    app not able to be deleted: Cannot delete NCP Internet Transporter app from Windows 10. Error message denies access to delete. https://answers.microsoft.com/en-us/windows/forum/all/app-not-able-to-be-deleted/c4bca92b-dfcf-48a9-bfb6-822e465f01c2"
  7. Not being able to delete.

    in Browsers and Email
    Not being able to delete.: Using Windows 10 and Windows Live Mail. I have two questions. 1. I an not able to delete some junk emails. Some junk mail delete and some don't, and those that don't delete are accompanied with an error message "An unknown error has occurred." I have quite a collection of...
  8. How to delete old WindowsApps folder?

    in Windows 10 Performance & Maintenance
    How to delete old WindowsApps folder?: I have the problem below. Please help me! 1. Yesterday, I have changed Windows Apps Installation Drive to E: -> Windows 10 created WindowsApps on E: -> I have changed back to C: but WindowsApps folder still exist on E: -> I can not deleted that folder. 2. I reset the...
  9. WindowsApps folder can't be deleted on secondary disk

    in Windows 10 Support
    WindowsApps folder can't be deleted on secondary disk: I have an SSD (This PC) for Windows, HDD (secondary disk) for files and whatnot. Running Windows 10 64-bit Home. I saw that you could move apps to another disk through Apps & features in Settings, so I decided to try it out. I moved an app to my secondary disk, and it...
  10. Deleting the WindowsApps folder on secondary drive?

    in Windows 10 Support
    Deleting the WindowsApps folder on secondary drive?: I set the Storage option for Windows Store to start installing apps too my D:/ Because of that, it created a folder called WindowsApps. Now it's time that I want to delete that folder, and all access is denied. I tried changing the permissions to my admin account and...