Windows 10: DRIVER_IRQL_NOT_LESS_OR_EQUAL (storahci.sys) - Bootloop Lenovo X201

Discus and support DRIVER_IRQL_NOT_LESS_OR_EQUAL (storahci.sys) - Bootloop Lenovo X201 in Windows 10 BSOD Crashes and Debugging to solve the problem; Hi All, As the title states, my Lenovo x201 (windows 7 professional upgraded to windows 10) encountered this error after I plugged in an old SD card... Discussion in 'Windows 10 BSOD Crashes and Debugging' started by 996c4s, Aug 28, 2016.

  1. 996c4s Win User

    DRIVER_IRQL_NOT_LESS_OR_EQUAL (storahci.sys) - Bootloop Lenovo X201


    Hi All,

    As the title states, my Lenovo x201 (windows 7 professional upgraded to windows 10) encountered this error after I plugged in an old SD card via USB to look at some old pictures. My system froze up and now I cannot access anything. It gets to "Preparing Automatic Repair," then "Diagnosing your PC," when trying to boot. After that I see the error on a blue screen.

    I do not know how to access safe mode in Windows 10 successfully without being able to boot into the system. I have tried shutting off the laptop 2 or 3 times in a row when the Windows logo appears to try and force it into Windows Recovery, but no luck.


    Any other suggestions for booting into safe mode? How would someone go about this?
    Thank you in advance.

    :)
     
    996c4s, Aug 28, 2016
    #1
  2. Ritp Win User

    driver_irql_not_less_or_equal (storahci.sys)

    What kind of response is this from Microsoft,

    I should buy a mac book now
     
  3. i.coward Win User
    driver_irql_not_less_or_equal (storahci.sys)

    Hi,

    So I have been getting the BSOD error in the title of this question. It doesn't seem to be incredibly uncommon across all versions of Windows, however all of the suggested solutions require me to actually log in to Windows, or at least get the computer booted
    before I can analyse the problem further.

    I thought I might hit up the community for some help.

    The Windows install is a clean install of Enterprise (MSDN key) on an MSI GS60 Ghost (4k) Laptop on a 128GB M.2 SSD.

    I am unable to enter the BIOS GUI using F8 (it never registers that I want to and continues to the BSOD), and hitting F12 with (or without) the original USB stick with the bootable install on it results in a 'no media present' error (albeit about 1/2mm in
    height because of the screen resolution!) If I let it attempt to boot, I see two windowed consoles quickly flash up before the BSOD rears its ugly smiley.

    If I was able to enter the BIOS, I would force install/repeair off the USB - I am open to wiping the install and attempting a driver fix. If I could get the boot menu I would try safe mode. But neither of these is possible at the moment.

    Is there any way that I may be able to force entry into BIOS, or to use the bootable USB in a non-conventional manner?

    Is there anything that anyone in the community may suggest?

    Now, it is also entirely possible that there is a hardware issue, as the computer did suffer from a drop a couple of months ago, and possibly something is loose. I have pulled it apart and played with most connections, but if it is possible that a loose
    connection could be the root cause I will look into that again (and indeed, if I don't have an answer to getting into the boot menu or bios by the time I finish work today, I will be opening it up). Could it possibly be a damaged hard drive and replacing it
    would solve all my woes.

    Any suggestions would be greatly appreciated. Once I get past the BSOD I can try the other suggestions for the driver_irql_not_less_or_equal error.

    edit: I should note that it has been working fine for a few weeks now and only stopped yesterday.

    Thanks!
     
    i.coward, Aug 28, 2016
    #3
  4. philc43 Win User

    DRIVER_IRQL_NOT_LESS_OR_EQUAL (storahci.sys) - Bootloop Lenovo X201

    philc43, Aug 29, 2016
    #4
  5. 996c4s Win User
    Thank you!

    So my problem is that Windows does not boot into the Recovery screen at all. It just keeps on going with the bootloop.
     
    996c4s, Aug 29, 2016
    #5
  6. philc43 Win User
    philc43, Aug 29, 2016
    #6
  7. 996c4s Win User
    996c4s, Aug 29, 2016
    #7
  8. 996c4s Win User

    DRIVER_IRQL_NOT_LESS_OR_EQUAL (storahci.sys) - Bootloop Lenovo X201

    Update:

    So I got into a bootable system using the Bootable Rescue Disk. I deleted the MS AHCI Driver and Reinstalled it (the lenovo intel driver), and still no luck. I am have tried accessing safe mode with many different ways (Solved Attn. SSD owners - Enabling AHCI mode AFTER Windows 10 installation. - Windows 10 Forums) and etc.

    Now the normal recovery option comes up with Windows 10. I go to Troubleshoot>advanced options>startup settings and it boots to the safemode menu. I clock the normal safemode option, and the bootloop still continues.

    For some reason, I cannot get into safemode, BUT I can boot into the recovery drive. I just don't know what to do from there. I can see my SSD with all of my files, which is good lol.
     
    996c4s, Apr 5, 2018
    #8
Thema:

DRIVER_IRQL_NOT_LESS_OR_EQUAL (storahci.sys) - Bootloop Lenovo X201

Loading...
  1. DRIVER_IRQL_NOT_LESS_OR_EQUAL (storahci.sys) - Bootloop Lenovo X201 - Similar Threads - DRIVER_IRQL_NOT_LESS_OR_EQUAL storahci sys

  2. DRIVER_IRQL_NOT_LESS_OR_EQUAL (CH341S64.SYS)

    in Windows 10 Drivers and Hardware
    DRIVER_IRQL_NOT_LESS_OR_EQUAL (CH341S64.SYS): Been having some issues with bluescreens lately. It appears to be related to Arduino drivers and software related to controlling a relay through it. The problem is the bluescreen screen hangs at 100% complete, so there is no dump file to be found. I did enable...
  3. BSOD DRIVER_IRQL_NOT_LESS_OR_EQUAL L1C63x64.sys

    in Windows 10 BSOD Crashes and Debugging
    BSOD DRIVER_IRQL_NOT_LESS_OR_EQUAL L1C63x64.sys: Hi, since a month or two I'm getting this BSOD while streaming with OBS https://drive.google.com/open?id=1Rah2ipKpSC85ao5wmyxu3I6peK5DOhyj DMP File...
  4. BSOD L1C63x64.sys / Driver_IRQL_Not_LESS_OR_EQUAL

    in Windows 10 BSOD Crashes and Debugging
    BSOD L1C63x64.sys / Driver_IRQL_Not_LESS_OR_EQUAL: Hello, recently i have been having some blue screens usualy while streaming, usualy after 1 hour passed but not always, sometimes it last 3 hours some times less than 1 tried stressing the processor but it didnt made a blue screen. Someone have any idea? I attach the BSOD...
  5. Windows 10 Lenovo Notebook bootloop?

    in Windows 10 BSOD Crashes and Debugging
    Windows 10 Lenovo Notebook bootloop?: Hey guys, about 2 weeks ago i turned my Lenovo YOGA 510-14AST (8 GB RAM) off by pressing the power off button. Since then my laptop is stuck in a bootloop. The Lenovo logo pops up and you can see the loading ring. 5 seconds later the Lenovo logo disappears but ring stays...
  6. BSOD Driver_IRQL_NOT_LESS_OR_EQUAL L1C63x64.sys

    in Windows 10 BSOD Crashes and Debugging
    BSOD Driver_IRQL_NOT_LESS_OR_EQUAL L1C63x64.sys: Hello So for the past couple of months I've been using my work phone to tether for my internet and no problems. I have to give it back soon so I'm back to using Comcast (shudder) which means I'm back to using my ethernet which is when all this started happening. I've...
  7. DRIVER_IRQL_NOT_LESS_OR_EQUAL Wdf01000.sys windows 10 help

    in Windows 10 BSOD Crashes and Debugging
    DRIVER_IRQL_NOT_LESS_OR_EQUAL Wdf01000.sys windows 10 help: I have recently made a new computer and am running Windows 10. I have been fine for about a week and then i started getting this BSOD with this error : DRIVER_IRQL_NOT_LESS_OR_EQUAL Wdf01000.sys. I think I am doing this correctly by uploading and providing these 3 dump files....
  8. BSOD DRIVER_IRQL_NOT_LESS_OR_EQUAL (L1C62x64.sys)

    in Windows 10 BSOD Crashes and Debugging
    BSOD DRIVER_IRQL_NOT_LESS_OR_EQUAL (L1C62x64.sys): hello i have a driver problem and its pointing to L1C62x64.sys the driver from the qualcomm atheros AR8171/8175 PCI-E gigabit Ethernet Controller (ndis 6.20) but i dont know how to fix it or if it realy is that driver. before windows 10 my pc was windows 7 home premium....
  9. Persistent BSOD: driver_irql_not_less_or_equal L1C63x64.sys

    in Windows 10 BSOD Crashes and Debugging
    Persistent BSOD: driver_irql_not_less_or_equal L1C63x64.sys: I've been having the same BSOD for the last few months. I haven't noticed a pattern about when it crashes, I tried to use the program Driver Booster 3 to update everything but clearly isn't a solution like I hoped. Since it started happening I've done both a system restore...
  10. DRIVER_IRQL_NOT_LESS_OR_EQUAL in L1C634x64.sys

    in Windows 10 BSOD Crashes and Debugging
    DRIVER_IRQL_NOT_LESS_OR_EQUAL in L1C634x64.sys: Hello, I just started getting BSODs with the error "DRIVER_IRQL_NOT_LESS_OR_EQUAL in L1C634x64.sys". I've tried updating the driver on my 'Qualcomm Atheros AR8131 PCI-E Gigabit Ethernet Controller (NDIS 6.30)", both automatically and via the Atheros website. They only show...